Check Charging System - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-23-2016, 08:46 AM   #1
Registered User
Newbie
 
Join Date: May 2016
Location: Haledon
Region: New Jersey
Posts: 9
Exclamation Check Charging System

I have a 2005 Mustang GT with 127,000 miles. I had a Pioneer touch-screen stereo installed by Best Buy in February. On 5/14, i was in the car with it running and i changed a setting on the EQ for the stereo and about 3 minutes later, the check charging system/battery light came on, the dome lights went dim, the stereo shut off, windows/locks wouldn't work and the car just died on me. I couldn't get it to start again. I did some research and came to the conclusion that i needed an alternator (i think was wrong) i installed the alternator Thursday, 5/19 and got the car to start. The next morning, on my way to work, everything seemed fine but the "check charging system" / battery light flashed on a couple of times then off. I made it to work, but didn't make it home afterwards. The car died on me, again. I went to the nearest Walmart and bought a battery this time, and even that barely got me home. Finally, i took it to a mechanic on Saturday, and he ran all of his tests and said everything was fine and the only thing he could THINK of is the ECM is fried. I don't trust mechanics and before I spend/waste any more money, I was hoping someone might have had a similar problem and a solution? PLEASE HELP
Joel28 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-23-2016, 09:58 AM   #2
Registered Member
Regular
 
nickysixx's Avatar
 
Join Date: Apr 2011
Location: Boonton
Region: New Jersey
Posts: 634
weird issue, did your mechanic print out the code slip so we can see a sample of it?
__________________
____________________________________________
1957 Buick Special Estate Wagon
1996 Mustang GT (sold)
1997 Mustang V6 (sold)
2002 Jeep Grand Cherokee Laredo (sold)
2007 Jeep Grand Cherokee
nickysixx is offline   Reply With Quote
Old 05-23-2016, 10:10 AM   #3
Registered User
Newbie
 
Join Date: May 2016
Location: Haledon
Region: New Jersey
Posts: 9
This is what i got from the mechanic..

Transmission - Memory Codes

P0689 - PCM Power Relay Sense Circuit Low
P1000 - OBDII System Checks Incomplete

Antilock Brakes - Memory Codes

C1233 - Left Front Wheel Speed Sensor Input Missing
C1234 - Right Front Wheel Speed Sensor Input Missing
B1318 - Low Battery Voltage at Module
B1317 - High Battery Voltage at Module
U1900 - ABS CAN Communication BUS Fault

Instrument Cluster Module - Memory Codes

U1900 - ABS CAN Communication BUS Fault
Joel28 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-23-2016, 11:20 AM   #4
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
I wonder if it's just coincidence and the radio may/may not have anything to do with it. You need to try and get your mechanic to log what he's done and look at the radio install mayhap disconnect the radio or at least fuse to it. I would also consider talking (email for paper trail) to Best buy
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 05-23-2016, 12:24 PM   #5
Registered User
Newbie
 
Join Date: May 2016
Location: Haledon
Region: New Jersey
Posts: 9
Quote:
Originally Posted by Strange Mud View Post
I wonder if it's just coincidence and the radio may/may not have anything to do with it. You need to try and get your mechanic to log what he's done and look at the radio install mayhap disconnect the radio or at least fuse to it. I would also consider talking (email for paper trail) to Best buy
I will definitely try this when i get home. Question: If i disconnect the fuse/stereo and it still doesn't work, would it be right to say the ECM is done-time for a new one? I've seen a lot of conversations regarding the same issue that seemed to never be resolved.
Joel28 is offline   Reply With Quote
Old 05-23-2016, 12:32 PM   #6
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
not a clue...it is a way to test if it's the cause.
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 05-24-2016, 08:42 AM   #7
Registered User
Newbie
 
Join Date: May 2016
Location: Haledon
Region: New Jersey
Posts: 9
Quote:
Originally Posted by Strange Mud View Post
not a clue...it is a way to test if it's the cause.
So i took the fuse out for the stereo and still, the Check Charging System / Battery light comes on. I don't know what to do and i really don't want to waste my money on the ECM if that isn't the issue. Any other suggestions?
Joel28 is offline   Reply With Quote
Old 05-24-2016, 09:10 AM   #8
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
Check battery voltage car off should be 12.6 or so. running should be 13.6-14.6

does it start/run? If not will it start/run with a jump or charged battery? tighten all battery connections
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 05-24-2016, 09:15 AM   #9
Registered User
Newbie
 
Join Date: May 2016
Location: Haledon
Region: New Jersey
Posts: 9
Quote:
Originally Posted by Strange Mud View Post
Check battery voltage car off should be 12.6 or so. running should be 13.6-14.6

does it start/run? If not will it start/run with a jump or charged battery? tighten all battery connections
I had the battery fully charged when i went to the mechanic and that got me home (only about 2 miles from home) i started it yesterday after pulling the fuse and it started no problem but i'm pretty sure its cause the batter is still fully charge and if i let it run / drove it, it'd die on me once the battery drains. The mechanic checked all of the voltages and said everything checked out. He says he's a "technician", but again, i don't want to buy the ECU and still have the same problem / get stuck with paying more money looking for the problem.
Joel28 is offline   Reply With Quote
Old 05-24-2016, 09:23 AM   #10
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
check voltage running...
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 05-24-2016, 09:43 AM   #11
Registered User
Newbie
 
Join Date: May 2016
Location: Haledon
Region: New Jersey
Posts: 9
Quote:
Originally Posted by Strange Mud View Post
check voltage running...
He did. He said that was good too.
Joel28 is offline   Reply With Quote
Old 05-24-2016, 10:55 AM   #12
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
idk what to suggest next, except many of the large auto parts stores will check batteries/alts for free
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 05-24-2016, 12:53 PM   #13
Registered User
Newbie
 
Join Date: May 2016
Location: Haledon
Region: New Jersey
Posts: 9
Quote:
Originally Posted by Strange Mud View Post
idk what to suggest next, except many of the large auto parts stores will check batteries/alts for free
One last question: Could you tell me where / what to look for in regards to the ECU? That mechanic said 961 but I've seen 350 and 450. What should the price range be?
Joel28 is offline   Reply With Quote
Old 05-24-2016, 01:14 PM   #14
Registered Member
Regular
 
wmschoonover's Avatar
 
Join Date: Mar 2016
Location: Owensboro
Region: Kentucky
Posts: 562
If the alternator tested good
And the battery tested good
You can drive until the battery dies...

The alternator is supposed to charge the system... Could the cables from the alternator to the battery be corroded or damaged and while putting out the power, it just can't get to the battery?


Sent from my iPhone using Mustang Evolution
wmschoonover is offline   Reply With Quote
Old 05-24-2016, 01:14 PM   #15
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
idk, i'll say mechanics get to mark up the price but then if it fails they should give you some wtty.
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 05-25-2016, 07:50 AM   #16
Registered User
Newbie
 
Join Date: May 2016
Location: Haledon
Region: New Jersey
Posts: 9
Quote:
Originally Posted by wmschoonover View Post
If the alternator tested good
And the battery tested good
You can drive until the battery dies...

The alternator is supposed to charge the system... Could the cables from the alternator to the battery be corroded or damaged and while putting out the power, it just can't get to the battery?


Sent from my iPhone using Mustang Evolution
I'm hoping that's it, going to check the cables today since its not raining. From what i could see just by looking down on it, the cables look fine. I'm going to have to check them more thoroughly when i get home.
Joel28 is offline   Reply With Quote
Old 05-25-2016, 08:11 AM   #17
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
you need to check with wrench (disconnect battery 1st)
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 05-25-2016, 08:53 AM   #18
Registered Member
Regular
 
nickysixx's Avatar
 
Join Date: Apr 2011
Location: Boonton
Region: New Jersey
Posts: 634
Quote:
Originally Posted by wmschoonover View Post
If the alternator tested good
And the battery tested good
You can drive until the battery dies...

The alternator is supposed to charge the system... Could the cables from the alternator to the battery be corroded or damaged and while putting out the power, it just can't get to the battery?


Sent from my iPhone using Mustang Evolution
No, this was eliminated at the mechanics while using a multimeter... a simple voltage test while it says check charging system would eliminate that. Visual inspections on the ground would be the only other thing.
Odd issue..
Not sure what you mean by what you said Strange mud?
__________________
____________________________________________
1957 Buick Special Estate Wagon
1996 Mustang GT (sold)
1997 Mustang V6 (sold)
2002 Jeep Grand Cherokee Laredo (sold)
2007 Jeep Grand Cherokee
nickysixx is offline   Reply With Quote
Old 05-25-2016, 09:16 AM   #19
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
make sure connections are clean and tight.....poor connections will pass the low current of a meter but not enuf amperage to do anything in the real world.

call me Mud
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Charging System forceflow2 2011-2014 V6 Mustang 8 02-29-2016 05:33 AM
Check Charging System rpstrickland 2005-2010 Mustang GT 11 02-18-2014 02:30 PM
Check Charging System Torchredfrankie 2005-2010 Mustang GT 8 11-04-2013 06:23 PM
Check charging system? mmigliore 2005-2010 Mustang GT 4 05-17-2013 10:57 PM
traction control, check charging system, and a/c acting up 07regency 2005-2010 Mustang GT 7 08-28-2012 02:22 PM

» Like Us On Facebook



07:54 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.