07 that stalls and Dies - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-23-2017, 12:03 AM   #1
Registered User
Newbie
 
OrangeGrabberGT's Avatar
 
Join Date: Nov 2017
Location: Roy
Region: Utah
Posts: 1
07 that stalls and Dies

Hey everyone,

I hope everyone is well and Happy Thanksgiving. So I need some direction. I am new to the SN197 body style with previous hand wrench time on a 1996 GT 4.6. So there are a lot of changes with this care which are different from my previous vehicle. So the other day, as I backed my car in, it began to stumble and stall. I got it in the garage and pulled the code. It showed. P0191 Fuel Pressure Sensor. It refused to start up. I did get it started several minutes later and then shut it off for the night. The next day, I took it to go get the part from the dealer only for the car to die just down the street less than a mile an half later and would not start. I got it pushed into a parking lot and had family take me to get the fuel pressure sensor. I swapped the part out and vehicle started and purred like new. I drove it back towards home. Within two turns, the vehicle acted like it lost power and only pushing in the clutch seemed to keep it momentarily from dying. I was able to limp it around the corner home and pull it into the driveway before it died. I am at a total loss what has happened to it. It began after filling up with a full tank of gas (91) three days ago. Not sure where to begin with this car. I am at a loss guys. This last time of it dying threw no codes. I plan to check grounds, and fuel filter, add heat to the gas to pull water from the fuel, and spray the MAF sensor. Fuel pumps have less than 8k on them and are the double pump setup from the GT500.

Is there anything that is common with this year to check besides the fuel pressure sensor which I replaced today? Car runs a Roush TVS Phase 2 with less than 8k on it as well.
OrangeGrabberGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-23-2017, 11:27 PM   #2
Registered Member
Regular
 
Join Date: Nov 2017
Location: bullhed city
Region: Arizona
Posts: 23
I would begin by checking if there is fuel pressure at the fuel rail. Was that a Fuel Pressure AND Temperature Sensor you replaced? Does it have an electrical connector on it, or not?

Aside from fuel, do you have spark?
65 k car is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Car still stalls. rollo1987 1996-2004 Mustang GT 37 09-07-2014 02:00 PM
Need help car still stalls. rollo1987 1996-2004 Mustang GT 20 08-06-2014 07:12 PM
Stalls on second StangLife209 1996-2004 Mustang GT 0 07-27-2014 10:09 PM
stalls after warm up captain78 1979-1995 Mustang GT 3 03-13-2013 02:12 PM
stalls when decelerating 2003stangmachI 1996-2004 Mustang GT 1 11-11-2009 09:17 AM

» Like Us On Facebook



12:13 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.