Upgrade headlights on 68 - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-27-2012, 04:33 PM   #1
Registered Member
Regular
 
LukeRailey68's Avatar
 
Join Date: Dec 2011
Location: Owens Cross Roads
Region: Alabama
Posts: 244
Upgrade headlights on 68

My right headlight is dimming in and out so I think it's time for an upgrade. Has anyone else bought new lights? Did you buy h4's and/or halogens? I'm looking for a pair that will plug right in and I don't want to invest in some expensive ones that constantly need replaced. I might end up going with stock replacements. Suggestions and reviews is what I'm looking for. Thanks
LukeRailey68 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-27-2012, 05:08 PM   #2
Registered Member
Regular
 
IanM's Avatar
 
Join Date: Nov 2012
Location: Pickerington, Ohio
Region: Ohio
Posts: 223
Quote:
Originally Posted by LukeRailey68 View Post
My right headlight is dimming in and out so I think it's time for an upgrade. Has anyone else bought new lights? Did you buy h4's and/or halogens? I'm looking for a pair that will plug right in and I don't want to invest in some expensive ones that constantly need replaced. I might end up going with stock replacements. Suggestions and reviews is what I'm looking for. Thanks
Have you taken them out and checked your connections? I had similar issues with another vehicle, took them apart, cleaned the connections really well, and it fixed the issue. Might take a bit of work, but you may not have to spend a lot to fix it. Just my 2 cents.
IanM is offline   Reply With Quote
Old 11-27-2012, 05:27 PM   #3
Registered Member
Regular
 
LukeRailey68's Avatar
 
Join Date: Dec 2011
Location: Owens Cross Roads
Region: Alabama
Posts: 244
You're right. I researched more and on a forum a guy had the same problem with one light going in and out. One person suggested the ground wire being bad. My ground wire is right in the front so I checked it and it was very loose so I assume that's the solution.
LukeRailey68 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-27-2012, 08:53 PM   #4
Registered Member
Regular
 
Tyoung68's Avatar
 
Join Date: Jun 2011
Location: concord
Region: California
Posts: 3,475
I put in hids they are plug and play the kit comes with everything you need all. I think it was in the 150-200 $ range i cant remember forsure
Tyoung68 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:58 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.