I have a high performance Mustang and my starter doesn't work, any suggestions? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-22-2009, 03:00 PM   #1
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 48
I have a high performance Mustang and my starter doesn't work, any suggestions?

I have '66 Mustang V8, high performance 289. I have Long Heddman headers, and a C4 transmission. I have tried the original starter, a new OEM starter, and a gear reduction high torque starter and none of them have worked. When I turn the car to start, the starter just "clicks". I know it's not the neutral safety switch, since it not only happened when the car was on Park, but also on Neutral. I checked the battery and it was charged. The alternator and ignition switch have all passed inspection. Any suggestions?
breandan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-22-2009, 03:48 PM   #2
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 39
I have a high performance Mustang and my starter doesn't work, any suggestions?

check your starter solenoid. Thats usually what is wrong when all you hear is the clicking sound.
imported_dallas is offline   Reply With Quote
Old 08-22-2009, 04:02 PM   #3
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 44
I have a high performance Mustang and my starter doesn't work, any suggestions?

Did You try dirict wiring to the starter? (Jumping it). Have you tryed to Jump Start the car?
You could have a bad selonid, and you are not getting enough voltage to the starter, (Jump the selonid) You could have the starter jambed aganist the fly wheel causing it to bind (on some models you have to shim the starter away from the flywheel).
derrik is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-22-2009, 04:29 PM   #4
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 30
I have a high performance Mustang and my starter doesn't work, any suggestions?

You have a bad starter solenoid. An easy fix for your motor. Located on the fender well right behind the battery if it's still in the stock location. The hotwire from the battery hooks directly to it. Been awhile since I bought one but the last one I bought was for a '66 Fairlane with a 302 and it was about $10.00. Same part.
bourke is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:44 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.