Gas pedal locked up? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-24-2009, 05:15 AM   #1
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 46
Gas pedal locked up?

ok i was driving and all of a sudden i notices it was going 40mph and i wasn't pressing the gas pedal. so i pulled it over and turned it off and i tried to press down the gas pedal and it wouldn't move i didn't press it super hard cus i didn't want to break it. i opened the hood and i could still move the thang that is hooked up to the gas pedal sorry i don't know what its called. its a 1976 mustang cobra II with a 3.0 v8 (i think..lol)
thanks.
booth is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-24-2009, 06:12 AM   #2
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 51
Gas pedal locked up?

Two possibilities, -- one is that the "throttle cable" - which is several strands of wire has "shredded out" inside the cable shield, and jammed!

The other is that you don't have good ground from engine (or minus of battery) to frame. And cable was good enough ground (that power was flowing through it to ground), -- however if current gets high enough (and possibly several strands of cable broken alredy),- you had enough curent flow to heat the cable up "cherry red" and melt into the shield and now it will not move!

Since electricity (power + amps) will flow through the easiest path,--- and if body not grounded to battery -- it will not have normal "provided path" available -- so it will find another!

Even if the cable is broken --the remedy is the same, -- put in new throttle cable! Just make sure and check grounding (to make sure it is not that ), so it won't happen again!
lorren is offline   Reply With Quote
Old 08-24-2009, 06:58 AM   #3
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 36
Gas pedal locked up?

you need to check the cable that is attached to the pedal and see if it is caught up on somthing or got kinked that the only thing i can think of right off hand
albion is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



08:05 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.