No spark from my 1966 mustang? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-21-2011, 03:15 AM   #1
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 51
No spark from my 1966 mustang?

change the points, coil, plugs and wires, it cranks but no spark
westbroc12 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-21-2011, 03:27 AM   #2
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 42
No spark from my 1966 mustang?

Are the points gaped to 0.015 inch ? be sure and use new points and condensor...trying to file the points is a waste of time and don't forget the rotor..... make sure you have the proper firing order and in time......

did you check compression? if it's been sitting for a while, add a little light oil or wd40 down the carb to help seal the rings and build compression..
colton is offline   Reply With Quote
Old 12-21-2011, 03:45 AM   #3
Registered User
Newbie
 
Join Date: Jul 2011
Posts: 6
No spark from my 1966 mustang?

when you change the points,coil,wires .....there is no mention of setting to # 1 TDC Go back and do set it at # 1 TDC Then at that THE rotor should point genarally to 1 (rotor)Now have friend slowly turn the crank sahft AS you watch the points travel on the high points and back to the low points at the same time watch the rotorwhen there is a spark some adjustment is well going to be in the Distributor cap bye
Channon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-21-2011, 03:50 AM   #4
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 39
No spark from my 1966 mustang?

Did you replace the "Condenser"? That's an important part of the ignition system too. Read below for hints at problem.

http://www.familycar.com/Classroom/ignition.htm
pueblo70 is offline   Reply With Quote
Old 12-21-2011, 04:33 AM   #5
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 44
No spark from my 1966 mustang?

check the distributor if you had it out it could be 180 degree out.
fahyim is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs

Tags
1966 mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:17 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.