C4 - Slipping and Gurgling - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-30-2017, 11:23 AM   #1
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
C4 - Slipping and Gurgling

It slips in D and doesn't want to shift to 2 until it really warms up, then it doesn't want to go into 3, but eventually does. Reverse barely works.
So I changed the filter and fluid. Fluid mostly red/orange and some gray sludge in pan (not too bad - no shavings). I got 6 1/2 quarts out and put in about the same.
Now reverse barely engages cold and warms up to not work at all. D is about the same as before the fluid change.
There is a gurgling sound when in P and revving the engine, which sounds like it's coming from the bell housing area when inside the car. Which would indicate that it's low on fluid, but it's fine on the dipstick when warmed up.
The C4 was rebuilt as stock 3 years ago at a local trans shop.
289 probably low 300's HP / 9 inch posi 3.50. The rear end was a swap from the stock 8 about 4 months ago.
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-30-2017, 11:01 PM   #2
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,576
If I have to guess, I'd say that the transmission is not building enough fluid pressure to function properly.
Every time that I have removed the pan on an automatic transmission lately, the bolts have become loose on the valve body. I've even found one or two laying in the bottom of the pan!
Possibly, something similar has happened to your transmission.
straybullitt is offline   Reply With Quote
Old 08-31-2017, 01:13 PM   #3
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
Thanks. I'll check that. I think I'm going to flush it.


Chevy runs deep, don't step in Chevy.
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-15-2017, 10:37 AM   #4
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
I decided not to spend any more time or cash on this trans. I ordered a TCI Streetfighter, but it's still a week or two out. So I thought I would try to get the old one driveable until then. Added a half can of Sea Foam and drove about 20 miles. Seemed a little better, but still would not go into 3 and Reverse barely worked. I went to back into the garage since R didn't work and now it moves forward in R N D 2 1. I had to turn off the engine in order to back down the driveway. I guess the whole thing is just fried at this point.
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Classic Mustangs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gurgling with O/R Hpipe martinez8191 2011-2014 V6 Mustang 3 11-18-2015 02:04 PM
Slipping jpsgtcs 2005-2010 Mustang GT 3 05-22-2015 08:58 PM
clutch slipping? satin06silver 2005-2010 V6 Mustang 8 08-15-2013 08:56 AM
89 clutch slipping.? Vazqueza90 1979-1995 Mustang GT 2 05-11-2013 04:33 PM
Starting Issue (Gurgling) Davo_281GT 2005-2010 Mustang GT 7 03-22-2013 01:18 PM

» Like Us On Facebook



03:59 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.