AC problems? - Mustang Evolution

Go Back   Mustang Evolution > Off Topic Forums > General Car Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-25-2011, 10:13 PM   #1
Registered Member
Regular
 
03stang03's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 22
AC problems?

Well..I was driving today and suddenly noticed the temperature gauge meter was almost on the red line, I also noticed that my air conditioning wasn't blowing out cold air anymore. Anyone know what this could be? I figured i either need more freeon, or my AC clutch is going out.
03stang03 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-25-2011, 11:31 PM   #2
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Re: AC problems?

Quote:
Originally Posted by 03stang03 View Post
Well..I was driving today and suddenly noticed the temperature gauge meter was almost on the red line, I also noticed that my air conditioning wasn't blowing out cold air anymore. Anyone know what this could be? I figured i either need more freeon, or my AC clutch is going out.
Was the car overheating? How many miles? Have you checked the coolant to make sure its there?

I'd say you probably need a new water pump, or a new thermostat.
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 08-25-2011, 11:38 PM   #3
Registered Member
Regular
 
Otlaw80's Avatar
 
Join Date: May 2009
Region: Illinois
Posts: 504
Re: AC problems?

Could be a cooling fan issue. Obviously if it's not working the car will over heat. Also if its not pulling air through the condenser for the A/C it won't blow as cold of air. Start it up and let it run for 10-15 min, see if the fan kicks on.
__________________
1986 GT T-Top. Driving Project
Otlaw80 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-28-2011, 01:39 AM   #4
Registered Member
Regular
 
03stang03's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 22
Yeah the fluids in the car are fine. But when the fan kicks on it makes this knocking noise like it's hitting something while it's spinning
03stang03 is offline   Reply With Quote
Old 08-28-2011, 09:59 PM   #5
Registered Member
Regular
 
03stang03's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 22
My fan is broken
03stang03 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Off Topic Forums > General Car Discussion

« Hood | My ride! »
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cooling problems dreamstang 1979-1995 Mustang GT 62 09-13-2011 05:19 AM
84' Tranny problems 16218 1979-1995 Mustang GT 13 08-21-2011 01:59 PM
little problems in the fox. 82stang224 1979-1995 Mustang GT 10 07-29-2011 07:11 PM
Y2k v6 idle problems 6Banger2000 2005-2010 V6 Mustang 4 07-22-2011 08:10 AM
Different Starting Problems milkrun49 2011-2014 Mustang GT 3 07-15-2011 03:19 PM

» Like Us On Facebook



01:12 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.