Please will you help me with my HID's and Ballast - Mustang Evolution

Go Back   Mustang Evolution > Off Topic Forums > General Car Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-25-2012, 12:58 AM   #1
Evolution's Finest
Supporter
 
SCCofSV's Avatar
 
Join Date: Mar 2012
Location: Burbank,Well, Close enough!
Region: California
Posts: 366
Please will you help me with my HID's and Ballast

I had a HID Conversion kit (Plug & Play System) installed on my car in April 2012.
H13 Xenon Bulbs w/ 35w Digital Std. Ballast.
This was done by a friend of a friend. For the first couple of months I had a problem with one of the bulbs not coming on. I'd have to turn the light switch a couple of times before both lights would work! After speaking to other people I found out this was not normal as I was told! He had me check the ballast first by switching them. It didn't work! He came by picked bulbs and both ballast up to return and get a new set!! He comes back hooks everything back up all is working for a couple of weeks then it all started all over again but now, he can't be reached!!

Here's where you come in or at least I hope!
I just switched both ballast and still the light does not work, i examined the bulb but still can't tell if its burned out? And i don't know how to remove the D*** bulb from plug not the housing assembly or is the one piece? If you need photos of what im talking about, i will take them in the morning and post them! Help!! please me!
Thank you! Sorry about the novel in the beginning!
SCCofSV is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-25-2012, 01:33 AM   #2
Registered Member
Regular
 
gregtommy's Avatar
 
Join Date: Jul 2011
Region: Washington
Posts: 1,462
Send a message via AIM to gregtommy Send a message via Skype™ to gregtommy
Please do take photos a friend of mine has a similar problem except when he hits the ballast it kicks on occasionally
__________________
MOTM DEC 2011
Base SC Dyno 595rwhp/493rwtrq
Refined Tune 608rwhp/504rwtrq


Mustang history started with a 2000 v6, 2003 GT, 2007 GT, 2011 GT, all Black(coincidence)
gregtommy is offline   Reply With Quote
Old 08-25-2012, 02:36 AM   #3
Evolution's Finest
Supporter
 
SCCofSV's Avatar
 
Join Date: Mar 2012
Location: Burbank,Well, Close enough!
Region: California
Posts: 366
Re: Please will you help me with my HID's and Ballast

gregtommy
Mine did as well or if I turn or on and off a few or a biunch of times. It would eventually start but, not any more. I also just found out that the worst thing you can do. I'm beginning to feel like a complete failure. I will take photos and post in the am.
SCCofSV is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-25-2012, 05:40 AM   #4
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Sounds like it's time to ditch the illegal hid's. The headlights on all of my cars come on with no issues..
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 08-25-2012, 09:19 AM   #5
Registered Member
Regular
 
gregtommy's Avatar
 
Join Date: Jul 2011
Region: Washington
Posts: 1,462
Send a message via AIM to gregtommy Send a message via Skype™ to gregtommy
Quote:
Originally Posted by SCCofSV
gregtommy
Mine did as well or if I turn or on and off a few or a biunch of times. It would eventually start but, not any more. I also just found out that the worst thing you can do. I'm beginning to feel like a complete failure. I will take photos and post in the am.
I unfortunately have only seen these things twice now and overall it looks like they bring bad luck to anyone that installs them. I can tell you that they sound like they are installed correctly if they worked to begin with but they start faulting out later on which just sounds like bad equipment.
__________________
MOTM DEC 2011
Base SC Dyno 595rwhp/493rwtrq
Refined Tune 608rwhp/504rwtrq


Mustang history started with a 2000 v6, 2003 GT, 2007 GT, 2011 GT, all Black(coincidence)
gregtommy is offline   Reply With Quote
Old 08-25-2012, 11:45 AM   #6
Evolution's Finest
Supporter
 
SCCofSV's Avatar
 
Join Date: Mar 2012
Location: Burbank,Well, Close enough!
Region: California
Posts: 366
Re: Please will you help me with my HID's and Ballast

But, which one? Or better yet, the kit he purchased for me came with two wiring harnesses. I believe one has a relay and one doesn't. Dang I wish I had the instructions!! Anyway, does anyone have knowledge of what a H13 blown bulb looks like? I've Googled it and there are no photos to at least compare... I'll go take photos so you'll know what I'm talking about! Unless someone has other suggestions!

---------- Post added at 09:45 AM ---------- Previous post was at 09:42 AM ----------

Oh!! They are from Extreme Lighting Accessories! But no website!
SCCofSV is offline   Reply With Quote
Old 08-25-2012, 12:02 PM   #7
Registered Member
Regular
 
1shotkllz's Avatar
 
Join Date: Apr 2012
Region: North Carolina
Posts: 398
Re: Please will you help me with my HID's and Ballast

Check Your connections first, wire might not be touching just right to get enough juice to light the bulb.
1shotkllz is offline   Reply With Quote
Old 08-25-2012, 02:56 PM   #8
Registered Member
Regular
 
2Greeny7's Avatar
 
Join Date: Jan 2012
Region: Connecticut
Posts: 776
Send a message via Skype™ to 2Greeny7
sounds like you need a relay to help balence the charge when you turn them on
__________________
2001 V6
CAI, SF3/X3 Tuner, 4.10 Gears, Auburn lim-slip
GT4 Rims (Summer), Stock Rims (Winter)
2 Subs, New speakers all around
1 Great Car 1 Happy Kid
July '12 Mustang of the Month
2Greeny7 is offline   Reply With Quote
Old 08-25-2012, 04:27 PM   #9
Evolution's Finest
Supporter
 
SCCofSV's Avatar
 
Join Date: Mar 2012
Location: Burbank,Well, Close enough!
Region: California
Posts: 366
I've done that multible time with no success. Last night when I switched the nonworking side ballast (drivers side) to Passenger side) I made certain everything tight. And the ballast worked and the passenger HID came on. But the drivers side did not now. So I know that both ballast are working when connected to passenger HID and not Drivers HID which now leads me to believe either the bulb is bad or wire?

After looking at the bulb I still am unable to tell! I've never seen a blown bulb. I even googled photos so as to know what to look for but, there's none. And I know of no one in the Los Angeles or surrounding areas that install these.
As for the "Relay Harness" I agree with you totally. I'm going to switch them. I know when you first turn the Headlight switch on, major amounts of power goes through the harness and ballast and ignitor to light the bulb, perhaps it burnt it out. Gosh I wish I had the instruction.
SCCofSV is offline   Reply With Quote
Old 08-26-2012, 12:25 AM   #10
Registered Member
Regular
 
2Greeny7's Avatar
 
Join Date: Jan 2012
Region: Connecticut
Posts: 776
Send a message via Skype™ to 2Greeny7
Quote:
Originally Posted by SCCofSV
I've done that multible time with no success. Last night when I switched the nonworking side ballast (drivers side) to Passenger side) I made certain everything tight. And the ballast worked and the passenger HID came on. But the drivers side did not now. So I know that both ballast are working when connected to passenger HID and not Drivers HID which now leads me to believe either the bulb is bad or wire?

After looking at the bulb I still am unable to tell! I've never seen a blown bulb. I even googled photos so as to know what to look for but, there's none. And I know of no one in the Los Angeles or surrounding areas that install these.
As for the "Relay Harness" I agree with you totally. I'm going to switch them. I know when you first turn the Headlight switch on, major amounts of power goes through the harness and ballast and ignitor to light the bulb, perhaps it burnt it out. Gosh I wish I had the instruction.
Switch the bulbs to test them! And yeah thats all ive got for an idea!
__________________
2001 V6
CAI, SF3/X3 Tuner, 4.10 Gears, Auburn lim-slip
GT4 Rims (Summer), Stock Rims (Winter)
2 Subs, New speakers all around
1 Great Car 1 Happy Kid
July '12 Mustang of the Month
2Greeny7 is offline   Reply With Quote
Old 08-26-2012, 11:58 AM   #11
Evolution's Finest
Supporter
 
SCCofSV's Avatar
 
Join Date: Mar 2012
Location: Burbank,Well, Close enough!
Region: California
Posts: 366
Re: Please will you help me with my HID's and Ballast

Quote:
Originally Posted by Greeny27 View Post
Switch the bulbs to test them! And yeah thats all ive got for an idea!
Alright, I will do that and get back to you. I want you to know that I SO APPRECIATE ALL THE HELP and ADVICE that you and the others have given me but, more importantly, thank you for not bailing due to my ignorance with these D*** HID's!

I also notice that the bulb is loose or that the base in which the bulb is attached to, is slightly loose. I have been EXTREMELY careful as not to touch or jar the bulb or base. BTW, if shown a closeup of the bulb, whould you be able to tell if it is blown or damaged?
SCCofSV is offline   Reply With Quote
Old 08-26-2012, 12:15 PM   #12
Registered Member
Regular
 
2Greeny7's Avatar
 
Join Date: Jan 2012
Region: Connecticut
Posts: 776
Send a message via Skype™ to 2Greeny7
Quote:
Originally Posted by SCCofSV

Alright, I will do that and get back to you. I want you to know that I SO APPRECIATE ALL THE HELP and ADVICE that you and the others have given me but, more importantly, thank you for not bailing due to my ignorance with these D*** HID's!

I also notice that the bulb is loose or that the base in which the bulb is attached to, is slightly loose. I have been EXTREMELY careful as not to touch or jar the bulb or base. BTW, if shown a closeup of the bulb, whould you be able to tell if it is blown or damaged?
Your very welcome! And hey im glad to help share what i know! And share the picture maybe we will know!
__________________
2001 V6
CAI, SF3/X3 Tuner, 4.10 Gears, Auburn lim-slip
GT4 Rims (Summer), Stock Rims (Winter)
2 Subs, New speakers all around
1 Great Car 1 Happy Kid
July '12 Mustang of the Month
2Greeny7 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Off Topic Forums > General Car Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:23 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.