High oil pressure on Jeep - Mustang Evolution

Go Back   Mustang Evolution > Off Topic Forums > General Car Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-09-2013, 04:59 PM   #1
Registered Member
Regular
 
Join Date: Oct 2012
Posts: 72
High oil pressure on Jeep

I have a 2000 Jeep Grand Cherokee 4.0 and this past week, the oil pressure gauge has read between 70-80 the entire time I drive. I was just wondering if anyone had an idea what the problem could be!

Click image for larger version

Name:	image-3197433629.jpg
Views:	2043
Size:	450.8 KB
ID:	90004
blackmustang12 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-09-2013, 05:04 PM   #2
Registered Member
Regular
 
BigpapaDean's Avatar
 
Join Date: Feb 2012
Region: Canada
Posts: 520
Hey black! I just posted the same thing a couple months ago. I got a 99 wrangler with the same prob, I ended up changing the oil pump for nothing. Turns out being the gauge itself that doesn't work. Even after changing out the pump the gauge still goes all the way left, if there is no change in the way your jeep is running I wouldn't worry about it. Check if you can your gauge and just order a new one, MUCH cheaper than an oil pump and labor. I was panicking for nothing. Keep me posted please.
BigpapaDean is offline   Reply With Quote
Old 02-09-2013, 05:18 PM   #3
Registered Member
Regular
 
Join Date: Oct 2012
Posts: 72
Quote:
Originally Posted by BigpapaDean
Hey black! I just posted the same thing a couple months ago. I got a 99 wrangler with the same prob, I ended up changing the oil pump for nothing. Turns out being the gauge itself that doesn't work. Even after changing out the pump the gauge still goes all the way left, if there is no change in the way your jeep is running I wouldn't worry about it. Check if you can your gauge and just order a new one, MUCH cheaper than an oil pump and labor. I was panicking for nothing. Keep me posted please.
Thanks for the reply! Haha wow all that time and money spend and it turns out to be a bad gauge! I hope it's somethin simple like that because I've been worried everytime I drive it now. Of course it's winter time and I really don't like takin the mustang out too much with all the salt on our roads haha I'll keep you updated on everything!
blackmustang12 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-09-2013, 05:40 PM   #4
Registered Member
Regular
 
BigpapaDean's Avatar
 
Join Date: Feb 2012
Region: Canada
Posts: 520
Lol, thanks and good luck! Keep the stang indoors.
BigpapaDean is offline   Reply With Quote
Old 02-12-2013, 02:00 PM   #5
Registered Member
Regular
 
Join Date: Oct 2012
Posts: 72
Quote:
Originally Posted by BigpapaDean
Lol, thanks and good luck! Keep the stang indoors.
Turns out it was the oil pressure sending unit. Got that replaced and it's good to go now!
blackmustang12 is offline   Reply With Quote
Old 02-14-2013, 05:23 PM   #6
Registered Member
Regular
 
BigpapaDean's Avatar
 
Join Date: Feb 2012
Region: Canada
Posts: 520
Cool, I'm glad you figured it out without causing any other probs. how much was it? If you don't mind me asking....
BigpapaDean is offline   Reply With Quote
Old 02-24-2013, 06:15 PM   #7
Registered Member
Regular
 
Join Date: Oct 2012
Posts: 72
Thank you! Till it was all said and done the shop charged me $105 for the sending unit and labor. I'm just glad it's fixed haha
blackmustang12 is offline   Reply With Quote
Old 02-25-2013, 09:02 AM   #8
Registered Member
Regular
 
BigpapaDean's Avatar
 
Join Date: Feb 2012
Region: Canada
Posts: 520
It's all good! That $ sounds about right, I think mine was about 130$ for the pump. The pump I didn't need...lol. Later brother.
BigpapaDean is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Off Topic Forums > General Car Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:12 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.