Idle issues - Mustang Evolution

Go Back   Mustang Evolution > Off Topic Forums > General Car Discussion



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-22-2014, 03:00 PM   #1
Registered User
Newbie
 
Join Date: Mar 2014
Posts: 1
Idle issues

I have a 2000 gt I recently replaced all four 02 sensors and the intake manifold (due to the plastic cracking) and it went smooth very easy everything was right in front of me and I had noted where everything was pulled and goes back to after we had finished the swap. The car ran like crap the idle has become awful when on the throttle it drives perfect but when idling it will sit at 2000 then drop to normal then start kinda chugging I let the battery sit unhooked over night then when that didn't work I cleaned the throttle body and I.A.C. Valve helped barely but still rough idle it will still get up and go like normal it's just that idle also the temp gauge gets almost to the half way mark but nothing more it has full coolant but the coolant Lahr is coming on this even occurred before the intake swap. Ps the intake was the dorman from oreilys please shed some light on this I'm stumped
joehall92 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-22-2014, 08:58 PM   #2
Road Trip!
 
dobypaw3's Avatar
 
Join Date: Jun 2012
Location: Upstate NY
Region: New York
Posts: 1,146
Idle issues

Quote:
Originally Posted by joehall92 View Post
I have a 2000 gt I recently replaced all four 02 sensors and the intake manifold (due to the plastic cracking) and it went smooth very easy everything was right in front of me and I had noted where everything was pulled and goes back to after we had finished the swap. The car ran like crap the idle has become awful when on the throttle it drives perfect but when idling it will sit at 2000 then drop to normal then start kinda chugging I let the battery sit unhooked over night then when that didn't work I cleaned the throttle body and I.A.C. Valve helped barely but still rough idle it will still get up and go like normal it's just that idle also the temp gauge gets almost to the half way mark but nothing more it has full coolant but the coolant Lahr is coming on this even occurred before the intake swap. Ps the intake was the dorman from oreilys please shed some light on this I'm stumped

You would probably get more responses to your problem in the 96'-04' board.
dobypaw3 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Off Topic Forums > General Car Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AOD to T5 Swap & Idle, Bucking Issues Trojan Horse 1979-1995 Mustang GT 5 02-06-2012 10:47 AM
Idle issues HELP DHall31 General Mustang Discussion 9 11-23-2011 06:33 PM
Issues at idle iwannagofast 1996-2004 Mustang GT 19 05-09-2011 08:10 PM
You guys with idle issues (possible vacume leak) try this SpectorV Pre-2005 V6 Mustang 3 06-01-2010 02:28 PM
Hot start idle issues Scorpion1 Pre-2005 V6 Mustang 12 04-07-2009 05:58 PM

» Like Us On Facebook



01:54 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.