ran in a few problems recently - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-31-2009, 11:09 PM   #1
Registered Member
Regular
 
iwannagofast's Avatar
 
Join Date: Aug 2006
Region: Wisconsin
Posts: 413
ran in a few problems recently

So i brought my car out of storage last week and really strange things have been happening. 1st when i bring the car to a stop the rpms bounce around and sometimes they get so low the car dies. 2nd when getting on it trying to catch an Evo the hose that conects from the intake to the heater core ripped, so i replaced it and then today i brought the car in to boost and the fitting that the hose is on blew completely off the intake. Any ideas on whats causing these problems?
iwannagofast is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-01-2009, 08:34 AM   #2
Registered Member
Regular
 
SaleenFiend's Avatar
 
Join Date: Jul 2008
Location: Louisiana
Region: Louisiana
Posts: 2,318
Re: ran in a few problems recently

Quote:
Originally Posted by iwannagofast View Post
So i brought my car out of storage last week and really strange things have been happening. 1st when i bring the car to a stop the rpms bounce around and sometimes they get so low the car dies. 2nd when getting on it trying to catch an Evo the hose that conects from the intake to the heater core ripped, so i replaced it and then today i brought the car in to boost and the fitting that the hose is on blew completely off the intake. Any ideas on whats causing these problems?
hmm, try clocking your MAF for the killing issue(rotating on the axis of 360*). Is the MAF or CAI aftermarket?

Sounds like the Heater core may be plugged? Thus pressure building bursting the hose/fitting. ?? Not sure. Does your coolant look good? any signs of leakage.
SaleenFiend is offline   Reply With Quote
Old 04-01-2009, 01:27 PM   #3
Registered Member
Regular
 
iwannagofast's Avatar
 
Join Date: Aug 2006
Region: Wisconsin
Posts: 413
Re: ran in a few problems recently

the coolant looks good, no signs of leaks. I thought the heater core might be the issue but the heat still works fine, so since the heat works doesnt that mean the heater core is ok? As for the maf and cai, the maf is stock the and the cai is custom to work with my vortec s/c
iwannagofast is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-01-2009, 03:12 PM   #4
Registered Member
Regular
 
SaleenFiend's Avatar
 
Join Date: Jul 2008
Location: Louisiana
Region: Louisiana
Posts: 2,318
Re: ran in a few problems recently

What kind of car are you driving?

Are you sure the hose/fitting wasn't already damaged or frayed before the issue?

For the idling issue clean the MAF with electrical cleaner and clean your IAC valve with carb cleaner. Check your spark plugs for any water residue. Also Look into the positioning of the MAF Sensor ... should be about 10 O'clock if standing in front of the engine



That maf is about 2 oclock

but with it being an idling issue I'm kinda hesitant on the MAF. Also get your tune checked with the shop you had it performed...
SaleenFiend is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ran into a very nice S197 HotRodRunning General Mustang Discussion 0 03-28-2009 04:29 PM
Cigar smokers: what have you smoked recently? fast64 The Bar 26 02-24-2007 12:37 PM
Some work I've done recently for friends fast64 Pictures and Videos 10 01-20-2007 01:37 PM
What I've done to the Stang recently Brent Pictures and Videos 11 12-18-2006 02:09 PM
Ran a 13.8 in the 1/4 PureVenom Pictures and Videos 12 11-30-2006 09:49 PM

» Like Us On Facebook



09:37 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.