03 GT Misfire - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-22-2009, 11:23 PM   #1
Registered User
Newbie
 
Join Date: Jan 2009
Region: Texas
Posts: 5
03 GT Misfire

I have researched some previous posts and tried a few things but nothing has worked yet. I have a mostly stock 03 gt. I have added a ford racing 70mm throttle body, 75mm trickflow plenum, K&N cai, and a Diablo tuner. The problem started small and has progressively gotton worse. The car feels like it's sputtering and only when crusing at a consistent speed and only some times. I can't feel it when accelerating but I can tell the performance isn't there. I have installed all new plugs, coil on plugs, dpfe egr sensor, and fuel pump. I was thinking injectors next but I hate to spend any more money on something that wont cure the problem. Any suggestions on what to check would be appreciated.
finallyaGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-23-2009, 11:43 PM   #2
Registered User
Newbie
 
Join Date: Jan 2009
Region: Texas
Posts: 5
Re: 03 GT Misfire

Well I changed the plugs again and went back to stock motorcraft. I drove to work today and just got home and the missing is gone.
finallyaGT is offline   Reply With Quote
Old 08-24-2009, 12:45 AM   #3
Registered Member
Regular
 
iwannagofast's Avatar
 
Join Date: Aug 2006
Region: Wisconsin
Posts: 413
Re: 03 GT Misfire

i got the same problem right now. so it was the coil packs?
iwannagofast is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-24-2009, 08:13 AM   #4
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
Re: 03 GT Misfire

vacuum leak?
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Old 08-24-2009, 01:02 PM   #5
Registered User
Newbie
 
Join Date: Jan 2009
Region: Texas
Posts: 5
Re: 03 GT Misfire

iwannagofast it was the spark plugs. When I first felt the motor starting to miss I tried the zex spark plugs but the problem continued. I then bought the coil onplugs but that didn't cure the problem either. So long story short I tried the stock motor craft plugs and now it's running great. I had planned on changing out the coil on plugs anyway but I was guessing with everything else. On the bright side I now have some new parts that I shouldn't have to worry about for a while. I thought it could be a vaccul leak like suggested so I bought a cheap cigar and checked for vaccum leaks by blowing small streams of smoke along the vaccum lines. Seamed like a good idea and like former president I didn't inhale either. Try new plugs first and .buy the motor craft
finallyaGT is offline   Reply With Quote
Old 08-24-2009, 05:54 PM   #6
Registered Member
Regular
 
Tape's Avatar
 
Join Date: Apr 2007
Posts: 273
Re: 03 GT Misfire

when you change the plugs change the boots as well, I've had the same issue twice and both times it's been the boots. they're about 6$ea so people tend to avoid them, but they have a lifetime warranty if you goto autozone, I change my boots when I change the plugs and haven't had those problems since.
Tape is offline   Reply With Quote
Old 08-24-2009, 06:25 PM   #7
Registered Member
Regular
 
Otlaw80's Avatar
 
Join Date: May 2009
Region: Illinois
Posts: 504
Re: 03 GT Misfire

Motorcraft/autolite are the best damn plugs you can buy for anything. And i'm not just saying that cause they are ford. Never had a problem with them, I have with most other brands except.
__________________
1986 GT T-Top. Driving Project
Otlaw80 is offline   Reply With Quote
Old 08-26-2009, 02:11 PM   #8
Registered Member
Regular
 
iwannagofast's Avatar
 
Join Date: Aug 2006
Region: Wisconsin
Posts: 413
Re: 03 GT Misfire

one of my injectors were unplugged, easy and cheap fix. jus how i like it
iwannagofast is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Misfire ??!! English Paul General Mustang Discussion 7 11-10-2009 01:18 AM
Another misfire 2000MustangGT17 1996-2004 Mustang GT 5 06-24-2009 09:47 AM
#1 misfire 2kslvrgt 1996-2004 Mustang GT 4 02-17-2009 02:26 PM
another misfire! Jeremym831 1996-2004 Mustang GT 4 03-03-2008 11:01 AM
misfire in #1 vramos1 Pre-2005 V6 Mustang 4 09-15-2007 03:24 PM

» Like Us On Facebook



12:45 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.