Still sputtering... - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-29-2009, 08:42 PM   #1
Registered Member
Regular
 
04SonicBlueGT's Avatar
 
Join Date: Oct 2009
Region: Florida
Posts: 21
Still sputtering...

My 04gt with 44k miles started to sputter after i cleaned my intake (K&N)... idk y. I changed the plugs and fuel filter but its still doing it... not as much after i changed the filter but still doing it... any ideas?
04SonicBlueGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-29-2009, 09:21 PM   #2
Registered Member
Regular
 
outlawfrog's Avatar
 
Join Date: Oct 2009
Region: Alabama
Posts: 283
Re: Still sputtering...

You said after you cleaned the intake.......so make sure all of the vaccum lines and all are still hooked-up in the right spot. I'm not sure on this, but just incase, check your MAF......IF you oiled the filter too much, the MAF might have sucked-up some of the oil, and that may be giving a false reading......but I'm just taking a shot in the dark here..lol
__________________
1996 GT, 5-speed, Moonlight Blue, Opal Gray leather, Flowmaster Cat-Back exhaust (Delta 40 series), BBK cold air intake & 75mm TBI, Super Chips programmer.
Quote:
Originally Posted by 67mustang97 View Post
outlawfrog is probably right
Quote:
Originally Posted by outlawfrog View Post
I might pull an "osirisguy", and make that my new sig quote!
........................................................................
outlawfrog is offline   Reply With Quote
Old 11-29-2009, 10:03 PM   #3
Registered Member
Regular
 
04SonicBlueGT's Avatar
 
Join Date: Oct 2009
Region: Florida
Posts: 21
Re: Still sputtering...

Thanks outlaw well ill check the MAF and the lines ive checked they are fine
04SonicBlueGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-29-2009, 10:05 PM   #4
Registered Member
Regular
 
outlawfrog's Avatar
 
Join Date: Oct 2009
Region: Alabama
Posts: 283
Re: Still sputtering...

I may be waaayyyy off....like I said, it was just a shot in the dark..lol
__________________
1996 GT, 5-speed, Moonlight Blue, Opal Gray leather, Flowmaster Cat-Back exhaust (Delta 40 series), BBK cold air intake & 75mm TBI, Super Chips programmer.
Quote:
Originally Posted by 67mustang97 View Post
outlawfrog is probably right
Quote:
Originally Posted by outlawfrog View Post
I might pull an "osirisguy", and make that my new sig quote!
........................................................................
outlawfrog is offline   Reply With Quote
Old 11-29-2009, 10:07 PM   #5
Registered Member
Regular
 
outlawfrog's Avatar
 
Join Date: Oct 2009
Region: Alabama
Posts: 283
Re: Still sputtering...

oh.....and the fact that I always had a habit of over oiling the k&n when I had my f-150...haha
__________________
1996 GT, 5-speed, Moonlight Blue, Opal Gray leather, Flowmaster Cat-Back exhaust (Delta 40 series), BBK cold air intake & 75mm TBI, Super Chips programmer.
Quote:
Originally Posted by 67mustang97 View Post
outlawfrog is probably right
Quote:
Originally Posted by outlawfrog View Post
I might pull an "osirisguy", and make that my new sig quote!
........................................................................
outlawfrog is offline   Reply With Quote
Old 11-30-2009, 01:23 AM   #6
Registered Member
Regular
 
OsirisGuy's Avatar
 
Join Date: Jun 2007
Location: New York
Region: New York
Posts: 1,262
Send a message via AIM to OsirisGuy
Re: Still sputtering...

Yeah I second the "check your MAF" and use some electronic cleaner on the contacts.
__________________
Quote:
Originally Posted by MetallicMist View Post
OsirisGuy is correct
Quote:
Originally Posted by stangaroo View Post
OsirisGuy is right
2002 Mustang GT

BBK CAI - Flowmaster Catbacks - Pro 5.0 Shifter
OsirisGuy is offline   Reply With Quote
Old 11-30-2009, 01:24 AM   #7
Legacy Member
Legacy
 
MonteCitan's Avatar
 
Join Date: Aug 2004
Region: California
Posts: 2,506
Send a message via AIM to MonteCitan
Re: Still sputtering...

Try spraying down the MAF with electrical contact/no residue cleaner (specified for electronics) just because it looks ok doesn't mean it hasn't gotten messed up a bit

just be sure to not physically touch it..

Edit.. Osiris was a smidge too fast for me
__________________
2012 IS F Blue IS F Sport
2006 Mustang V6 wannabe
MonteCitan is offline   Reply With Quote
Old 11-30-2009, 01:25 AM   #8
Registered Member
Regular
 
OsirisGuy's Avatar
 
Join Date: Jun 2007
Location: New York
Region: New York
Posts: 1,262
Send a message via AIM to OsirisGuy
Re: Still sputtering...

Haha! I'm like a ninja!
__________________
Quote:
Originally Posted by MetallicMist View Post
OsirisGuy is correct
Quote:
Originally Posted by stangaroo View Post
OsirisGuy is right
2002 Mustang GT

BBK CAI - Flowmaster Catbacks - Pro 5.0 Shifter
OsirisGuy is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sputtering 04SonicBlueGT 1996-2004 Mustang GT 5 11-15-2009 08:24 PM
sputtering at low rpms eddie1 1996-2004 Mustang GT 28 05-12-2009 09:22 PM
sputtering Stang!! jagger969 1979-1995 Mustang GT 2 04-09-2008 10:02 PM

» Like Us On Facebook



03:20 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.