Problem after typhoon intake manifold install. - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-07-2011, 10:05 AM   #1
Registered User
Newbie
 
RudyJ's Avatar
 
Join Date: Oct 2009
Region: Louisiana
Posts: 7
Problem after typhoon intake manifold install.

I just installed my typhoon inatake manifold, MSD blaster coils & a new Optima battery. Everything looks great but now it wont start. I ve checked over everything & it all good good. When put the key in my gauges sweep & everthing looks the way its suppose to but when I try to start her I just hear a clicking sound & its like I have no more power from the battery but its new & I have test light that came with it & it shows the battery is good. Anybody have any ideas on what can be the problem? Thanks in advance.
RudyJ is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-07-2011, 10:22 AM   #2
Registered Member
Regular
 
stampde's Avatar
 
Join Date: Oct 2010
Location: Manalapan
Region: New Jersey
Posts: 1,880
Re: Problem after typhoon intake manifold install.

just sounds like a bad connection at the battery , clean your cables and re tighten them
__________________
2011 GT Auto
stampde is offline   Reply With Quote
Old 02-07-2011, 10:27 AM   #3
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
Re: Problem after typhoon intake manifold install.

when the needles flip like that its a sign the car lost its battery or the battery is not performing right, it happens when you disconnect and reconnect the battery for example.
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-07-2011, 11:54 AM   #4
Registered User
Newbie
 
RudyJ's Avatar
 
Join Date: Oct 2009
Region: Louisiana
Posts: 7
Well, it was a bad connection. But now it idles realy bad. I have to stay on the throttle or it stalls.
RudyJ is offline   Reply With Quote
Old 02-07-2011, 12:26 PM   #5
Registered Member
Regular
 
doubletap4311's Avatar
 
Join Date: Jan 2011
Region: Texas
Posts: 28
Either bad coil or vacuum leak
__________________
2002 Gt, 5 speed, BBK Cai, BBK 78 MM intake plenum combo, steeda UDP, steeda tri axe shifter, 4.10 Ford racing gears, Sct custom tune, raptor shift light.
doubletap4311 is offline   Reply With Quote
Old 02-07-2011, 02:39 PM   #6
Registered Member
Regular
 
stampde's Avatar
 
Join Date: Oct 2010
Location: Manalapan
Region: New Jersey
Posts: 1,880
Re: Problem after typhoon intake manifold install.

yup what doubletap said !!! i'd lean toward vacuum leak
__________________
2011 GT Auto
stampde is offline   Reply With Quote
Old 02-09-2011, 05:41 PM   #7
Registered Member
Regular
 
iwannagofast's Avatar
 
Join Date: Aug 2006
Region: Wisconsin
Posts: 413
Re: Problem after typhoon intake manifold install.

Did you have a dyno before this intake? if yes, get another one done now. I've heard alot about typhoons causing hp and torque loss
iwannagofast is offline   Reply With Quote
Old 02-09-2011, 11:06 PM   #8
Road Trip!
 
Join Date: Dec 2010
Region: Canada
Posts: 2,203
Quote:
Originally Posted by iwannagofast
Did you have a dyno before this intake? if yes, get another one done now. I've heard alot about typhoons causing hp and torque loss
Ditto
Everett is offline   Reply With Quote
Old 02-10-2011, 09:13 AM   #9
Registered Member
Regular
 
DarkShadows's Avatar
 
Join Date: Mar 2008
Region: Louisiana
Posts: 1,178
Installed intake, and had mine retuned and runs strong for me now!!
__________________

March 2010 Mustangevolution Mustang of the Month 1st eva biatch!
DarkShadows is offline   Reply With Quote
Old 02-12-2011, 06:53 AM   #10
Registered Member
Regular
 
Join Date: Feb 2011
Region: North Carolina
Posts: 22
Re: Problem after typhoon intake manifold install.

I have a K&N on mine and have no issues. I believe you forgot to hook up a vac line or two somewhere. Anyhow, I have heard the CAI's don't do what they are worth. Just an add on that looks good. Anyone feel free to correct me if I am wrong. Anywhere from 100 to 200 dollars is not worth a 5 to 10 HP gain to me.
Jdaddy42 is offline   Reply With Quote
Old 02-12-2011, 07:06 AM   #11
Road Trip!
 
Join Date: Dec 2010
Region: Canada
Posts: 2,203
Quote:
Originally Posted by Jdaddy42
I have a K&N on mine and have no issues. I believe you forgot to hook up a vac line or two somewhere. Anyhow, I have heard the CAI's don't do what they are worth. Just an add on that looks good. Anyone feel free to correct me if I am wrong. Anywhere from 100 to 200 dollars is not worth a 5 to 10 HP gain to me.
On a new edge you dont even get that. 05 and up need a tune or it's a waste of money
Everett is offline   Reply With Quote
Old 02-12-2011, 07:46 AM   #12
Registered Member
Regular
 
Wolfsbain76's Avatar
 
Join Date: Jul 2010
Region: New York
Posts: 268
Re: Problem after typhoon intake manifold install.

Quote:
Originally Posted by Everett View Post
On a new edge you dont even get that. 05 and up need a tune or it's a waste of money
That's so good to know, I would have installed it and not even have known! I absolutely love being a part of a group with knowledge!! Looks like a summertime project then. Thanks for the heads up!
__________________
2007 Mustang GT
Wolfsbain76 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:50 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.