car problems. - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-18-2011, 08:25 PM   #1
Registered Member
Regular
 
Twit38's Avatar
 
Join Date: Nov 2010
Region: Illinois
Posts: 33
car problems.

Its been maybe over a month my car has been broke down. No one can figure out what's wrong with it. It all started when I changed the spark plugs. Had to replace a boot Ans coyle then the car starts surging and Bucking and driving like crap..we changed egr valve the fuel pump fuel filter now I took it down the road today and the engine light started flashing..which I didn't know what it meant but knew it was bad. I looked it up and it said a dangerous miss fire? My.next guess is to change all the boots and coils what do you all think? The car has no power and it surges and jumps around going down the road.
__________________
I'm a angel in ariat boots and a devil in blue jeans. I'm every cowgirls nightmare and every cowboys dream
Twit38 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-18-2011, 10:33 PM   #2
Registered Member
Regular
 
98gtdriver's Avatar
 
Join Date: May 2011
Region: Washington
Posts: 368
The cats could be plugged
__________________
-Eric
98gtdriver is offline   Reply With Quote
Old 06-19-2011, 10:27 AM   #3
Registered Member
Regular
 
Las0mbra's Avatar
 
Join Date: Jan 2011
Region: Oklahoma
Posts: 2,104
Try cleaning the maf
Las0mbra is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-19-2011, 10:31 AM   #4
Registered Member
Regular
 
Join Date: May 2009
Region: New York
Posts: 94
Re: car problems.

double check you got the wires on the right plugs
pringle9666 is offline   Reply With Quote
Old 06-19-2011, 12:12 PM   #5
Registered Member
Regular
 
jbanks's Avatar
 
Join Date: Jun 2011
Region: Georgia
Posts: 238
Quote:
Originally Posted by pringle9666
double check you got the wires on the right plugs
If it's the car in the picture, there aren't any wires, just COP's. You could have damaged one when you changed the plugs, they can break when you pull them off. Happened to me with my 03, had to replace it.
__________________
Boom!
jbanks is offline   Reply With Quote
Old 06-19-2011, 04:14 PM   #6
Registered Member
Regular
 
onesickstang01's Avatar
 
Join Date: May 2011
Posts: 441
Take it to a good shop and have them test the coils. I have a tester at my shop that all i have to do it put it over the COP and it will tell me if its firing. Dont forget injectors though, they will cause misfire as well. Make sure all thr connectors are connected securely. Sometimes they look to be but arent. If any of the securing clips are broken ziptie them secure and test. Injectors can be tested the same way as the COPs with the right tester. Sometimes its cheaper just to have the right tests done rather than throwin money at every other part in the car
onesickstang01 is offline   Reply With Quote
Old 06-19-2011, 09:28 PM   #7
Registered Member
Regular
 
jbanks's Avatar
 
Join Date: Jun 2011
Region: Georgia
Posts: 238
Quote:
Originally Posted by onesickstang01
Sometimes its cheaper just to have the right tests done rather than throwin money at every other part in the car
I agree 100%
__________________
Boom!
jbanks is offline   Reply With Quote
Old 06-20-2011, 08:26 AM   #8
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
Re: car problems.

put a scanner on it (free at most auto places dont pay for it to be done)

it could be the coil you installed is bad~ or another one is bad. I would recheck the install of the coil and look at the plug to see if its good as well make sure the end of the plug is all there and looks good.
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Car Seat Problems a3705872 Pre-2005 V6 Mustang 6 10-04-2010 11:04 PM
Vortech supercharger problems car quits running sporter 2005-2010 Mustang GT 15 11-28-2008 06:55 PM
Problems Once Again... MyStangStanks Pre-2005 V6 Mustang 3 11-20-2006 07:25 PM
Car problems continue,Speedo' problem Dark02Pony Pre-2005 V6 Mustang 4 09-22-2005 01:19 PM
Problems: Smokedya95stang ME Site Help & Announcements 0 03-06-2004 07:51 PM

» Like Us On Facebook



03:11 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.