My 6 disc OEM CD player bad - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-11-2011, 05:16 PM   #1
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
My 6 disc OEM CD player bad

My factory cd player says that all 6 disc slots are full but there is no CDs in it. It just says cd error when I want to load one???
jjsg09 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-11-2011, 08:01 PM   #2
Registered Member
Regular
 
junoS197Bl08's Avatar
 
Join Date: Oct 2009
Region: North Carolina
Posts: 533
Re: My 6 disc OEM CD player bad

did u try pressing the eject button on all 6 slots doubt that will work but its worth a try. Also try disconnecting the battery for a while and that will basically reset everything. So hopefully that will work.

Then if that doesn't work. Is it under warrantee? If it is under warrantee then take it into ford and have them fix it. But if its not under warrantee then I would start looking into aftermarket head units rather than buying a new OEM one.
__________________
2008 V6 Windveil Blue with 5spd standard transmission-pony package, replica rims, shorty antenna
junoS197Bl08 is offline   Reply With Quote
Old 07-11-2011, 08:28 PM   #3
Registered Member
Regular
 
sally2002's Avatar
 
Join Date: May 2011
Region: Indiana
Posts: 438
Quote:
Originally Posted by junoS197Bl08
did u try pressing the eject button on all 6 slots doubt that will work but its worth a try. Also try disconnecting the battery for a while and that will basically reset everything. So hopefully that will work.

Then if that doesn't work. Is it under warrantee? If it is under warrantee then take it into ford and have them fix it. But if its not under warrantee then I would start looking into aftermarket head units rather than buying a new OEM one.
I just had my 6 disc go out on me also and to get a new one from ford it will cost around 500 dollars for a new head unit and to me thats pretty salty. I would go aftermarket. Thats what my plans are and find one that is iPod capable and more for half the price but that's my opinion.
sally2002 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-11-2011, 09:51 PM   #4
Registered Member
Regular
 
sonicpony03's Avatar
 
Join Date: Dec 2007
Location: WI
Region: Wisconsin
Posts: 5,411
Re: My 6 disc OEM CD player bad

Not sure if you have the Mach system (94-04) or the Shaker (05-present). The Mach 460's 6 disc are known to go out. The loading unit wears out and it's ~315 for a remanufactured unit with your old one sent in as a core.

If you can live without the 6 disc and Mach head unit, go aftermarket.

I haven't heard too much about the Shaker systems going bad, but I guess it can happen.
__________________


12 Black GT500 SVT PP l VMP TVS l JLT123 l O/R X l 28x11.50Rx15 M/T Street R's l BMR Suspension l Recaros

03 Sonic Blue 3.8 / 17 Magnetic Fusion Sport 2.7 EB
sonicpony03 is offline   Reply With Quote
Old 07-12-2011, 12:11 AM   #5
Registered Member
Regular
 
vinnygt's Avatar
 
Join Date: Jun 2011
Region: California
Posts: 666
Re: My 6 disc OEM CD player bad

mach 460 sucks...if im playing a cd the damn thing cuts off on every bump.
vinnygt is offline   Reply With Quote
Old 07-12-2011, 01:06 AM   #6
Registered Member
Regular
 
03GT88's Avatar
 
Join Date: Mar 2011
Region: Mississippi
Posts: 532
My mach 1000 did the same crap in my 03. Wouldn't load when it did it said cd error. Wouldn't eject and so on. I took it out unplugged it and put it back in. That didn't help. So then I took it back out took off the outer cover of the unit to just see if I saw any broken parts. Didn't notice anything. I took my cds out and put it back in the car. It has been working great for probably 6 months. Don't know why it fixed the problem but it did. Its worth trying I say.
03GT88 is offline   Reply With Quote
Old 07-12-2011, 10:51 AM   #7
Moderator Emeritus
Regular
 
Lalayla's Avatar
 
Join Date: Mar 2010
Location: Tampa
Region: Florida
Posts: 5,066
Send a message via AIM to Lalayla Send a message via MSN to Lalayla Send a message via Skype™ to Lalayla
I had to replace mine because the volume would turn all the way up when I tried to turn it down.
__________________

Layla - December 2010 Mustang of the Month
Lalayla is offline   Reply With Quote
Old 07-12-2011, 12:37 PM   #8
Registered Member
Regular
 
stampde's Avatar
 
Join Date: Oct 2010
Location: Manalapan
Region: New Jersey
Posts: 1,880
Re: My 6 disc OEM CD player bad

yup my mACH460 KEPT DOING THE SAME THING , A couple years back ,sometimes disconnecting the battery works , other times it would just fix itself ,and cd's kept getting jammed too , i replaced it all ,with after market stuff ,sounds a lot better too!!!
__________________
2011 GT Auto
stampde is offline   Reply With Quote
Old 07-12-2011, 12:51 PM   #9
Moderator Emeritus
Regular
 
Lalayla's Avatar
 
Join Date: Mar 2010
Location: Tampa
Region: Florida
Posts: 5,066
Send a message via AIM to Lalayla Send a message via MSN to Lalayla Send a message via Skype™ to Lalayla
Quote:
Originally Posted by stampde
yup my mACH460 KEPT DOING THE SAME THING , A couple years back ,sometimes disconnecting the battery works , other times it would just fix itself ,and cd's kept getting jammed too , i replaced it all ,with after market stuff ,sounds a lot better too!!!
Agreed I like my clarion better and it doesn't scare the crap out of me when I turn my car on.
__________________

Layla - December 2010 Mustang of the Month
Lalayla is offline   Reply With Quote
Old 07-12-2011, 01:23 PM   #10
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
Re: My 6 disc OEM CD player bad

you can grab them cheap if you want a replacement head unit
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Old 07-12-2011, 08:20 PM   #11
Registered Member
Regular
 
sonicpony03's Avatar
 
Join Date: Dec 2007
Location: WI
Region: Wisconsin
Posts: 5,411
Re: My 6 disc OEM CD player bad

They aren't bad for stock. I was pretty happy with the system when it worked.

But it seems they don't have the longevity as a lot of them have issues after a couple years.
__________________


12 Black GT500 SVT PP l VMP TVS l JLT123 l O/R X l 28x11.50Rx15 M/T Street R's l BMR Suspension l Recaros

03 Sonic Blue 3.8 / 17 Magnetic Fusion Sport 2.7 EB
sonicpony03 is offline   Reply With Quote
Old 07-13-2011, 01:25 AM   #12
Registered User
Newbie
 
Join Date: Aug 2010
Region: Texas
Posts: 18
Re: My 6 disc OEM CD player bad

Mine did that once, what you do is turn the car to accessory, then power off the radio. Turn your car off and unplug the neg cable for a few mins, then reconnect the cable, turn your car back to accessory and turn it on.....it should reset itself.
__________________
2002 GT Premium: A few bolt ons.
Dyno tuned by PSI Motorsports
255.67whp & 300.46wtrq
02gtkev is offline   Reply With Quote
Old 07-13-2011, 09:12 AM   #13
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by junoS197Bl08
did u try pressing the eject button on all 6 slots doubt that will work but its worth a try. Also try disconnecting the battery for a while and that will basically reset everything. So hopefully that will work.

Then if that doesn't work. Is it under warrantee? If it is under warrantee then take it into ford and have them fix it. But if its not under warrantee then I would start looking into aftermarket head units rather than buying a new OEM one.
Yea I've done everything but the battery cable thing. But I've completely have removed it out and taken the faceplate off an no CDs in it don't know y it still says it's full.
jjsg09 is offline   Reply With Quote
Old 07-13-2011, 09:16 AM   #14
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by sonicpony03
Not sure if you have the Mach system (94-04) or the Shaker (05-present). The Mach 460's 6 disc are known to go out. The loading unit wears out and it's ~315 for a remanufactured unit with your old one sent in as a core.

If you can live without the 6 disc and Mach head unit, go aftermarket.

I haven't heard too much about the Shaker systems going bad, but I guess it can happen.
It's the Mach 460 it's was working great but the other day i turned it on and went to put a disc in and it says they are all full
jjsg09 is offline   Reply With Quote
Old 07-13-2011, 09:17 AM   #15
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by 03GT88
My mach 1000 did the same crap in my 03. Wouldn't load when it did it said cd error. Wouldn't eject and so on. I took it out unplugged it and put it back in. That didn't help. So then I took it back out took off the outer cover of the unit to just see if I saw any broken parts. Didn't notice anything. I took my cds out and put it back in the car. It has been working great for probably 6 months. Don't know why it fixed the problem but it did. Its worth trying I say.
Well I opened I up no discs in it and still shows all 6 slots full
jjsg09 is offline   Reply With Quote
Old 07-13-2011, 09:18 AM   #16
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by stampde
yup my mACH460 KEPT DOING THE SAME THING , A couple years back ,sometimes disconnecting the battery works , other times it would just fix itself ,and cd's kept getting jammed too , i replaced it all ,with after market stuff ,sounds a lot better too!!!
What after market one did u go with
jjsg09 is offline   Reply With Quote
Old 07-13-2011, 10:02 PM   #17
Registered Member
Regular
 
jbanks's Avatar
 
Join Date: Jun 2011
Region: Georgia
Posts: 238
Quote:
Originally Posted by jjsg09

Yea I've done everything but the battery cable thing. But I've completely have removed it out and taken the faceplate off an no CDs in it don't know y it still says it's full.
Disconnect the battery and reconnect it. Should fix it. If not, throw it in the yard.
__________________
Boom!
jbanks is offline   Reply With Quote
Old 07-13-2011, 10:19 PM   #18
Registered Member
Regular
 
03GT88's Avatar
 
Join Date: Mar 2011
Region: Mississippi
Posts: 532
Sounds like there all pretty crappy ford should have done a Recall Haha.
03GT88 is offline   Reply With Quote
Old 07-13-2011, 11:09 PM   #19
Road Trip!
 
Join Date: Feb 2011
Region: North Carolina
Posts: 668
Re: My 6 disc OEM CD player bad

yeah the CD player in the truck went bad several times under warranty and finally we had to get an aftermarket one after the last time it broke....we went Clarion and it is nice but it doesn't match the instrument colors
2008Shelby is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

« comp cams | 94 5.0 »
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad luck... Blackedout Pre-2005 V6 Mustang 20 07-29-2011 08:50 AM

» Like Us On Facebook



08:39 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.