Cooling fan help!! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-14-2011, 11:58 AM   #1
Registered Member
Regular
 
Join Date: Jul 2011
Posts: 67
Cooling fan help!!

So on my 96 GT just wondering if there is any relay/module that belongs in between the cooling fan and the harness? When I bought the car it was missing the fan and harness plug for the fan. So I wired in a new plug but the fan still wont kick in. Any help would be great!
zrider07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-14-2011, 03:18 PM   #2
Registered Member
Regular
 
onesickstang01's Avatar
 
Join Date: May 2011
Posts: 441
Yes the ccrm. I know on 99-04 its in passenger side wheel well but i think on pre 99 its somewhere by air filter. It controls ac fuel pump fans
onesickstang01 is offline   Reply With Quote
Old 08-14-2011, 03:35 PM   #3
Registered Member
Regular
 
Join Date: Jul 2011
Posts: 67
K. So I just did a quick test and as soon as I unplug the ECT sensor for the PCM the fan will turn on. Would that mean the sensor is gone, or could it be the ccrm?
zrider07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-14-2011, 04:18 PM   #4
Registered Member
Regular
 
onesickstang01's Avatar
 
Join Date: May 2011
Posts: 441
Must be the sensor. If it was ccrm fan wouldnt turn on
onesickstang01 is offline   Reply With Quote
Old 08-14-2011, 04:51 PM   #5
Registered Member
Regular
 
Join Date: Jul 2011
Posts: 67
Any idea if the ccrm has to be grounded or not? Mine isn't.
zrider07 is offline   Reply With Quote
Old 08-14-2011, 05:19 PM   #6
Registered Member
Regular
 
onesickstang01's Avatar
 
Join Date: May 2011
Posts: 441
No the grounds are internal from the ecm.
onesickstang01 is offline   Reply With Quote
Old 08-14-2011, 05:31 PM   #7
Registered Member
Regular
 
Join Date: Jul 2011
Posts: 67
Ok I kinda thought so. Thanks.
zrider07 is offline   Reply With Quote
Old 08-15-2011, 07:25 PM   #8
Registered Member
Regular
 
Join Date: Jul 2011
Posts: 67
So I got a new ECT sensor and put it in today, it made no difference. I still can't get the fan to turn on unless the sensor is unplugged.
zrider07 is offline   Reply With Quote
Old 08-16-2011, 10:21 AM   #9
Registered Member
Regular
 
03GT88's Avatar
 
Join Date: Mar 2011
Region: Mississippi
Posts: 532
Have you checked fuses?
03GT88 is offline   Reply With Quote
Old 08-16-2011, 10:47 AM   #10
Registered Member
Regular
 
Join Date: Jul 2011
Posts: 67
Ya all the fuses are good. I've checked them a couple times!
zrider07 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
radiator fan shady Pre-2005 V6 Mustang 6 07-27-2011 01:42 PM
Cooling fan??? zrider07 1996-2004 Mustang GT 4 07-25-2011 10:38 PM
Overheating issue Edge4 1979-1995 Mustang GT 11 07-19-2011 10:06 PM
Cooling fan and AC problem, please help 95GTS 1979-1995 Mustang GT 4 07-08-2011 09:24 PM
94 mustang gt is running hot!!! 94 GT 1979-1995 Mustang GT 20 07-01-2011 03:45 PM

» Like Us On Facebook



03:01 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.