Left low beam headlight wont work but i will when i turn on high beams - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-05-2011, 07:51 PM   #1
Registered User
Newbie
 
p1blake04's Avatar
 
Join Date: Jun 2011
Posts: 9
Left low beam headlight wont work but i will when i turn on high beams

Left headlight won't work when low beams are in but when you turn high beams on they work fine I need help!
p1blake04 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-05-2011, 08:10 PM   #2
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Re: Left low beam headlight wont work but i will when i turn on high beams

Replace the bulb. 9007 bulb.

Two different filaments, one for high, one for low. Your low beam filament is blown.
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 09-05-2011, 10:36 PM   #3
Registered Member
Regular
 
GTtopgear's Avatar
 
Join Date: Jul 2011
Region: Michigan
Posts: 274
Quote:
Originally Posted by lowflyn
Replace the bulb. 9007 bulb.

Two different filaments, one for high, one for low. Your low beam filament is blown.
If that dosnt work it's the fuse. Happened to me and it took a min why it didn't work
__________________

02 GT : LT headers, H pipe, Cat back, 80mm TB, Intake, Strut tower bar, lightweight pullies All BBK, drilled and slotted rotors, Clear headlights, Eibach Pro Kit, Hid kit for both head and fog, chin spoiler,18' chrome 2010 GT wheels with nitto tires
GTtopgear is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-05-2011, 10:38 PM   #4
Registered User
Newbie
 
p1blake04's Avatar
 
Join Date: Jun 2011
Posts: 9
Yeah I had hid's but I went back to stock they still didn't work so it must be a fuse u know what exact fuse it is
p1blake04 is offline   Reply With Quote
Old 09-05-2011, 11:30 PM   #5
Registered Member
Regular
 
GTtopgear's Avatar
 
Join Date: Jul 2011
Region: Michigan
Posts: 274
Quote:
Originally Posted by p1blake04
Yeah I had hid's but I went back to stock they still didn't work so it must be a fuse u know what exact fuse it is
That's exactly what I did went from hid to stock. I don't remember witch one it was but I know it's not under the hood it's under the steering column
__________________

02 GT : LT headers, H pipe, Cat back, 80mm TB, Intake, Strut tower bar, lightweight pullies All BBK, drilled and slotted rotors, Clear headlights, Eibach Pro Kit, Hid kit for both head and fog, chin spoiler,18' chrome 2010 GT wheels with nitto tires
GTtopgear is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:01 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.