03 Mustang GT acceleration issue - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Join Mustang Evolution Today

Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-31-2011, 03:06 PM   #1
Registered Member
Zebs5408's Avatar
Join Date: Mar 2009
Region: Georgia
Posts: 800
03 Mustang GT acceleration issue

A few weeks ago for some reason at low rpms my engine feels like its bogging down...like its about to stale..when im in 5th gear crusin at 60mph i could feel it alot yesterday..when i barely hit the gas it feels like its choking...u can feel it in side the car...at high rpms or when accelerating fastly i can start to feel it now too...its like it skips then it fine then does it again..Idk if its my spark plugs..or some one put something in my gas tank or its crappy water down gas or what lol...Ive had no problems out of this car...engine has 152,000 miles on it....any guess what it could be? i know its alot of miles but im all about maintenance so the car has been babied!

04' mustang 3.9 40th Anniversary Edition- (V2 Vortech Supercharger, 38# injectors, 3.73 gears w/ T-lok, Predator Diablo, Mac cold air intake, Port & polished upper AND lower intake manifold, Mac Long Tube Headers, Mac o/r H pipe, flowmasters, 2.5 flowmaster tips)

03' Mustang GT (20" Cobra R's, 40 series Flowmasters)
Zebs5408 is offline   Reply With Quote
Old 10-31-2011, 05:15 PM   #2
Registered Member
ksrumbel's Avatar
Join Date: Feb 2011
Location: Hamburg
Region: Pennsylvania
Posts: 483
Could need a fuel filter.

ksrumbel is offline   Reply With Quote
Old 10-31-2011, 06:35 PM   #3
Registered Member
Beav's Avatar
Join Date: Feb 2011
Region: Kansas
Posts: 565
Re: 03 Mustang GT acceleration issue

Start with a fuel filter...

07 Roush 427R, Brembo 14" rotor and four piston calipers

05 GT Mustang, FRPP, FR X pipe, Hurst short throw,
American Racing Torque Thrust 10X20 wheels,
Granettelli tower brace, custom painted flat black grafix, Yellow Optima
Beav is offline   Reply With Quote
Old 11-01-2011, 06:02 AM   #4
Registered Member
t0t4lbl4ck0ut's Avatar
Join Date: May 2011
Posts: 711
Check your o2 sensors as well. Mine did a similar thing and it was the pass front o2
t0t4lbl4ck0ut is offline   Reply With Quote

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

« pulleys | Car show »
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
What mods can get 350+hp? Johnstonb93 2005-2010 V6 Mustang 82 11-01-2014 04:04 PM
1969 Mustang Coupe Restoration Project yellow99 Classic Mustangs 5 10-15-2011 10:05 AM
1995 Mustang SVT Cobra Project yellow99 1979-1995 Mustang GT 0 09-03-2011 05:51 PM
1971 Mustang Fastback Project yellow99 Classic Mustangs 0 09-03-2011 05:49 PM

» Like Us On Facebook

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

05:36 PM

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.