need help bad please help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-05-2012, 06:07 PM   #1
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
need help bad please help

my car has been off the road for almost a month now. it will not accelerate at all. when start it up it is fine. but once put a load on it then it just jumps and chokes out. i don't know what to do please help
Codysmustang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-05-2012, 06:24 PM   #2
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Re: need help bad please help

check your fuel pressure at the shrader valve on the fuel rail. I'd say it's either your fuel pump or your frps.
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 02-05-2012, 06:47 PM   #3
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
Re: need help bad please help

i changed out the fuel pump and filter already.. so where exactly do i need to check the fuel pressure?
Codysmustang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-05-2012, 07:06 PM   #4
Registered Member
Regular
 
02PONY's Avatar
 
Join Date: Nov 2011
Region: Indiana
Posts: 886
Sounds like fuel pressure regulator

---------- Post added at 08:06 PM ---------- Previous post was at 08:04 PM ----------

But don't think these have one any codes
__________________
02PONY is offline   Reply With Quote
Old 02-05-2012, 07:09 PM   #5
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
Re: need help bad please help

where is it exactly.. i have the all data for the car and it telling me that there is none..
Codysmustang is offline   Reply With Quote
Old 02-05-2012, 07:11 PM   #6
Registered Member
Regular
 
02PONY's Avatar
 
Join Date: Nov 2011
Region: Indiana
Posts: 886
So no codes and it dies as soon as u press the gas?
__________________
02PONY is offline   Reply With Quote
Old 02-05-2012, 07:26 PM   #7
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
Re: need help bad please help

it has codes. last time i looked had 12. 4 for O2 sensors ( which i changed the rear 2 and the other two close to the engine i believe are wielded to the exhaust) like 2 or 4 for evap.. and then apparently there are some throttle codes to.. i can get a list
Codysmustang is offline   Reply With Quote
Old 02-06-2012, 06:43 AM   #8
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by Codysmustang
it has codes. last time i looked had 12. 4 for O2 sensors ( which i changed the rear 2 and the other two close to the engine i believe are wielded to the exhaust) like 2 or 4 for evap.. and then apparently there are some throttle codes to.. i can get a list
Check your CAI bolts and make sure it didn't come loose. I have a JLT CAI and when I leave my car setting for a week it loosens around the throttle body and my car does the same thing. Pretty much it just sucks in unmonitored air in and your car can't accelerate worth crap.

If that checks out to be ok I'd say fuel pressure regulator, you can find the fuel pressure check valve on the fuel rail passenger side toward the front of the engine with a plastic black cap.
jjsg09 is offline   Reply With Quote
Old 02-06-2012, 06:46 AM   #9
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
I am missing a ring around the cai after the sensor. The piece came off. And I know where talking about on fuel rail. What am I soposed to do to check the pressure and all that?
Codysmustang is offline   Reply With Quote
Old 02-06-2012, 06:53 AM   #10
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by Codysmustang
I am missing a ring around the cai after the sensor. The piece came off. And I know where talking about on fuel rail. What am I soposed to do to check the pressure and all that?
That ring is very important you need to get it back on there your probably getting too much air after that sensor. It's very important to have everything tight on a CAI.

Go to a parts store and rent a fuel pressure tester. I rent mine from Auto Zone for $160 but it's fully refunded after you bring it back. Just match the right fitting on the fuel port hook the gauge to it. Turn your stang on and it should read around 40 for a good read out. If its surging up and down on the gauge it's probably your FPR going bad.
jjsg09 is offline   Reply With Quote
Old 02-06-2012, 08:39 AM   #11
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
Re: need help bad please help

ok will do.. and if it is the fpr where is it located at so i can replace it?
Codysmustang is offline   Reply With Quote
Old 02-06-2012, 01:47 PM   #12
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by Codysmustang
ok will do.. and if it is the fpr where is it located at so i can replace it?
I'm doing some research on a fpr on the 4.6 and there isn't one......huh. Well there is a fuel relay switch that can be going bad.
jjsg09 is offline   Reply With Quote
Old 02-06-2012, 01:59 PM   #13
Registered Member
Regular
 
Gster's Avatar
 
Join Date: Dec 2010
Region: Kentucky
Posts: 173
Quote:
Originally Posted by Codysmustang
I am missing a ring around the cai after the sensor. The piece came off. And I know where talking about on fuel rail. What am I soposed to do to check the pressure and all that?
That's your problem fix your CAI .
Gster is offline   Reply With Quote
Old 02-06-2012, 02:02 PM   #14
Moderator Emeritus
Regular
 
deadsp0t's Avatar
 
Join Date: Aug 2011
Location: MidWorld
Region: Other
Posts: 4,786
Quote:
Originally Posted by Gster

That's your problem fix your CAI .
Yes.. Cover all the basic stuff before throwing unnecessary parts at it
__________________
That's unimpressive
deadsp0t is offline   Reply With Quote
Old 02-06-2012, 02:44 PM   #15
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
Will do y'all thank you so much for the help.. Will the added air cause the car to throw throttle codes? I gonna try to get that list of codes up so can see bout fixing it
Codysmustang is offline   Reply With Quote
Old 02-06-2012, 04:11 PM   #16
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by Codysmustang
Will do y'all thank you so much for the help.. Will the added air cause the car to throw throttle codes? I gonna try to get that list of codes up so can see bout fixing it
Oh yea it did it to mine when my CAI came loose.
jjsg09 is offline   Reply With Quote
Old 02-06-2012, 04:25 PM   #17
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
Nice thank y'all I doin the work later today so I will let u no
Codysmustang is offline   Reply With Quote
Old 02-06-2012, 07:17 PM   #18
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
Re: need help bad please help

ok so put the clamp on and it runs! now it still kinda chokes out so still gonna check the fuel pressure relay.. but it could also be that the battery was to low.. had to jump it off.. but i will charge it over night then tomorrow i will take the battery completely out to clear all the codes. hopefully that gets rid of the throttle codes and maybe even the O2 codes as well. i will post the codes on here in the next hour. see what can do.. i really want y'all to know i really appreciate everything y'all have done to help me. THANK YOU SO MUCH
Codysmustang is offline   Reply With Quote
Old 02-07-2012, 08:03 PM   #19
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by Codysmustang
ok so put the clamp on and it runs! now it still kinda chokes out so still gonna check the fuel pressure relay.. but it could also be that the battery was to low.. had to jump it off.. but i will charge it over night then tomorrow i will take the battery completely out to clear all the codes. hopefully that gets rid of the throttle codes and maybe even the O2 codes as well. i will post the codes on here in the next hour. see what can do.. i really want y'all to know i really appreciate everything y'all have done to help me. THANK YOU SO MUCH
No problem bud just let us know what happens. Hope taking the battery out will clear up the rest of the problems.
jjsg09 is offline   Reply With Quote
Old 02-11-2012, 04:25 PM   #20
Registered Member
Regular
 
Codysmustang's Avatar
 
Join Date: Feb 2011
Region: Louisiana
Posts: 197
Re: need help bad please help

ok so i got the thing running and i think the filter needed to be changed.. i ran the car without it and did great for a bit.. then choked out. the problem is that i bout the car with the k&n cai on it. the base seems to have a 6" on it. i looked at the k&n at the car shops and auto zone and don't look the same.. and spectre filters go to 4".. so what now?
Codysmustang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Signs of a bad oxygen sensor 04machazblue 1979-1995 Mustang GT 33 01-24-2012 05:10 PM
Bad Lifters? Please help.. FORDGT14 1996-2004 Mustang GT 0 01-22-2012 04:03 PM
Bad Fuel Filter? chrissiesstang Pre-2005 V6 Mustang 4 11-09-2011 05:51 AM
96 SVT Cobra appears Superchip is bad opinions on my options please Spiney SVT Mustang 15 11-07-2011 08:34 AM
Bad luck... Blackedout Pre-2005 V6 Mustang 20 07-29-2011 08:50 AM

» Members Mustangs

Tonka

Borii

Linda

Doe_Rae_mi
Add your Mustang
» Like Us On Facebook



01:56 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.