Cleaned tb/plunum/maf now have problem - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-22-2012, 09:52 AM   #1
Registered Member
Regular
 
02PONY's Avatar
 
Join Date: Nov 2011
Region: Indiana
Posts: 886
Cleaned tb/plunum/maf now have problem

K I cleaned my air intake tube/maf/tb/plenum/iac I used the correct cleaners for each one also put new egr gasket air filter and sea foamed vacuum lines/and gas ever since when I get on it even a little it has hesitation up until around -3700-4000rpm anyone have idea wtf is wrong
__________________
02PONY is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-22-2012, 10:28 AM   #2
Registered Member
Regular
 
stampde's Avatar
 
Join Date: Oct 2010
Location: Manalapan
Region: New Jersey
Posts: 1,880
Re: Cleaned tb/plunum/maf now have problem

re-check all your vacum lines ,make sure they are all on
__________________
2011 GT Auto
stampde is offline   Reply With Quote
Old 02-22-2012, 10:31 AM   #3
Registered Member
Regular
 
02PONY's Avatar
 
Join Date: Nov 2011
Region: Indiana
Posts: 886
Ya I've checked a couple times even sprayed around vacuum lines intake plenum and all no change I rpm runs fine at idle and reving just under a load until the rpm's get half way then it comes back to life
__________________
02PONY is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-22-2012, 10:34 AM   #4
Registered Member
Regular
 
stampde's Avatar
 
Join Date: Oct 2010
Location: Manalapan
Region: New Jersey
Posts: 1,880
Re: Cleaned tb/plunum/maf now have problem

you may have nuked the TPS sensor ? that happens a lot when you clean the throttle body , I don't know why ? best thing to do is pop it off when cleaning throttle body ..........
__________________
2011 GT Auto
stampde is offline   Reply With Quote
Old 02-22-2012, 10:36 AM   #5
Registered Member
Regular
 
02PONY's Avatar
 
Join Date: Nov 2011
Region: Indiana
Posts: 886
Ok I ordered a tps and iac for my new bbk plenum/tb I'll try them whenever they show up
__________________
02PONY is offline   Reply With Quote
Old 02-26-2012, 09:33 PM   #6
Registered Member
Regular
 
02PONY's Avatar
 
Join Date: Nov 2011
Region: Indiana
Posts: 886
It was indeed the tps installed a new one runs like a champ
__________________
02PONY is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Could you awesome gentleman have any reccomendations on a cold air intake? memo232 Roush Mustang 10 03-22-2012 03:32 PM
battery now in trunk victory181 1996-2004 Mustang GT 2 02-22-2012 12:36 PM
95 gt problem jedpony 1979-1995 Mustang GT 5 02-19-2012 09:55 PM
Now heir this now heir this Mrsnow Shelby Mustang 1 02-19-2012 09:23 PM
Figured out the problem with my acceleration! I think Mustang_Madness 1996-2004 Mustang GT 0 02-19-2012 01:21 AM

» Like Us On Facebook



02:14 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.