help me please - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-27-2012, 09:31 PM   #1
Registered User
Newbie
 
jstn_hasty's Avatar
 
Join Date: Feb 2012
Region: Pennsylvania
Posts: 18
help me please

so i was driving around today like always and my car was running just fine, no loss of power nothing and i went a friends house and shut my car off, when i went to turn it on it started making this crazy loud knocking sound like inside the passenger side valve cover, i have good oil presure and the car runs fine still, so i listened for any vibration in the motor nothing, well the knocking went away but its still there just very quiet, so i pulled off the valve cover to look and see if maybe i smashed a lifter and nothing everything seems to be tight nothings loose all lifters look good no metal shaving inside and i have no idea whats causeing it to tap like i said it just started doing this out of the blue, someone please help meee!!!!!!!!!!!!
jstn_hasty is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-27-2012, 11:19 PM   #2
Registered Member
Regular
 
irishn8's Avatar
 
Join Date: Jan 2012
Region: Washington
Posts: 721
Check engine light? Any mods?
irishn8 is offline   Reply With Quote
Old 02-28-2012, 10:15 AM   #3
Registered User
Newbie
 
jstn_hasty's Avatar
 
Join Date: Feb 2012
Region: Pennsylvania
Posts: 18
check engine lights on cause of o2 sensor and not really head and intake and throttle body spacer thats it
jstn_hasty is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-28-2012, 10:45 AM   #4
Registered Member
Regular
 
CrimsonGT's Avatar
 
Join Date: Dec 2010
Region: Tennessee
Posts: 257
Um did you check your plugs might have blown one loose does it sound like its missing or just knocking
Good luck sorry to hear about the troubles
CrimsonGT is offline   Reply With Quote
Old 02-29-2012, 12:22 AM   #5
Registered User
Newbie
 
jstn_hasty's Avatar
 
Join Date: Feb 2012
Region: Pennsylvania
Posts: 18
im checking that tomorrow. thanks for all the help man
jstn_hasty is offline   Reply With Quote
Old 02-29-2012, 12:27 AM   #6
Moderator Emeritus
Regular
 
deadsp0t's Avatar
 
Join Date: Aug 2011
Location: MidWorld
Region: Other
Posts: 4,786
Quote:
Originally Posted by jstn_hasty
im checking that tomorrow. thanks for all the help man
Does it speed up at the same pace as revs, or slower? Valve train runs at 1/2 crank speed.
__________________
That's unimpressive
deadsp0t is offline   Reply With Quote
Old 02-29-2012, 12:28 AM   #7
Registered Member
Regular
 
Eturner's Avatar
 
Join Date: Aug 2011
Region: Michigan
Posts: 3,257
Quote:
Originally Posted by jstn_hasty
im checking that tomorrow. thanks for all the help man
You said your engine light is on because of your O2 sensor!.. I would still run a scanner on your car and see if any other codes popped!..
Eturner is offline   Reply With Quote
Old 02-29-2012, 04:49 PM   #8
Registered User
Newbie
 
jstn_hasty's Avatar
 
Join Date: Feb 2012
Region: Pennsylvania
Posts: 18
it was a loud knock now just a small tap and gets louder when you rev it. it dont seem like its missing
jstn_hasty is offline   Reply With Quote
Old 02-29-2012, 10:07 PM   #9
Registered Member
Regular
 
1quick4.6's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 82
Lifters
1quick4.6 is offline   Reply With Quote
Old 03-01-2012, 07:37 PM   #10
Registered Member
Regular
 
jdmeaux's Avatar
 
Join Date: Feb 2012
Region: Louisiana
Posts: 22
Re: help me please

yup...lifters
__________________
1997 CVPI ** ex-U.S. Marshall Service (the CAR) I don't think it was stock from them ** 13.26@107.24 MPH w/ me, my tools, and a full tank Added CAI, Niche 19 x 8.5" wheels with 245/45ZR19 rubbers, and a complete front end rebuilt with poly
A Super Duty Mustang Sedan

My Avatar is a picture of my Dream Machine
jdmeaux is offline   Reply With Quote
Old 03-01-2012, 07:53 PM   #11
Registered Member
Regular
 
Mathew r Wright's Avatar
 
Join Date: Sep 2011
Region: Oklahoma
Posts: 470
Re: help me please

I don't know man sounds like a header exhaust leak to me I'd check there...
Mathew r Wright is offline   Reply With Quote
Old 03-01-2012, 09:11 PM   #12
Registered Member
Regular
 
1quick4.6's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 82
Also check your chain guides
1quick4.6 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Show me your rear Beau Pictures and Videos 5434 10-03-2017 08:41 PM
Where can I buy this!!? HELP! 83 Fox 1979-1995 Mustang GT 2 02-27-2012 08:00 PM
Plasti Dip Help! BeasGT 1996-2004 Mustang GT 33 02-27-2012 12:34 PM
Looking at a used T45 need help!!! 1995boss 1979-1995 Mustang GT 2 02-27-2012 12:15 AM
NEED HELP ASAP!!!!!!!!!!!! 99ford 2005-2010 V6 Mustang 25 02-26-2012 10:05 PM

» Like Us On Facebook



09:14 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.