check engine light - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-15-2012, 05:09 PM   #1
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
check engine light

I washed my car yesterday and drove it up the road and back and parked it in the garage, everything was fine. It ran normal like always. But today I got it out and started it and its running really rough, and my check engine light is blinking. I changed my spark plugs a while back and I found some water on my coil. But I didn't think to much of it cause it wasn't a lot, and it ran fine until now. It's a 02 gt automatic and I'm about to turn over 182,000 miles. Just would like some input on what it could be.
2002Gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-15-2012, 05:16 PM   #2
Registered Member
Regular
 
AgentOrange's Avatar
 
Join Date: Oct 2011
Region: Florida
Posts: 991
It could be a whole lot of different things. A flashing CEL is usually bad news. Get us some codes and we will all do our best..
AgentOrange is offline   Reply With Quote
Old 03-15-2012, 09:55 PM   #3
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
I'm goin to check my vacuum hoses tomorrow. Hopefully that's it!
2002Gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-16-2012, 10:14 PM   #4
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Found out just a o2 sensor!
2002Gt is offline   Reply With Quote
Old 03-16-2012, 10:40 PM   #5
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by 2002Gt
Found out just a o2 sensor!
Not bad at 182,000 I'm finding out these cars are pretty reliable.
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 03-17-2012, 07:16 AM   #6
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Quote:
Originally Posted by 99ford

Not bad at 182,000 I'm finding out these cars are pretty reliable.
Yea me too! I bought it about a year ago and its been my DD since then. It's been a really good car!
2002Gt is offline   Reply With Quote
Old 03-18-2012, 07:45 AM   #7
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
I replaced the o2 sensor and it still feels like its missing a little bit. No cel though, but my gas mileage has went to crap. It was bank 1 sensor 1. Which was the passenger side right?
2002Gt is offline   Reply With Quote
Old 03-18-2012, 12:48 PM   #8
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Anybody have any input?
2002Gt is offline   Reply With Quote
Old 03-18-2012, 12:58 PM   #9
Registered Member
Regular
 
Arron's racecar's Avatar
 
Join Date: Mar 2008
Region: Nevada
Posts: 341
Yep passenger side before the cat. It may take a while for you car to "relearn" the new sensor and start giving the proper AFRs
__________________
2004 GT current mods : CAI, BBK Short throw shifter TB and UDPs, SCT x3/SF3 with BAMA Perfomance tunes Roush body kit, roush side skirt exhaust and paint.
Arron's racecar is offline   Reply With Quote
Old 03-18-2012, 01:23 PM   #10
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
About how long? I drove it about 30 miles back from the shop.
2002Gt is offline   Reply With Quote
Old 03-18-2012, 03:08 PM   #11
Registered Member
Regular
 
Arron's racecar's Avatar
 
Join Date: Mar 2008
Region: Nevada
Posts: 341
Wow it should have been good after about 10-15 miles. Did you remove the neg battery terminal or clear the DTCs after replacing the sensor?
__________________
2004 GT current mods : CAI, BBK Short throw shifter TB and UDPs, SCT x3/SF3 with BAMA Perfomance tunes Roush body kit, roush side skirt exhaust and paint.
Arron's racecar is offline   Reply With Quote
Old 03-18-2012, 04:00 PM   #12
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Yea I did. I just bought some maf cleaner and I'm goin to try that
2002Gt is offline   Reply With Quote
Old 03-18-2012, 05:05 PM   #13
Registered Member
Regular
 
Arron's racecar's Avatar
 
Join Date: Mar 2008
Region: Nevada
Posts: 341
Yeah go ahead and clean the MAF and maybe check the plugs
__________________
2004 GT current mods : CAI, BBK Short throw shifter TB and UDPs, SCT x3/SF3 with BAMA Perfomance tunes Roush body kit, roush side skirt exhaust and paint.
Arron's racecar is offline   Reply With Quote
Old 03-18-2012, 06:33 PM   #14
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
I replaced the plugs last month. So I know they are good. I need to check my coils though.
2002Gt is offline   Reply With Quote
Old 03-19-2012, 07:55 PM   #15
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Engine light came back on, went and got my cel checked and its a mis fire in cylinder 4. I replaced my plugs about 2 months ago, and my coils looked ok then but its probably time for them be changed anyway. 182,000 miles
2002Gt is offline   Reply With Quote
Old 03-19-2012, 11:57 PM   #16
Registered Member
Regular
 
Arron's racecar's Avatar
 
Join Date: Mar 2008
Region: Nevada
Posts: 341
Quote:
Originally Posted by 2002Gt
Engine light came back on, went and got my cel checked and its a mis fire in cylinder 4. I replaced my plugs about 2 months ago, and my coils looked ok then but its probably time for them be changed anyway. 182,000 miles
Yeah I would definitely change the coils.
__________________
2004 GT current mods : CAI, BBK Short throw shifter TB and UDPs, SCT x3/SF3 with BAMA Perfomance tunes Roush body kit, roush side skirt exhaust and paint.
Arron's racecar is offline   Reply With Quote
Old 03-21-2012, 09:15 PM   #17
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Well I changed the coils but I guess I have a bad plug. I haven't checked my vacuum lines (kinda dreading doing that lol) but I'm hoping that one plug is bad!
2002Gt is offline   Reply With Quote
Old 03-22-2012, 04:18 AM   #18
Registered Member
Regular
 
FORDGT14's Avatar
 
Join Date: Aug 2011
Location: Surprise
Region: Arizona
Posts: 614
Sounds like a bad coil or bad plug to me
FORDGT14 is offline   Reply With Quote
Old 03-23-2012, 07:55 PM   #19
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Vacuum problem. Cones to find out the guy I bought the car from put a heater hose on the vacuum lines
2002Gt is offline   Reply With Quote
Old 03-23-2012, 08:01 PM   #20
Road Trip!
 
Join Date: Mar 2012
Region: Louisiana
Posts: 1,176
Does anybody know if high flow cats will make the check engine light come on?
Ryan7racin is offline   Reply With Quote
Old 03-23-2012, 09:58 PM   #21
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
Quote:
Originally Posted by Ryan7racin
Does anybody know if high flow cats will make the check engine light come on?
I would think not but somebody with more experience can chime in and correct me if I'm wrong
BigB227 is offline   Reply With Quote
Old 03-24-2012, 01:49 PM   #22
Registered Member
Regular
 
AgentOrange's Avatar
 
Join Date: Oct 2011
Region: Florida
Posts: 991
Quote:
Originally Posted by BigB227

I would think not but somebody with more experience can chime in and correct me if I'm wrong
They shouldn't give you any issues. They are there for emmissions purposes, and if you have a CEL, you fail a test instantly which would defeat their purpose. So long story short, as long as they are in good shape still they should function fine and shouldn't give you a code. If you don't have any emmissions laws where you live, I suggest an off road H and a tuner to set the O2s to "always happy".
AgentOrange is offline   Reply With Quote
Old 03-24-2012, 01:58 PM   #23
Registered User
Newbie
 
Join Date: Jan 2012
Region: Texas
Posts: 6
Re: check engine light

Sounds like the problem I had just last week, It was the ignition coil. I replaced all 8 and replaced all 8 plugs. I also had a misfire in the number 4 cylinder. It is running GREAT now! Hope this information helps.
__________________
2002 Mustang GT
vevo08 is offline   Reply With Quote
Old 03-28-2012, 08:55 PM   #24
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Finally got the time to check everything. Comes down to the intake manifold leaking. I don't have the money to buy a aluminum one so I'm going to get the Ford racing one.
2002Gt is offline   Reply With Quote
Old 03-28-2012, 09:13 PM   #25
Registered Member
Regular
 
CodyNelson's Avatar
 
Join Date: Apr 2011
Region: West Virgina
Posts: 1,204
Re: check engine light

the ford racing one will be fine man. people run them up to 600 hp or more. they are better than people give them credit for
CodyNelson is offline   Reply With Quote
Old 03-28-2012, 09:34 PM   #26
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Thanks. Any power increase? Or better throttle response?
2002Gt is offline   Reply With Quote
Old 03-28-2012, 09:54 PM   #27
Registered Member
Regular
 
CodyNelson's Avatar
 
Join Date: Apr 2011
Region: West Virgina
Posts: 1,204
Quote:
Originally Posted by 2002Gt
Thanks. Any power increase? Or better throttle response?
Unfortunately no. It's the same as the stock intake with the aluminum coolant crossover.
CodyNelson is offline   Reply With Quote
Old 03-29-2012, 03:38 PM   #28
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Well as long as it gets fixed!
2002Gt is offline   Reply With Quote
Old 03-29-2012, 03:54 PM   #29
Registered Member
Regular
 
murraydylan1993's Avatar
 
Join Date: Feb 2012
Region: Illinois
Posts: 342
Ive had my cel on for years now haaha i had my friend run it through the handheld and it says its somethin with emissions. Haha everything runs fine just kinda annoying at night
__________________
1/4 mile at a time.
murraydylan1993 is offline   Reply With Quote
Old 03-29-2012, 04:41 PM   #30
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
Quote:
Originally Posted by murraydylan1993
Ive had my cel on for years now haaha i had my friend run it through the handheld and it says its somethin with emissions. Haha everything runs fine just kinda annoying at night
Same with me lol the only time the light bothers me is when someone gets in my car and assumes something's wrong with it lol
BigB227 is offline   Reply With Quote
Old 03-29-2012, 05:19 PM   #31
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Lol lucky for me I don't have to worry about emissions!
2002Gt is offline   Reply With Quote
Old 03-29-2012, 10:18 PM   #32
Registered Member
Regular
 
murraydylan1993's Avatar
 
Join Date: Feb 2012
Region: Illinois
Posts: 342
Quote:
Originally Posted by 2002Gt
Lol lucky for me I don't have to worry about emissions!
Me neither thank god
__________________
1/4 mile at a time.
murraydylan1993 is offline   Reply With Quote
Old 03-30-2012, 10:33 PM   #33
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Yea I haven't got my off road x pipe yet. But I'm thinkin about running super 44 flows with slp off road x. But right now I have a muffler delete with my stock h
2002Gt is offline   Reply With Quote
Old 03-30-2012, 11:47 PM   #34
Registered Member
Regular
 
Gobabygo67's Avatar
 
Join Date: Aug 2011
Region: Georgia
Posts: 292
Quote:
Originally Posted by 2002Gt
Yea I haven't got my off road x pipe yet. But I'm thinkin about running super 44 flows with slp off road x. But right now I have a muffler delete with my stock h
I have a similar setup but mine is Bassani off road x and super 44s
Gobabygo67 is offline   Reply With Quote
Old 03-31-2012, 07:46 AM   #35
Registered Member
Regular
 
2002Gt's Avatar
 
Join Date: May 2011
Region: Georgia
Posts: 167
Quote:
Originally Posted by Gobabygo67

I have a similar setup but mine is Bassani off road x and super 44s
How do you like it?
2002Gt is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Tags
check engine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MAC ProChamber & V6 Engine robb15033 Pre-2005 V6 Mustang 8 03-25-2012 12:55 AM
Wierd idle shakes and engie light Dylanbest 1996-2004 Mustang GT 39 03-20-2012 01:13 PM
Engine shaking at start up 813floridaracin Pre-2005 V6 Mustang 5 03-14-2012 09:54 PM
Engine shops? WhiteCobra94 1979-1995 Mustang GT 10 03-13-2012 03:59 PM
engine block color, valve covers and others questions lemons95 Pre-2005 V6 Mustang 3 03-13-2012 09:37 AM

» Like Us On Facebook



05:12 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.