engine problem? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-25-2012, 08:04 PM   #1
Registered Member
Regular
 
StackeStang's Avatar
 
Join Date: Feb 2012
Region: Alabama
Posts: 259
engine problem?

I was driving the other day and my car acted like it was going to die, and as I pulled into the gas station it did die. I thought it may have just been bad gas in the car because I got gas and it ran fine. but today when i would accelerate I heard a strange knocking sound coming from the engine. any ideas?
StackeStang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-25-2012, 09:09 PM   #2
Registered Member
Regular
 
Mathew r Wright's Avatar
 
Join Date: Sep 2011
Region: Oklahoma
Posts: 470
Re: engine problem?

Sounds like a vacuum leak to me, cause when you have one, the motor will pings and peg like as if its air fuel is off... I found this was the problem when I first bought mine. It was just because the breather tube from the valve cover on the passenger side to the the plenum was dry rotted... You know how it's got that lil 90 degree hose that connects to the plug that connects to the valve cover ya that was it... Also the cold air intake was loose so had to tighten that up to... So I'd just look around or get it pressure checked, however ya wanna do it, hey maybe even ur runnin lean but I really don't wanna say that to worry ya. Try Changing the fuel filter, heck run it to auto store code check it see if they pull something up idnk just tryin to advise ya...
Mathew r Wright is offline   Reply With Quote
Old 03-25-2012, 09:21 PM   #3
Registered Member
Regular
 
Eturner's Avatar
 
Join Date: Aug 2011
Region: Michigan
Posts: 3,257
Quote:
Originally Posted by StackeStang
I was driving the other day and my car acted like it was going to die, and as I pulled into the gas station it did die. I thought it may have just been bad gas in the car because I got gas and it ran fine. but today when i would accelerate I heard a strange knocking sound coming from the engine. any ideas?
1. If you have anyway of checking the codes, such as with a tuner, then do that!.. If not then go to AutoZone and ask them to run a scanner on your car!.. 2. Does your idle seem to be a bit rough?.. If so then it might be a bad coil or plug!.. 3. I also agree and say to check your hoses and intake fittings!..
Eturner is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-25-2012, 10:36 PM   #4
Registered Member
Regular
 
StackeStang's Avatar
 
Join Date: Feb 2012
Region: Alabama
Posts: 259
Re: engine problem?

the check engine light isn't coming on so i didn't think to check with my tuner... i may do that. and yeah I've had issues with the vacuum hose you mentioned, i'll check that. the intake should be fine i tightened it well just a couple months ago when i got my CAI. i plan on getting new plugs very soon too. thanks for the info guys!
StackeStang is offline   Reply With Quote
Old 03-25-2012, 10:57 PM   #5
Registered Member
Regular
 
Eturner's Avatar
 
Join Date: Aug 2011
Region: Michigan
Posts: 3,257
Quote:
Originally Posted by StackeStang
the check engine light isn't coming on so i didn't think to check with my tuner... i may do that. and yeah I've had issues with the vacuum hose you mentioned, i'll check that. the intake should be fine i tightened it well just a couple months ago when i got my CAI. i plan on getting new plugs very soon too. thanks for the info guys!
Some times your car will pickup a code but not throw the warning light I imeadiatly!..
Eturner is offline   Reply With Quote
Old 03-27-2012, 01:04 AM   #6
Registered Member
Regular
 
Mathew r Wright's Avatar
 
Join Date: Sep 2011
Region: Oklahoma
Posts: 470
Quote:
Originally Posted by Eturner

Some times your car will pickup a code but not throw the warning light I imeadiatly!..
Yes that's true I was runnin lean and didn't even know it...
Mathew r Wright is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
engine cleaning eswinty 2011-2014 V6 Mustang 9 03-31-2012 11:37 PM
check engine light 2002Gt 1996-2004 Mustang GT 48 03-31-2012 08:11 PM
1966 Mustang ammeter problem Gatorlee12 Classic Mustangs 2 03-30-2012 09:54 PM
Tranny problem? Eltwo 2011-2014 V6 Mustang 12 03-27-2012 09:50 PM
MAC ProChamber & V6 Engine robb15033 Pre-2005 V6 Mustang 8 03-25-2012 12:55 AM

» Like Us On Facebook



02:36 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.