A few issues - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-26-2012, 08:49 AM   #1
Registered User
Newbie
 
Bearden86's Avatar
 
Join Date: Mar 2012
Region: Texas
Posts: 18
A few issues

Hey everyone I bought a 04 GT about a moth ago with 100k it's a pretty clean mustang. I purchased a CAI from AM just the cheap 89 dollar one and a day after I installed it by SES light came on the codes where bank 1 and bank 2 lean. The car is idling a little weird it seems to rise and fall it almost sounds like a cam. I seem to be missing a little power to but I'm not sure I'm still not use to the car. I checked all the vacuum hoses but can't seem to find any leaks. Any suggestions?
Bearden86 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-26-2012, 09:17 AM   #2
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Recheck your CAI for leaks...I bet that's it
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 03-26-2012, 09:27 AM   #3
Registered User
Newbie
 
Bearden86's Avatar
 
Join Date: Mar 2012
Region: Texas
Posts: 18
You can use carb cleaner to check correct
Bearden86 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-26-2012, 11:40 PM   #4
Registered User
Newbie
 
Teneys97GT's Avatar
 
Join Date: Mar 2012
Region: Washington
Posts: 6
MAF SENSOR
Teneys97GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Issues cruiser4life Classic Mustangs 5 03-27-2012 08:57 PM
tryn to save a few bucks jdavis96gt 1996-2004 Mustang GT 10 03-26-2012 10:52 PM
tryn to save a few bucks jdavis96gt 1996-2004 Mustang GT 0 03-25-2012 01:32 PM
Anyone else owned a few decades...? DaYanks4Ev Pre-2005 V6 Mustang 55 03-21-2012 03:03 AM

» Like Us On Facebook



12:41 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.