98 gt (NPI) choking on top end of rpm's - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-27-2012, 05:44 PM   #1
Registered Member
Regular
 
leviz79's Avatar
 
Join Date: Sep 2011
Location: La Porte
Region: Texas
Posts: 30
98 gt (NPI) choking on top end of rpm's

I had this problem before- after the car got hot from alot of city driving when I have it loaded in like 1st, 2nd or 3rd gear and heavy on the gas the motor would choke out on me (stutter) around 5-6k rpms, it runs smooth any other time or when its been sitting fir a long time. Ive changed the plugs, wires, did a fuel injection clean at the ford dealership, all 4 new 02 sensors, fixing to change out my charcoal canister. Please help if any tips on whats going on. Thank you.
leviz79 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-27-2012, 07:23 PM   #2
Registered Member
Regular
 
1quick4.6's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 82
Mine did the same and i changed the egr vacuum solenoid and cleaned the mass airfloe with mass air cleaner and fixed it
1quick4.6 is offline   Reply With Quote
Old 03-27-2012, 07:42 PM   #3
Registered Member
Regular
 
Join Date: Mar 2012
Region: California
Posts: 31
Is there any possibility of the engine flooding?
Chaise33 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-27-2012, 08:02 PM   #4
Registered Member
Regular
 
1quick4.6's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 82
Quote:
Originally Posted by Chaise33
Is there any possibility of the engine flooding?
What do u mean? Too much fuel?
1quick4.6 is offline   Reply With Quote
Old 03-27-2012, 09:34 PM   #5
Registered Member
Regular
 
leviz79's Avatar
 
Join Date: Sep 2011
Location: La Porte
Region: Texas
Posts: 30
I dont think its flooding out cause its fine at all ranges of the rpm's except around 5-6k, it runs smooth and even on normal to mildly hard throttle it responds well ots just when I get on it HARD, she's good up untill those high rpm's. It did it to me about a couple months back and was good up untill today is when it started up. I do need to look into changing out some emission items like that egr solenoid, and valve ect... Could that be a victim since they are original, not throwing up any codes for them items either.
leviz79 is offline   Reply With Quote
Old 03-27-2012, 09:58 PM   #6
Registered Member
Regular
 
1quick4.6's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 82
Quote:
Originally Posted by leviz79
I dont think its flooding out cause its fine at all ranges of the rpm's except around 5-6k, it runs smooth and even on normal to mildly hard throttle it responds well ots just when I get on it HARD, she's good up untill those high rpm's. It did it to me about a couple months back and was good up untill today is when it started up. I do need to look into changing out some emission items like that egr solenoid, and valve ect... Could that be a victim since they are original, not throwing up any codes for them items either.
Certainly
1quick4.6 is offline   Reply With Quote
Old 03-27-2012, 10:16 PM   #7
Registered Member
Regular
 
leviz79's Avatar
 
Join Date: Sep 2011
Location: La Porte
Region: Texas
Posts: 30
Ill go ahead tomorrow and change out at least the egr valve and solenoid and let you know how that goes. Thanks alot for your help 1quick4.6.
leviz79 is offline   Reply With Quote
Old 03-27-2012, 11:02 PM   #8
Registered Member
Regular
 
1quick4.6's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 82
Quote:
Originally Posted by leviz79
Ill go ahead tomorrow and change out at least the egr valve and solenoid and let you know how that goes. Thanks alot for your help 1quick4.6.
Anytime let me know hiw it goes
1quick4.6 is offline   Reply With Quote
Old 03-28-2012, 09:17 AM   #9
Registered Member
Regular
 
leviz79's Avatar
 
Join Date: Sep 2011
Location: La Porte
Region: Texas
Posts: 30
Hey there 1quick4.6 just letting you know I went to auto zone this morning and bought my new egr and vacc. Slnd, indtalled and my idle is alot smoother and top end power situation has not been acting up so far. I greatly appreciate your help. Thank you.
leviz79 is offline   Reply With Quote
Old 03-28-2012, 05:35 PM   #10
Registered Member
Regular
 
1quick4.6's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 82
Quote:
Originally Posted by leviz79
Hey there 1quick4.6 just letting you know I went to auto zone this morning and bought my new egr and vacc. Slnd, indtalled and my idle is alot smoother and top end power situation has not been acting up so far. I greatly appreciate your help. Thank you.
Your welcome, anytime
1quick4.6 is offline   Reply With Quote
Old 04-06-2012, 12:42 AM   #11
Registered Member
Regular
 
leviz79's Avatar
 
Join Date: Sep 2011
Location: La Porte
Region: Texas
Posts: 30
Well its doing it again. Next im gonna clean my mass air flow sensor.
leviz79 is offline   Reply With Quote
Old 04-06-2012, 12:48 AM   #12
Registered Member
Regular
 
1quick4.6's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 82
Clean your mass airflow with maf cleaner only, then clean out your throttle body with cleaner, could also be evap purge valve solenoid
1quick4.6 is offline   Reply With Quote
Old 04-12-2012, 01:08 AM   #13
Registered Member
Regular
 
leviz79's Avatar
 
Join Date: Sep 2011
Location: La Porte
Region: Texas
Posts: 30
once again your right. i cleaned out the MAF and scrubbed my T/B and its running strong. thanks alot again.
leviz79 is offline   Reply With Quote
Old 04-12-2012, 01:14 AM   #14
Registered Member
Regular
 
1quick4.6's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 82
Anytime man
1quick4.6 is offline   Reply With Quote
Old 04-12-2012, 09:14 AM   #15
Registered Member
Regular
 
Supersnake4.6's Avatar
 
Join Date: Nov 2010
Region: Florida
Posts: 160
Also the stock coil packs in 96 thru 98 gt only only good toabout 5700 rpm msd would help alot
Supersnake4.6 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Extensively Modified 1993 GT For Sale Trojan Horse FYI Ads | Recently Listed 5 04-06-2012 07:22 PM
Go Pro On A Mustang GP3GT 1996-2004 Mustang GT 20 04-01-2012 12:51 PM
Loss of horsepower? Doe_Rae_mi 1996-2004 Mustang GT 6 03-29-2012 09:34 PM
17" tires recommendations for 1999 Mustang GT magnum1331 1996-2004 Mustang GT 13 03-28-2012 07:45 PM
2010 axle backs on 2005 tc x 4 2005-2010 Mustang GT 4 03-27-2012 04:49 PM

» Like Us On Facebook



06:46 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.