need help... new tb&plenum - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-28-2012, 04:12 PM   #1
Registered Member
Regular
 
imhooked's Avatar
 
Join Date: Feb 2012
Region: New York
Posts: 254
need help... new tb&plenum

if anyone knows... i installed bbk 70mm and stack racing plenum today.

car fired right up (as expected!) and seems to idle fine. after car completely warmed up and driven about some, idle rests nicely at about 750 in neutral. it does first drop to 1000, and then takes second or to to drop to all the way 750. (was wondering if this is normal or not?). NOTE i have not tried adjusting idle (YET).

i did think i smelled something like exhaust (or maybe unburned gas?)in cockpit during my ride, which may be my imagination, but i am pretty sensitive to this stuff. after i parked car, opened hood revved engine couple times, went about 1/2 way to WOT and sounded like i almost got a little backfire?! did i miss something, computer need time to adjust, or nothing to be alarmed about?

also note: i am quite certain everything is reconnected, and tightened. i do have a K&N caik and no other current mods although the exhaust and SCT tuner are next. any help appreciated-
imhooked is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-28-2012, 04:22 PM   #2
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
I could be wrong but it could be due
To you not having the car tuned for the new throttle body, maybe putting the tune on will fix your problem
BigB227 is offline   Reply With Quote
Old 03-28-2012, 04:36 PM   #3
Registered Member
Regular
 
imhooked's Avatar
 
Join Date: Feb 2012
Region: New York
Posts: 254
Re: need help... new tb&plenum

yup was wondering that myself.

also wasn't sure but on acceleration (even before i installed the parts) i had been having some 'vibration', which i had initially attributed to brakes or tires, but now am wondering if engine may be missing a little. maybe time for new plugs? car only has 55000 miles and pretty well cared for as i'm original owner, but who knows
imhooked is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-28-2012, 04:41 PM   #4
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
Quote:
Originally Posted by imhooked
yup was wondering that myself.

also wasn't sure but on acceleration (even before i installed the parts) i had been having some 'vibration', which i had initially attributed to brakes or tires, but now am wondering if engine may be missing a little. maybe time for new plugs? car only has 55000 miles and pretty well cared for as i'm original owner, but who knows
Yeah you never know and putting I new plugs wouldn't hurt
BigB227 is offline   Reply With Quote
Old 03-29-2012, 05:55 AM   #5
Registered Member
Regular
 
imhooked's Avatar
 
Join Date: Feb 2012
Region: New York
Posts: 254
Re: need help... new tb&plenum

was thinking... i didn't have a new egr valve gasket. the old one was either permatex gasket seal type, or just disintegrated. was wondering if that might have be a problem, but i will replace it anyway when get a chance

engine is running better. took it out and again last night and she goes pretty good! as far as the tuner goes, maybe it will help but as i only used 70mm tb figured engine would adjust a/f on it's own really not sure if necessary

i think the plugs, exhaust(o/r h and new cat back), and tuner will certainly wake 'er up a bit more!
imhooked is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New 2012 Ford Mustang 5.0 mods Sprintradc 2011-2014 Mustang GT 15 03-29-2012 09:24 AM
New rear look, good or bad Dmay65 Classic Mustangs 8 03-29-2012 12:21 AM
Need advise "again" !!! 89 coupe 1979-1995 Mustang GT 9 03-28-2012 06:07 PM
Pros or cons b&m hammer shifter 02utahgt 1996-2004 Mustang GT 5 03-28-2012 11:54 AM
Trade in 2010 for a new 2012 Teboidro 2011-2014 Mustang GT 31 03-28-2012 09:49 AM

» Like Us On Facebook



08:55 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.