Plenum ? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-18-2012, 07:11 PM   #1
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Plenum ?

Is there a gasket between it and the intake manifold? Advance couldn't find it in their computer?!?!? Does it need one?? Is the one reusable??? What do I need to do?
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-18-2012, 07:22 PM   #2
Filibuster
 
Join Date: Aug 2011
Region: Illinois
Posts: 1,656
Im not familiar with mod motors,but id say it has a gasket otherwise there'd be a possible vacuum leak..

---------- Post added at 07:22 PM ---------- Previous post was at 07:19 PM ----------

And if its a quality gasket in good shape I believe that gasket can be reused...
XXSTEVEO66 is offline   Reply With Quote
Old 04-18-2012, 07:50 PM   #3
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
No there's not. If you have the factory plastic intake it has a rubber ring at the top. That's the gasket.
jjsg09 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-18-2012, 08:16 PM   #4
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Quote:
Originally Posted by jjsg09
No there's not. If you have the factory plastic intake it has a rubber ring at the top. That's the gasket.
Cool beans...it's going on tomorrow!!!
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 04-18-2012, 08:25 PM   #5
Filibuster
 
Join Date: Aug 2011
Region: Illinois
Posts: 1,656
Quote:
Originally Posted by jjsg09
No there's not. If you have the factory plastic intake it has a rubber ring at the top. That's the gasket.
well then that explains why they couldn't find the gasket at advanced...
XXSTEVEO66 is offline   Reply With Quote
Old 04-18-2012, 08:29 PM   #6
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Quote:
Originally Posted by XXSTEVEO66

well then that explains why they couldn't find the gasket at advanced...
Well actually . they did find a rubber and looking gasket...but it didn't match our thought pattern of what it should look like
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 04-18-2012, 08:32 PM   #7
Registered User
Newbie
 
STANG BOYZ's Avatar
 
Join Date: Apr 2012
Region: California
Posts: 11
What does it mean when u get this yellow light light in the dash board that looks like a spray can with a fan in it.
STANG BOYZ is offline   Reply With Quote
Old 04-18-2012, 09:17 PM   #8
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Quote:
Originally Posted by STANG BOYZ
What does it mean when u get this yellow light light in the dash board that looks like a spray can with a fan in it.
Yo shiots about to blow up!!!


J/k idk...do u have the manual??

Post a pic of it..
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 04-18-2012, 09:43 PM   #9
Registered User
Newbie
 
STANG BOYZ's Avatar
 
Join Date: Apr 2012
Region: California
Posts: 11
Lol no I don't have the Manuel but its like a duracell battery with an x in the middle
STANG BOYZ is offline   Reply With Quote
Old 04-18-2012, 09:51 PM   #10
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Quote:
Originally Posted by STANG BOYZ
Lol no I don't have the Manuel but its like a duracell battery with an x in the middle


Click image for larger version

Name:	image-181049414.jpg
Views:	114
Size:	142.4 KB
ID:	47555

Which one?

If your talking about number 14 it's traction control...
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 04-18-2012, 10:01 PM   #11
Registered Member
Regular
 
Mmustang01's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 186
Re: Plenum ?

Traction control
Mmustang01 is offline   Reply With Quote
Old 04-18-2012, 10:04 PM   #12
Filibuster
 
Join Date: Aug 2011
Region: Illinois
Posts: 1,656
Quote:
Originally Posted by 2002VertGT

Which one?

If your talking about number 14 it's traction control...
Well atleast you got your answer of your question before you participated in your own thread being jacked lol
XXSTEVEO66 is offline   Reply With Quote
Old 04-18-2012, 10:06 PM   #13
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Quote:
Originally Posted by XXSTEVEO66

Well atleast you got your answer of your question before you participated in your own thread being jacked lol
Yeah I know right....
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 04-18-2012, 10:10 PM   #14
Registered User
Newbie
 
STANG BOYZ's Avatar
 
Join Date: Apr 2012
Region: California
Posts: 11
Thanx for the picture very helpful but Its not on there I have a 99mustang gt 35th anniversary
STANG BOYZ is offline   Reply With Quote
Old 04-18-2012, 10:25 PM   #15
Registered Member
Regular
 
CodyNelson's Avatar
 
Join Date: Apr 2011
Region: West Virgina
Posts: 1,204
Low coolant maybe
CodyNelson is offline   Reply With Quote
Old 04-18-2012, 10:45 PM   #16
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Quote:
Originally Posted by STANG BOYZ
Thanx for the picture very helpful but Its not on there I have a 99mustang gt 35th anniversary
That should be the same cluster for 94-04...take a picture of it for us and post it...
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 04-18-2012, 11:07 PM   #17
Registered User
Newbie
 
STANG BOYZ's Avatar
 
Join Date: Apr 2012
Region: California
Posts: 11
Ok cool ill post it tomorrow
STANG BOYZ is offline   Reply With Quote
Old 04-19-2012, 12:25 AM   #18
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
Its the low coolant light. Add some coolant mix to your overflow tank and it should go away.
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 04-19-2012, 10:58 AM   #19
Registered User
Newbie
 
STANG BOYZ's Avatar
 
Join Date: Apr 2012
Region: California
Posts: 11
Thanx very much that was exactly it ...it just needed coolant I got worried for a bit..
STANG BOYZ is offline   Reply With Quote
Old 04-19-2012, 12:52 PM   #20
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
No problem
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 06-08-2012, 11:56 AM   #21
Registered User
Newbie
 
STANG BOYZ's Avatar
 
Join Date: Apr 2012
Region: California
Posts: 11
Hello once again ok I got a problem with my gt when I'm driving it automatically turns of I stop the car then after a couple of minutes it turns back on can you give me an idea of what could it be
STANG BOYZ is offline   Reply With Quote
Old 06-08-2012, 01:08 PM   #22
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Quote:
Originally Posted by STANG BOYZ
Hello once again ok I got a problem with my gt when I'm driving it automatically turns of I stop the car then after a couple of minutes it turns back on can you give me an idea of what could it be
I would guess fuel or electrical problem
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 06-08-2012, 02:58 PM   #23
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
Quote:
Originally Posted by STANG BOYZ
Hello once again ok I got a problem with my gt when I'm driving it automatically turns of I stop the car then after a couple of minutes it turns back on can you give me an idea of what could it be
How long has it been since you replaced your fuel filter?
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 06-08-2012, 04:53 PM   #24
Registered User
Newbie
 
STANG BOYZ's Avatar
 
Join Date: Apr 2012
Region: California
Posts: 11
I have not in a long time u think Thatz what it is
STANG BOYZ is offline   Reply With Quote
Old 06-08-2012, 05:02 PM   #25
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
Quote:
Originally Posted by STANG BOYZ
I have not in a long time u think Thatz what it is
It could be that or maybe your ignition switch
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 06-08-2012, 07:31 PM   #26
Registered Member
Regular
 
CodyNelson's Avatar
 
Join Date: Apr 2011
Region: West Virgina
Posts: 1,204
Its some sort of electrical problem
CodyNelson is offline   Reply With Quote
Old 06-09-2012, 02:50 PM   #27
Filibuster
 
Join Date: Aug 2011
Region: Illinois
Posts: 1,656
Just a shot out of a cannon here but ive heard of security systems causing similar issues...
XXSTEVEO66 is offline   Reply With Quote
Old 06-10-2012, 03:33 PM   #28
Registered User
Newbie
 
STANG BOYZ's Avatar
 
Join Date: Apr 2012
Region: California
Posts: 11
Thanx fellas ill try to find out what it is I don't really want to take it to the shop any more info would help thanx again
STANG BOYZ is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:41 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.