Acceleration Problem? Please Help! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-21-2012, 03:11 AM   #1
Registered Member
Regular
 
FORDGT14's Avatar
 
Join Date: Aug 2011
Location: Surprise
Region: Arizona
Posts: 614
Question Acceleration Problem? Please Help!

Just so everyone knows, my car is a 99 Gt 4.6l 2V V8

It just started doing this the other day, I was heading into town and made a HUGE mistake and put circle k gas in my car (sorry if you like circle k gas). But anyways, it was a the closest gas station, so i went ahead and got gas there, I used "91". The car ran fine all the way to town, no issues what so ever. But after about 45 mins of driving, it started having trouble accelerating, like it didn't have the power to take off or something, I would have to ride the hell out of the clutch to get the car moving. Well I thought maybe I just bought bad gas, so i put $20 in Chevron fuel in it and it helped a little for the rest of the day. But today when I got in the car and left the house, it was worse than before. If I floor it in first gear, instead of lighting up the tires like it normally would, it just sits there and sputters, its horrible. It idles completely normal with no "misfire" sounds, it only does this when the engine has to pull the weight of the car or has to accelerate fast. I already ran some "Chemtool" through the fuel system thinking maybe my injectors were dirty and it didn't help a damn thing.

It drives alot better with the a/c off too, it almost dies from an idle when i come to a stop with the a/c on. When its off, the car is alot easier to drive but still sputters really bad when I give it too much gas.

Im thinking fuel filter, fuel pump, or???

Any help will be appreciated. Thanks
FORDGT14 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2012, 08:18 AM   #2
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
You answered your own question, fuel filter. I bet my car on it.
tc x 4 is offline   Reply With Quote
Old 04-21-2012, 08:28 AM   #3
Pete Jones
Regular
 
90mustangLX's Avatar
 
Join Date: Sep 2011
Region: Ohio
Posts: 781
Send a message via ICQ to 90mustangLX Send a message via AIM to 90mustangLX
Quote:
Originally Posted by tc x 4
You answered your own question, fuel filter. I bet my car on it.
Def check the filter but also could possibly be the fuel pimp getting hot(clogged filter or clogged pump) and not supplying enough fuel pressure starving your car for fuel. My gt did that when I first got it years ago. Would run fine and idle fine for a while then all of a sudden mash it and it would just spit and sputter and hold itself at a certain rpm.
__________________
90 LX hatchback
(sold but not forgotten)

89 LX Notchback
No motor/trans (for now)
90mustangLX is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2012, 09:46 AM   #4
Registered Member
Regular
 
Arron's racecar's Avatar
 
Join Date: Mar 2008
Region: Nevada
Posts: 341
Quote:
Originally Posted by 90mustangLX

Def check the filter but also could possibly be the fuel pimp getting hot(clogged filter or clogged pump).
Yeah I just changed mine yesterday. Was having an identical problem. And now all better. .. Oh and you gotta remember to pay your fuel pimp!
__________________
2004 GT current mods : CAI, BBK Short throw shifter TB and UDPs, SCT x3/SF3 with BAMA Perfomance tunes Roush body kit, roush side skirt exhaust and paint.
Arron's racecar is offline   Reply With Quote
Old 04-21-2012, 10:31 AM   #5
Registered Member
Regular
 
Csnow99gt's Avatar
 
Join Date: Feb 2012
Region: Kansas
Posts: 72
Fuel pimps have a strong back hand!
Csnow99gt is offline   Reply With Quote
Old 04-21-2012, 11:02 AM   #6
Pete Jones
Regular
 
90mustangLX's Avatar
 
Join Date: Sep 2011
Region: Ohio
Posts: 781
Send a message via ICQ to 90mustangLX Send a message via AIM to 90mustangLX
Quote:
Originally Posted by Csnow99gt
Fuel pimps have a strong back hand!
That they do!
__________________
90 LX hatchback
(sold but not forgotten)

89 LX Notchback
No motor/trans (for now)
90mustangLX is offline   Reply With Quote
Old 04-21-2012, 11:12 AM   #7
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
If your car has more then 70k miles just change the pump to a walbro 255, I did in my old car and holy hell I didn't even know my pump was that bad felt like a different car, I had no signs of trouble either just changed it because I was getting ready for nitrous
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 04-21-2012, 11:47 AM   #8
Registered Member
Regular
 
MiGT01's Avatar
 
Join Date: Jan 2012
Region: Michigan
Posts: 406
Re: Acceleration Problem? Please Help!

Start with the filter first, then do the pimp!! Bwah
__________________
01 Black Beauty GT
Eibach pro kit,Tokico shocks/struts,BBK CAI,75mm TB/ Plenum,4.10 FRPP gears,BBK o/r X pipe,Magnaflow Catback,SCT Tuner running 91 Tune,Bama Tunes for Life Member,RAM HD Clutch,BM shifter with MGW "GT" knob,AM smoked Headlights/Sylvania zXe bulbs,VHT smoked tails/3rd brake,Redtop Optima,Mach 1 grille delete,Mach 1 chin spoiler,BULLITT Pedals,20% tint all round,4.6 High Performance Badges
MiGT01 is offline   Reply With Quote
Old 04-21-2012, 02:46 PM   #9
Registered Member
Regular
 
FORDGT14's Avatar
 
Join Date: Aug 2011
Location: Surprise
Region: Arizona
Posts: 614
Re: Acceleration Problem? Please Help!

Ok. But how many fuel filters are on these cars? Just the one by the tank right?
FORDGT14 is offline   Reply With Quote
Old 04-21-2012, 04:27 PM   #10
Registered Member
Regular
 
MiGT01's Avatar
 
Join Date: Jan 2012
Region: Michigan
Posts: 406
Re: Acceleration Problem? Please Help!

Quote:
Originally Posted by FORDGT14 View Post
Ok. But how many fuel filters are on these cars? Just the one by the tank right?
Yeppers!
__________________
01 Black Beauty GT
Eibach pro kit,Tokico shocks/struts,BBK CAI,75mm TB/ Plenum,4.10 FRPP gears,BBK o/r X pipe,Magnaflow Catback,SCT Tuner running 91 Tune,Bama Tunes for Life Member,RAM HD Clutch,BM shifter with MGW "GT" knob,AM smoked Headlights/Sylvania zXe bulbs,VHT smoked tails/3rd brake,Redtop Optima,Mach 1 grille delete,Mach 1 chin spoiler,BULLITT Pedals,20% tint all round,4.6 High Performance Badges
MiGT01 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

« GAS | Misfire! »
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:37 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.