Sequential tailight help!! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-08-2012, 02:48 PM   #1
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Sequential tailight help!!

I need help with my sequential tailights! So when I put them on my hazards worked fine working sequentially. But when I do either my right or left turn signal it doesn't work. Only the middle light flickers! And inside the car the arrow flickers quickly as if a fuse is out. And now my brake lights won't even turn on! WTF like when I turn on the parking lights they turn on but when I step on the brakes they don't turn on an now my hazards aren't working!! Not even in the car do they turn on they make no sound and there isn't any indication on the dash tht they are on!
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-08-2012, 03:54 PM   #2
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
First thing first. I take it these are splice in seqentials. Have you checked all fuses to make sure you didn't pop one?
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 05-08-2012, 04:29 PM   #3
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Check your wiring. Its messed up somewhere on one of your splices. Then replace the fuse
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-08-2012, 04:56 PM   #4
Registered Member
Regular
 
Enorym's Avatar
 
Join Date: Dec 2010
Region: California
Posts: 196
Quote:
Originally Posted by Venomouz831
I need help with my sequential tailights! So when I put them on my hazards worked fine working sequentially. But when I do either my right or left turn signal it doesn't work. Only the middle light flickers! And inside the car the arrow flickers quickly as if a fuse is out. And now my brake lights won't even turn on! WTF like when I turn on the parking lights they turn on but when I step on the brakes they don't turn on an now my hazards aren't working!! Not even in the car do they turn on they make no sound and there isn't any indication on the dash tht they are on!
Change your bulbs to all the same brand and kind. I think you have some with a single filament installed you need two filament bulbs. I had the same prob with mine.
Enorym is offline   Reply With Quote
Old 05-08-2012, 04:58 PM   #5
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Well my fuses look good like nothing was fried. The splices look fine I switched them around and nothin
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 05-08-2012, 05:25 PM   #6
Registered Member
Regular
 
Enorym's Avatar
 
Join Date: Dec 2010
Region: California
Posts: 196
Quote:
Originally Posted by Venomouz831
Well my fuses look good like nothing was fried. The splices look fine I switched them around and nothin
Bulbs! Change them that's the problem. Get two filament bulbs all the same brand and kind.
Enorym is offline   Reply With Quote
Old 05-08-2012, 05:27 PM   #7
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Quote:
Originally Posted by Enorym

Bulbs! Change them that's the problem. Get two filament bulbs all the same brand and kind.
Ok but i mean when I turn on the parking lights they go on. But like turn signals and hazards and brakes don't work. They were working before but not no more
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 05-08-2012, 05:27 PM   #8
Registered Member
Regular
 
Enorym's Avatar
 
Join Date: Dec 2010
Region: California
Posts: 196
http://gifboom.com/x/dff000 trust me I know. I had to do it.
Enorym is offline   Reply With Quote
Old 05-08-2012, 06:44 PM   #9
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
What kit did you go with. I've installed a ton of these
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 05-08-2012, 07:24 PM   #10
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Quote:
Originally Posted by lowflyn
What kit did you go with. I've installed a ton of these
It was one from eBay splice kind. Now neither of my signals works nor does my break lights turn on. In the car my hazards or turn signal flicker.
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 05-08-2012, 07:35 PM   #11
Registered Member
Regular
 
2002VertGT's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 1,876
Quote:
Originally Posted by Venomouz831

It was one from eBay splice kind. Now neither of my signals works nor does my break lights turn on. In the car my hazards or turn signal flicker.
This is why I tell everyone to spend the extra $ to get PnP and do it right with no worrys
__________________
2004 F150 4x4 Lariat Supercrew, 5.4l, Black/Arizona Beige (daily driver)
2002 Mustang GT Convertible, triple black, mach 1000 system (Summer Car)
2001 Ranger Edge 4x4 xcab (sold to cousin)

4.10 Gear/RPM thread
2002VertGT is offline   Reply With Quote
Old 05-08-2012, 07:54 PM   #12
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Yea I knw but I mean it seemed easy to do just guess quality was bad
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 05-08-2012, 08:04 PM   #13
Registered Member
Regular
 
Enorym's Avatar
 
Join Date: Dec 2010
Region: California
Posts: 196
Re: Sequential tailight help!!

Quote:
Originally Posted by 2002VertGT View Post
This is why I tell everyone to spend the extra $ to get PnP and do it right with no worrys
I totally agree. if you don't have experience wiring them up just spend the extra money. I got mine from Sequential Turn Signals, One Touch Turn Signals, Challenger Sequential Taillights, Sequential Tail Lights, Mustang, Dynamite Stick Sequential, Pulsing Brake Light Pulser Flasher, Raxiom, Amrerican Muscle, Stack Racing, One Touch, Blink Blink, Corvett I bought them initially for my 85 fiero and had to wire them up...and also got them for my mustang the day I bought it back in 06. I didn't wire up my mustangs though I learned from the first time lol. I did have to experiment with different bulbs like I mentioned because the single filament didn't work sequentially.
Enorym is offline   Reply With Quote
Old 05-08-2012, 10:12 PM   #14
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
I do believe it's my fuses now because like I sated before the hazards or turn signals aren't blinking in the dash at all
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 05-08-2012, 10:15 PM   #15
Registered Member
Regular
 
Enorym's Avatar
 
Join Date: Dec 2010
Region: California
Posts: 196
Quote:
Originally Posted by Venomouz831
I do believe it's my fuses now because like I sated before the hazards or turn signals aren't blinking in the dash at all
Considering you've been at this it's prob a combination of all of these things you prob shorted it trying to figure it out so the fuse is shot. The wireing was wrong, and the bulbs were wrong Lol take a step back and look it all over again.
Enorym is offline   Reply With Quote
Old 05-08-2012, 10:55 PM   #16
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Quote:
Originally Posted by Enorym

Considering you've been at this it's prob a combination of all of these things you prob shorted it trying to figure it out so the fuse is shot. The wireing was wrong, and the bulbs were wrong Lol take a step back and look it all over again.
Yea I knw I've been at it for like 4 hours now. Ima just tell em to send me a refund and I'll buy some fro AM.
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 05-08-2012, 11:19 PM   #17
Registered Member
Regular
 
02PONY's Avatar
 
Join Date: Nov 2011
Region: Indiana
Posts: 886
Did it not come with instructions
__________________
02PONY is offline   Reply With Quote
Old 05-08-2012, 11:22 PM   #18
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Quote:
Originally Posted by 02PONY
Did it not come with instructions
Yes it did and I followed them step by step but doesn't even turn on. It fried my fuse for break lights. I emailed him pics of it and said it looks right, he said just to wiggle the connection and what not.

Click image for larger version

Name:	image-3908111804.jpg
Views:	97
Size:	434.4 KB
ID:	49755
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 05-08-2012, 11:34 PM   #19
Registered Member
Regular
 
Enorym's Avatar
 
Join Date: Dec 2010
Region: California
Posts: 196
If you lived nearby I'd offer a helping hand. I know how tedious it is messing with this kinda stuff especially when you want it towork so badly.

---------- Post added at 09:34 PM ---------- Previous post was at 09:33 PM ----------

Quote:
Originally Posted by Enorym
If you lived nearby I'd offer a helping hand. I know how tedious it is messing with this kinda stuff especially when you want it towork so badly.
I'm in NorCal daly city to be exact.
Enorym is offline   Reply With Quote
Old 05-08-2012, 11:38 PM   #20
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Quote:
Originally Posted by Enorym
If you lived nearby I'd offer a helping hand. I know how tedious it is messing with this kinda stuff especially when you want it towork so badly.

---------- Post added at 09:34 PM ---------- Previous post was at 09:33 PM ----------



I'm in NorCal daly city to be exact.
Yea thnks. Oh you live in Frisco I live like 2 hours away from there a place called monterey bay, if only u were closer
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 05-09-2012, 12:02 AM   #21
Registered Member
Regular
 
02PONY's Avatar
 
Join Date: Nov 2011
Region: Indiana
Posts: 886
Wow that's alot of splicing did u replace fuse? Does it keep blowing fuses?
__________________
02PONY is offline   Reply With Quote
Old 05-09-2012, 12:17 AM   #22
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Quote:
Originally Posted by 02PONY
Wow that's alot of splicing did u replace fuse? Does it keep blowing fuses?
No I haven't replaced it it's already night time here. I'll buy the fuse tmrw
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 05-09-2012, 07:35 AM   #23
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Wiring appears to be correct.

---------- Post added at 07:35 AM ---------- Previous post was at 07:33 AM ----------

This is where I've gotten my kits from since 2003.http://www.mustangtaillightsequencers.com/
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 05-09-2012, 07:40 AM   #24
Registered Member
Regular
 
02PONY's Avatar
 
Join Date: Nov 2011
Region: Indiana
Posts: 886
Same here zero problems
__________________
02PONY is offline   Reply With Quote
Old 05-09-2012, 08:24 AM   #25
Registered Member
Regular
 
Las0mbra's Avatar
 
Join Date: Jan 2011
Region: Oklahoma
Posts: 2,104
Quote:
Originally Posted by lowflyn
Wiring appears to be correct.

---------- Post added at 07:35 AM ---------- Previous post was at 07:33 AM ----------

This is where I've gotten my kits from since 2003.http://www.mustangtaillightsequencers.com/
Me too! Mine work great.

---------- Post added at 08:24 AM ---------- Previous post was at 08:24 AM ----------

Also purevenom uses them too.
Las0mbra is offline   Reply With Quote
Old 05-09-2012, 04:10 PM   #26
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
Whats the difference between these sequencals and the ones on American muscle?
Sonicblue11 is offline   Reply With Quote
Old 05-09-2012, 04:23 PM   #27
Registered Member
Regular
 
Las0mbra's Avatar
 
Join Date: Jan 2011
Region: Oklahoma
Posts: 2,104
Quote:
Originally Posted by Sonicblue11
Whats the difference between these sequencals and the ones on American muscle?
They're the same, well, different looking, but splice the same.
Las0mbra is offline   Reply With Quote
Old 05-09-2012, 04:29 PM   #28
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
Quote:
Originally Posted by Las0mbra

They're the same, well, different looking, but splice the same.
Different how though? Like the lighting or just the wires or something
Sonicblue11 is offline   Reply With Quote
Old 05-09-2012, 04:32 PM   #29
Registered Member
Regular
 
Las0mbra's Avatar
 
Join Date: Jan 2011
Region: Oklahoma
Posts: 2,104
Quote:
Originally Posted by Sonicblue11

Different how though? Like the lighting or just the wires or something
Wiring. The lights look identical to the AM ones with the raxiom slow rate flashers. Well, make sure you buy the original/slow rate ones.
Las0mbra is offline   Reply With Quote
Old 05-09-2012, 04:40 PM   #30
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
Okay and yeah it's the same right? It's 40 dollars cheaper than am
Sonicblue11 is offline   Reply With Quote
Old 05-09-2012, 05:51 PM   #31
Registered Member
Regular
 
wolfstang03's Avatar
 
Join Date: Feb 2012
Region: New York
Posts: 344
Or you can get a modded flasher relay. I think am has them but they're mad expensive! I got mine from some odd ball web site for lie 10 or 15 bucks. Just Google it first.
__________________
--WOLFSTANG 03--
wolfstang03 is offline   Reply With Quote
Old 05-09-2012, 06:38 PM   #32
Registered Member
Regular
 
Enorym's Avatar
 
Join Date: Dec 2010
Region: California
Posts: 196
Quote:
Originally Posted by Las0mbra

They're the same, well, different looking, but splice the same.
You have to wire it up as opposed to it already having a harness.
Enorym is offline   Reply With Quote
Old 05-09-2012, 08:48 PM   #33
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
You have to cut two wires on your harness and run a new one to the inside light. Takes me about twenty minutes to wire them up. Comes with all the connectors and ive never had any issues with any kits I have installed. Need to order two more for friends' cars actually
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

« help | FR500's!! »
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:01 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.