Flickering hid - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-09-2012, 01:04 PM   #1
Registered Member
Regular
 
Snapple750's Avatar
 
Join Date: Jan 2011
Region: South Carolina
Posts: 289
Flickering hid

One of my foglight hids is flickering. It's just the passenger side, could this mean the ballast is bad? I've tried swapping the bulb and redoing the wiring.
__________________
2 Legit 2 Quit
Snapple750 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-09-2012, 01:42 PM   #2
Registered Member
Regular
 
Siendly22's Avatar
 
Join Date: May 2011
Region: California
Posts: 574
Did you try switching the ballast?
Siendly22 is offline   Reply With Quote
Old 06-09-2012, 05:34 PM   #3
Registered Member
Regular
 
t0t4lbl4ck0ut's Avatar
 
Join Date: May 2011
Posts: 711
99% chance it's your ballast. Ballasts are almost always the culprit with HIDs. Especially if they are cheap and not fastened down. Make sure you get them strapped down really good cause the bouncing and smacking things will break the resistors and capacitors in the ballasts
t0t4lbl4ck0ut is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-09-2012, 07:53 PM   #4
Registered Member
Regular
 
Snapple750's Avatar
 
Join Date: Jan 2011
Region: South Carolina
Posts: 289
Quote:
Originally Posted by Siendly22
Did you try switching the ballast?
With a new one?
__________________
2 Legit 2 Quit
Snapple750 is offline   Reply With Quote
Old 06-09-2012, 08:39 PM   #5
Registered Member
Regular
 
Siendly22's Avatar
 
Join Date: May 2011
Region: California
Posts: 574
Quote:
Originally Posted by Snapple750

With a new one?
Don't change it yet. Try to switch it both side and you'll see if the ballast is the real problem. Do this first before you replace to a new one.
Siendly22 is offline   Reply With Quote
Old 06-10-2012, 02:53 AM   #6
Registered Member
Regular
 
t0t4lbl4ck0ut's Avatar
 
Join Date: May 2011
Posts: 711
Quote:
Originally Posted by Siendly22

Don't change it yet. Try to switch it both side and you'll see if the ballast is the real problem. Do this first before you replace to a new one.
Lol I figured that would be the next obvious step lol
t0t4lbl4ck0ut is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:24 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.