miss. - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-15-2012, 04:13 PM   #1
Registered Member
Regular
 
taylor98gt's Avatar
 
Join Date: Apr 2012
Region: Kentucky
Posts: 648
miss.

my car has a slight miss in it at idle, my o2 sensor is broken off and hanging there under my car which is throwing a check engine light, could the o2 sensor be whats making it miss? ive put new plugs in it, and have done the reidle thing a few times, it runs fine till the engine light comes bak on. my car is a 98 gt btw
taylor98gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-15-2012, 09:31 PM   #2
Registered Member
Regular
 
96stangracer's Avatar
 
Join Date: Jan 2012
Region: Florida
Posts: 27
Take it to a shop scan it and yes the upstream is a performance kind like air flow meter to control the computers parameters so fix it and what code do you get probaly lean i would expect that is also a exhaust leak if it is open not good either
96stangracer is offline   Reply With Quote
Old 06-15-2012, 10:37 PM   #3
Registered Member
Regular
 
taylor98gt's Avatar
 
Join Date: Apr 2012
Region: Kentucky
Posts: 648
Quote:
Originally Posted by 96stangracer
Take it to a shop scan it and yes the upstream is a performance kind like air flow meter to control the computers parameters so fix it and what code do you get probaly lean i would expect that is also a exhaust leak if it is open not good either
Okay thanks Ima take it Tuesday an get it fixed
taylor98gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-16-2012, 12:23 AM   #4
Registered Member
Regular
 
NeverEnuff's Avatar
 
Join Date: Jun 2012
Region: Texas
Posts: 37
Re: miss.

For a short answer, yes.

Go get a new Motorcraft sensor.
__________________
89 Coupe-Carbd 32v, 437rwhp NA, 592rwhp Spray
79 Coupe-Project IRS, 32v, AC Daily Driver
01 Bullitt-B cammed 32v (wifes)
00 Expedition-L swapped, SuperCharged Boat
07 Expedition-stock (wifes), Tow Vehicle
NeverEnuff is offline   Reply With Quote
Old 06-16-2012, 01:54 AM   #5
Registered Member
Regular
 
taylor98gt's Avatar
 
Join Date: Apr 2012
Region: Kentucky
Posts: 648
Re: miss.

Quote:
Originally Posted by NeverEnuff View Post
For a short answer, yes.

Go get a new Motorcraft sensor.
i just hope thats all it is, i really want to get it running right before doing a little work to it, i want to do the pi swap first and a tuner. hopefully thatll get me running pretty quick
taylor98gt is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:54 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.