missing and low pressure when clutch is in,please help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-12-2012, 06:29 PM   #1
Registered Member
Regular
 
redstang98's Avatar
 
Join Date: Jul 2012
Region: North Carolina
Posts: 89
missing and low pressure when clutch is in,please help

someone please help before i send it off a cliff.
new plugs ,wires and coil packs good. motor skiping or missing and low pressure when clutch is engaged

---------- Post added at 05:29 PM ---------- Previous post was at 05:22 PM ----------

only stays running when i have the vemon 400 on
redstang98 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2012, 07:37 PM   #2
Registered Member
Regular
 
Join Date: Jan 2012
Region: Mississippi
Posts: 162
What's Vemon 400 ? If it's an alarm system then I think that may be your problem
96gt014.6 is offline   Reply With Quote
Old 07-12-2012, 09:06 PM   #3
Registered Member
Regular
 
redstang98's Avatar
 
Join Date: Jul 2012
Region: North Carolina
Posts: 89
Not alarm . It controls mas and throttle body in comp.
redstang98 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2012, 09:30 PM   #4
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Sounds like a vacuum leak or pcv valve clogged. Could also be the idle air control valve.
jjsg09 is offline   Reply With Quote
Old 07-12-2012, 09:38 PM   #5
Registered Member
Regular
 
redstang98's Avatar
 
Join Date: Jul 2012
Region: North Carolina
Posts: 89
PVC valve is on the driver side valve cover?
redstang98 is offline   Reply With Quote
Old 07-12-2012, 09:47 PM   #6
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Should be on the passenger side under cold air intake
jjsg09 is offline   Reply With Quote
Old 07-12-2012, 09:58 PM   #7
Registered Member
Regular
 
redstang98's Avatar
 
Join Date: Jul 2012
Region: North Carolina
Posts: 89
Then what that on driver side . Im electronic not mechanical
redstang98 is offline   Reply With Quote
Old 07-12-2012, 10:00 PM   #8
Registered Member
Regular
 
redstang98's Avatar
 
Join Date: Jul 2012
Region: North Carolina
Posts: 89
Hey do you know what this is thats at my finger

Click image for larger version

Name:	ForumRunner_20120712_225951.png
Views:	144
Size:	302.7 KB
ID:	58836
redstang98 is offline   Reply With Quote
Old 07-14-2012, 05:01 AM   #9
Registered Member
Regular
 
LAS97GT's Avatar
 
Join Date: Jan 2012
Location: Spring Lake
Region: North Carolina
Posts: 681
Quote:
Originally Posted by redstang98
Then what that on driver side . Im electronic not mechanical
Crank case vent
__________________
---Las97GT
LAS97GT is offline   Reply With Quote
Old 07-15-2012, 08:06 PM   #10
Registered Member
Regular
 
redstang98's Avatar
 
Join Date: Jul 2012
Region: North Carolina
Posts: 89
Replaced all that and still the same what is that line that is black with red stripe on it going out back bottom on the pluiem1/4 hose ?

---------- Post added at 07:06 PM ---------- Previous post was at 07:05 PM ----------

About to put sea foam in it to c if it helps
redstang98 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:00 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.