Finishing up my Billet Interior - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-20-2012, 08:15 AM   #1
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Finishing up my Billet Interior

Couple more parts for my interior.

I'll post up some pics later today.

Any special trick getting the cruise buttons off?
Attached Thumbnails
Click image for larger version

Name:	image-2554536851.jpg
Views:	219
Size:	517.7 KB
ID:	59946  
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-20-2012, 08:18 AM   #2
Registered Member
Regular
 
Rm360's Avatar
 
Join Date: Feb 2012
Region: Illinois
Posts: 1,140
A very small thin screwdriver is all you need they will pop right out!!!
Rm360 is offline   Reply With Quote
Old 07-20-2012, 08:26 AM   #3
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Thanks!
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-20-2012, 08:33 AM   #4
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Right on! It's gonna look good
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-20-2012, 10:01 AM   #5
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
It's never easy I pop the new billet buttons on and my cruise didn't work so I took the buttons off and the cruise still doesn't work Musta blew a fuse somehow.

Anyone know where that's located?
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-20-2012, 11:07 AM   #6
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Re: Finishing up my Billet Interior

My buddy adjusted my clutch the other day, I think that is the problem:

"today while driving I kept hitting the button to activate and nothing, dead as a doornail, than I thought I just put in a brand new clutch cable and clutch kit, so I thought maybe theirs a sensor on the clutch pedal?!?!?!?! SO I put my foot under the clutch pedal while driving and pulled back 1/8" back towards me while driving and sure enough when I hit the on plus set accelerator button it WORKED LIKE A CHARM, So im under the impression I need to move my clutch pedal back 1/8" towards me so the sensor has contact or I need to adjust my clutch cable a slight bit more???? NEED TO CALL MY INSTALL GUY TO SEE WHAT HE SAYS, it seems like a easy fix since its working with slight back pressure on the pedal which in theory is pushing the top of the clutch pedal towards the engine bay which means their has to be a sensor somewhere up their."

Gonna try that...

That worked, it was the clutch.
WheelStander is offline   Reply With Quote
Old 07-20-2012, 04:53 PM   #7
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Stereo is next.
Attached Thumbnails
Click image for larger version

Name:	image-2026238915.jpg
Views:	180
Size:	521.4 KB
ID:	60025   Click image for larger version

Name:	image-908571343.jpg
Views:	156
Size:	393.9 KB
ID:	60026  

Click image for larger version

Name:	image-3348342244.jpg
Views:	162
Size:	535.1 KB
ID:	60027  
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-20-2012, 05:07 PM   #8
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Quote:
Originally Posted by WheelStander
Stereo is next.
Looks awesome! And your cruise works now too?
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-20-2012, 06:00 PM   #9
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Thanks Azure. Yeah the cruise is working, had to adjust the clutch cable under the dash a little bit.
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-25-2012, 08:21 PM   #10
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
I picked up a lighter delete, power plug, coin delete and fog light button.

How exactly do I get the fog lamp button off?
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-25-2012, 08:22 PM   #11
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Quote:
Originally Posted by WheelStander
I picked up a lighter delete, power plug, coin delete and fog light button.

How exactly do I get the fog lamp button off?
It's not the whole switch?
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-25-2012, 08:34 PM   #12
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Just the button.
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-25-2012, 08:42 PM   #13
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Quote:
Originally Posted by WheelStander
Just the button.
Hmm, maybe you can pop out the bezel around the shifter and get to the switch. Maybe there is some way to release the button from the switch.
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-25-2012, 08:44 PM   #14
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Ok thanks. I'll try popping up the bezel.
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-25-2012, 09:23 PM   #15
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Does your new fog light button look like the in the pic below on the left?
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-25-2012, 09:25 PM   #16
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Seems like it would pop off like the ones on your door did, if like the ones in the pic.
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-25-2012, 09:28 PM   #17
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Yeah it looks like that.

I didn't do the ones on the door so I'm not sure exactly how.

Thanks.
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-25-2012, 09:35 PM   #18
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
I went out and looked at mine, but it's different. Must have changed them by 2004.
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-26-2012, 07:16 AM   #19
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Here are 2004 buttons...
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-26-2012, 08:36 AM   #20
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
I can't get this thing to pop out. UPR says 10 minute installation but doesn't provide instructions I've got no clue at this point...

And what should I do with that plug it's attached to the trim ring on the power supply? Cut it off remove it ?

You need a lighter delete like mine-thanks for the info so far.
Attached Thumbnails
Click image for larger version

Name:	image-3710574718.jpg
Views:	119
Size:	439.7 KB
ID:	60945   Click image for larger version

Name:	image-3977051697.jpg
Views:	108
Size:	393.6 KB
ID:	60946  

Click image for larger version

Name:	image-3777363987.jpg
Views:	92
Size:	376.8 KB
ID:	60947  
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-26-2012, 09:07 AM   #21
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
It looks like the best way to pop the button off would be with a little screw driver between the button and the edge of the button housing. Try it at or near the middle. Try to pry the screw driver such that the button moves away from the edge some, then pry up to where it would pop out. Hopefully you can see how it's going to go as you start to pry. Check out the arrow in the pic.

I'd like to get a lighter delete or cap so I can pop it off and plug my phone in.
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-26-2012, 09:10 AM   #22
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Little screwdriver like this myaa
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-26-2012, 11:49 AM   #23
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Re: Finishing up my Billet Interior

I can get the side closest to driver to pop up using that method but pass side just wont pop up...weird.

Edit: I pulled the whole assembly.
WheelStander is offline   Reply With Quote
Old 07-26-2012, 07:49 PM   #24
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Not sure if I do anything else...
Attached Thumbnails
Click image for larger version

Name:	image-1697467004.jpg
Views:	104
Size:	356.8 KB
ID:	61009   Click image for larger version

Name:	image-4059148561.jpg
Views:	105
Size:	329.2 KB
ID:	61010  

__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-26-2012, 08:10 PM   #25
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Quote:
Originally Posted by WheelStander
Not sure if I do anything else...
Looks good man! So how did that somna B come off?
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-26-2012, 08:26 PM   #26
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
I had to take the Assembly out and pry the button out with two screwdrivers it was a pain in the butt I'm surprised I didn't break the switch.
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-26-2012, 08:35 PM   #27
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
Quote:
Originally Posted by WheelStander
I had to take the Assembly out and pry the button out with two screwdrivers it was a pain in the butt I'm surprised I didn't break the switch.
Well I'm glad it turned out cause it looks good. Did the tilt wheel handle just unscrew off?
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-26-2012, 08:46 PM   #28
Registered Member
Regular
 
WheelStander's Avatar
 
Join Date: Mar 2012
Location: Charlotte
Region: North Carolina
Posts: 1,470
Thanks.

Had to use a mini wrench, came off really hard though.

Thanks for the help.
__________________
Induction: Kenne Bell | wHp: 515 Tq: 503 | 1/4 Mile:11.09@123
WheelStander is offline   Reply With Quote
Old 07-26-2012, 08:48 PM   #29
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,860
No prob!
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:54 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.