1998 GT Check Engine Light - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-25-2012, 11:55 PM   #1
Registered Member
Regular
 
98RedGT's Avatar
 
Join Date: May 2011
Region: Missouri
Posts: 107
1998 GT Check Engine Light

Car runs fine then will randomly idle and run a little rough and the check engine light comes on. Will eventually go off and run fine then after a while do the same thing? Any idea?
Attached Thumbnails
Click image for larger version

Name:	image-3261580019.jpg
Views:	198
Size:	537.3 KB
ID:	60929  
__________________
ROOM FOR IMPROVEMENT
98RedGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-26-2012, 01:23 AM   #2
Lorraine's driver

Regular
 
ab_mach1's Avatar
 
Join Date: Feb 2012
Location: Indianapolis
Region: Indiana
Posts: 7,858
I looked up that code and it's probably the O2 sensors, or one of them. Was there any other codes with P1151?
__________________
Instagram: @ab_mach1
ab_mach1 is offline   Reply With Quote
Old 07-26-2012, 01:27 AM   #3
Registered Member
Regular
 
maldog's Avatar
 
Join Date: Jun 2012
Region: Nevada
Posts: 1,563
Re: 1998 GT Check Engine Light

Have u done anything recently to the engine? Cleaned ur air filter? Do u have a CAI? If u over oil ur air filter it will do all sorts of strange things. The oil will also get on the MAF sensor and screw with things. I know because it's happened on my GT. I cleaned the MAF sensor and the air filter on my CAI, cleared all my codes and she's back to normal.
__________________
2006 Mustang GT Premium RedFire. CAI, SLP Loudmouth, SCT Progammer, 5 speed manual trans. My other car is a CORVETTE!
maldog is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-26-2012, 02:12 AM   #4
Registered Member
Regular
 
infamous281's Avatar
 
Join Date: Jul 2012
Region: Texas
Posts: 779
Quote:
Originally Posted by 98RedGT
Car runs fine then will randomly idle and run a little rough and the check engine light comes on. Will eventually go off and run fine then after a while do the same thing? Any idea?

Most likely a Bad Sensor.. IAC or TPS
infamous281 is offline   Reply With Quote
Old 07-26-2012, 02:26 AM   #5
Registered Member
Regular
 
98RedGT's Avatar
 
Join Date: May 2011
Region: Missouri
Posts: 107
Re: 1998 GT Check Engine Light

Nothing recently, and yes I have a JLT CAI. Would the MIL eliminators fix it?
__________________
ROOM FOR IMPROVEMENT
98RedGT is offline   Reply With Quote
Old 07-26-2012, 05:37 AM   #6
Registered Member
Regular
 
Join Date: Dec 2010
Posts: 1,291
Re: 1998 GT Check Engine Light

Quote:
Originally Posted by 98RedGT View Post
Nothing recently, and yes I have a JLT CAI. Would the MIL eliminators fix it?
No, they work on the rear o2 sensor and this code is from the front. Check your fuse box and see if a fuse wasnt blown. If not then just get you too new sensors. Im sure they havent ever been changed before so get two new ones from the front, or upstream sensors. Look at them and make sure they are connected correctly and not burnt agaisnt the exhaust.
southernstang00 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Tags
check engine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:39 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.