A charging system question... - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-29-2008, 04:48 PM   #1
Registered User
Newbie
 
silverstang's Avatar
 
Join Date: Apr 2007
Region: Massachusetts
Posts: 17
Question A charging system question...

So, i guess heres the deal. I replaced my battery right before christmas. It lasted a while only to find out my altenator was bad as well, so i replaced that at the end of december. now, when im driving, especially at night, my battery will get down to the point that my lights dim, all my gauge warning lights come on, and usually to the point that the gauges dont even work. i usually have to pull over using the e-brake and wait forever to get power back, if it doesnt die.
I've returned that alt and got a new one figuring its the voltage regulator, but this is no better. im only getting 11.4v at the battery with the car running, and forget it when i turn everything on.
So my question being, does anyone have any ideas on where to start??

Thanks for the input and sorry for the long *** thread.
__________________
00 gt
C&L intake
H-pipe
Mach chin spoiler (still sitting in garage)
silverstang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-09-2008, 08:40 PM   #2
Registered User
Newbie
 
silverstang's Avatar
 
Join Date: Apr 2007
Region: Massachusetts
Posts: 17
Re: A charging system question...

so if anyone has the same problem, i put a new battery (die hards suck apparently) in last week and im getting solid volts. that problem hasnt happened to me since. hope this helps.
__________________
00 gt
C&L intake
H-pipe
Mach chin spoiler (still sitting in garage)
silverstang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
charging system not working muskrat Classic Mustangs 8 04-12-2008 10:50 PM
question on 460 system roushstang666 Mustang Audio & Video 1 09-11-2006 01:02 AM
charging system woes Thomas91169 Mustang Audio & Video 15 08-12-2006 01:34 AM
PLEASE Help!! charging issues...91 GT scorpionSStang 1979-1995 Mustang GT 11 02-10-2006 05:56 PM
battery charging problem I_luv_HP&trq Pre-2005 V6 Mustang 20 09-24-2005 03:58 AM

» Like Us On Facebook



05:44 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.