CEL now on... p1520? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-31-2008, 03:03 PM   #1
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
CEL now on... p1520?

so, I had a CEL come on last night on the interstate, doing 70 at about 1900 or so RPM. It was raining. I get the code checked today at AutoZone and he forgot the code between my car and 20 feet from the car. He initially said "p1052", but after a couple seconds goes "well, maybe p1520". He said it ended up reading a "Looping Fuel Problem". However, while he was reading, I noted it said something about low coolant temp. Any suggestions here? I replaced the fuel filter like 5,000 miles ago. The car runs fine, all the way through the RPM range. Some times, when the engine is cold, if I get on it a little hard, there's a hesitation after I shift. Like the car is catching its breath, but then pulls hard throughout the whole gear. It only does that when the engine is a little cold. Any help is appreciated!
****EDIT**** Ok, once figuring out my car doesn't have IMRC, I went out and had them rescan it, and had them tell me the number while at the car. It was a p0125.

P0125 is Insufficient Coolant Temperature For Closed Loop Fuel Control
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-31-2008, 05:51 PM   #2
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: CEL now on... p1520?

and I'll help myself:

P0125 - Insufficient Coolant Temperature For Closed Loop Fuel Control Indicates the ECT or CHT sensor has not achieved the required temperature level to enter closed loop operating conditions within a specified amount of time after starting engine. Insufficient warm up time
Low engine coolant level
Leaking or stuck open thermostat
Malfunctioning ECT sensor
Malfunctioning CHT sensor
Refer to Thermostat Monitor in Section 1, Description and Operation, for system information.

My coolant level is just fine, checked that at the auto store. My engine temp was just fine... nice and warm. Could be thermostat stuck open. Could be either sensor.

So, now my question becomes this... how do I tell which of these is the culprit? I need to do a coolant flush, so if the t-stat is stuck open, won't that allow all of the coolant to drain out? I'm hoping so, but I don't want air trapped in the engine. (not that it would, but I get paranoid). I've put a t-stat on an F-150 4.6 engine... but the engine was out of the truck when we did it, how hard is it to do? I'd prefer to stick with the stock temp t-stat because I don't feel like spending the extra fuel and emissions on 180 degree.
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Old 03-31-2008, 06:40 PM   #3
Legacy Member
Legacy
 
Thomas91169's Avatar
 
Join Date: Sep 2003
Region: California
Posts: 2,280
Send a message via AIM to Thomas91169
Re: CEL now on... p1520?

well the Tstat is a restriction plate. When it is stuck open the water is moving through the radiator so fast it cools it down pretty well, however it circulates at a speed in which it does not allow the engine/coolant to reach the designated temperature to enter closed loop operation, which is why its running like dog**** (in open loop). The tstat restricts flow so the coolant basically heats up to operating temperature faster and the engine can reach closed loop earlier.

put in a new Tstat and see what happens.
__________________
-Thomas-

1998 Eclipse GST Spyder - 14b turbo | 3" Catback | Evo8 BoV | 170fwhp if that

2003 Redfire Cobra - 448whp/435wtq - Sold
Thomas91169 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-31-2008, 06:49 PM   #4
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: CEL now on... p1520?

I ordered a new Motorcraft T-stat... figured I might as well. Now, I looked up "how" to do it, just let me run over it see if it sounds right.
1) drain coolant
2) vise grips on the hose clamp
3) remove hose
4) remove two 1/2" head bolts (longer bolt is on pass side)
5) pop off old t-stat
6) clean old material from mating surface
7) pop on new t-stat after checking it to make sure it opens at desired temp
8) rebolt housing back on (no idea on torque specs???)
9) reattach hose
10) fill coolant

does that sound right? Also, I need the torque specs. Will this be ok to drive around on until Thursday evening when I can change it? I only have to drive about 4 miles to work. Also, should I go with a 190 degree or 180? I think the 190 will do just fine.
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Old 04-01-2008, 12:29 AM   #5
Legacy Member
Legacy
 
Thomas91169's Avatar
 
Join Date: Sep 2003
Region: California
Posts: 2,280
Send a message via AIM to Thomas91169
Re: CEL now on... p1520?

i would stick with whatever ford recommends. the only thing i can think of is maybe you might need a t-stat housing gasket as well.
__________________
-Thomas-

1998 Eclipse GST Spyder - 14b turbo | 3" Catback | Evo8 BoV | 170fwhp if that

2003 Redfire Cobra - 448whp/435wtq - Sold
Thomas91169 is offline   Reply With Quote
Old 04-01-2008, 08:12 AM   #6
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: CEL now on... p1520?

last time I bought a t-stat it came with one. I'll make sure I get a new gasket and a new o-ring. Might as well do it right the first time.
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Old 04-01-2008, 12:56 PM   #7
Legacy Member
Legacy
 
Join Date: May 2003
Region: Pennsylvania
Posts: 381
Re: CEL now on... p1520?

I had that problem recently and a new T-stat fixed it. Like Thomas said make sure to get a new O-ring.
__________________

-Denver
2002 Mineral Grey GT, 5-speed: MGW short throw, JLT CAI: SOLD
2002 Electric Green V6, Auto: SOLD
greenpony02 is offline   Reply With Quote
Old 04-01-2008, 02:04 PM   #8
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: CEL now on... p1520?

it comes in tomorrow... I'll make sure new gasket, new o-ring
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL/Problems 05torch 2005-2010 Mustang GT 6 11-15-2009 08:25 PM
cel help saleenman 1996-2004 Mustang GT 4 10-23-2009 10:19 PM
hey I have a CEL that.... Fishers Stang 1996-2004 Mustang GT 11 07-03-2005 11:14 AM
cel-shading the car in PS tedness Pictures and Videos 20 06-03-2005 01:15 AM
new 02 sensor but still CEL??!! a1yola Pre-2005 V6 Mustang 9 12-06-2003 05:53 AM

» Like Us On Facebook



06:21 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.