Popping noise - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Join Mustang Evolution Today

Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-25-2012, 08:44 AM   #1
Registered Member
01StangGt's Avatar
Join Date: Mar 2011
Region: Texas
Posts: 177
Popping noise

Ok so when I am braking and starting to take off I hear a popping noise from the front of the car and I can feel it underneath my feet. I checked it out before but never noticed anything. Possible stabilizer bushings? I did lower the car a few months ago but can not remember if it made the noise before I lowered it or not. Any advice would help

01StangGt is offline   Reply With Quote
Old 10-25-2012, 03:27 PM   #2
Registered Member
GHO5T5NIPER's Avatar
Join Date: Sep 2012
Region: Kansas
Posts: 476
My 98 4runner did the same thing. Turned out to be the sway bars broke off and were somehow causing a popping sound. Idk if its the same in mustangs but its something to check out.

GHO5T5NIPER is offline   Reply With Quote
Old 10-25-2012, 04:21 PM   #3
Registered Member
Siendly22's Avatar
Join Date: May 2011
Region: California
Posts: 574
Try to check your balljoint . IMO
Siendly22 is offline   Reply With Quote
Old 10-25-2012, 05:25 PM   #4
Registered Member
02NightmareGT's Avatar
Join Date: Feb 2012
Region: Missouri
Posts: 262
My Stang did that after I lowered it. Took the Drivers side back apart and put it back together with the help of my dad and made sure everything was freakin tight. Fixed the problem
02NightmareGT is offline   Reply With Quote
Old 10-25-2012, 09:21 PM   #5
Registered Member
poncho2049's Avatar
Join Date: Aug 2012
Region: California
Posts: 35
mine did the samething after i lowered it too. one of the sway bar bushings wasnt on there quite right
poncho2049 is offline   Reply With Quote
Old 10-25-2012, 10:19 PM   #6
Registered Member
infamous281's Avatar
Join Date: Jul 2012
Region: Texas
Posts: 752
Its your cradle bolts.. That hold your engine.. Just tighten them. Had same problem

infamous281 is offline   Reply With Quote

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

» Like Us On Facebook

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

04:49 PM

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.