Weird noise when turning - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-06-2012, 05:54 PM   #1
Registered Member
Regular
 
03fastblack's Avatar
 
Join Date: Feb 2012
Region: Missouri
Posts: 291
Weird noise when turning

Ok so I just put camber bolts on my car and its been a week. Now when I turn it makes a loud popping noise and kinda when I brake too. Could this mean that they have came loose or what?
03fastblack is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-07-2012, 01:49 AM   #2
Registered Member
Regular
 
Mfore33's Avatar
 
Join Date: Feb 2012
Location: Murfreesboro
Region: Tennessee
Posts: 540
I would definitely get it checked out soon. Don't want anything falling off while driving causing big costly repairs.
Mfore33 is offline   Reply With Quote
Old 11-07-2012, 01:58 AM   #3
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
After you installed the bolts did you get the alignment done?
primer2tone is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-07-2012, 01:59 AM   #4
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Did you tighten em well?
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 11-07-2012, 08:57 AM   #5
Registered Member
Regular
 
03fastblack's Avatar
 
Join Date: Feb 2012
Region: Missouri
Posts: 291
No it hasn't been aligned that was gonna happen this week.
03fastblack is offline   Reply With Quote
Old 11-07-2012, 10:41 AM   #6
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
Well, get your alignment and see if that clears it up.
primer2tone is offline   Reply With Quote
Old 11-07-2012, 08:17 PM   #7
Registered Member
Regular
 
1996mustang's Avatar
 
Join Date: Jun 2012
Location: Miami
Region: Florida
Posts: 1,013
Sounds like strut mount bushings depending where the popping sound is coming from
__________________
1996 Mustang GT, 17x9 front and 17x10.5 cobra r replica rims, 255/40/17 front 285/40/17 rear at the moment,
o/r x-pipe flow master 40 series dump downs, cai/ram intake, 75mm c&l throttle body and plenum, pi heads and intake swap, msd wires, stock gears, untuned at the moment, no dyno numbers for now.
1996mustang is offline   Reply With Quote
Old 11-08-2012, 11:33 AM   #8
Registered Member
Regular
 
03fastblack's Avatar
 
Join Date: Feb 2012
Region: Missouri
Posts: 291
I figured it out, the camber bolt weren't tight enough.
03fastblack is offline   Reply With Quote
Old 11-08-2012, 11:52 AM   #9
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
That's what I though
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:45 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.