Shutters under load - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-10-2012, 03:39 PM   #1
Registered User
Newbie
 
Rockpanama's Avatar
 
Join Date: Oct 2012
Region: Indiana
Posts: 5
Shutters under load

Hey everyone. I have an 03 gt and it has recently started shuttering under load but clears up after I get the Rpm up. Any guesses?
Rockpanama is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2012, 04:08 PM   #2
Registered Member
Regular
 
JetLife 01GT's Avatar
 
Join Date: Dec 2011
Region: California
Posts: 598
Plugs or cops? Does it feel like the motor is running rough or misfiring? Also manual or auto?
__________________
2001 GT

Engine/Drivetrain: SCT iTSX with BAMA 91 Race Tune, Airaid CAI, JBA O/R H-Pipe, SLP Power-Flo Catback, Exedy Stage 2 Clutch, Exedy Lightweight Flywheel

Suspension: H&R SuperSport Springs, KYB Shocks & Struts
JetLife 01GT is offline   Reply With Quote
Old 11-10-2012, 09:12 PM   #3
Registered Member
Regular
 
1996mustang's Avatar
 
Join Date: Jun 2012
Location: Miami
Region: Florida
Posts: 1,013
When u say shudders does it feel from the rear of the car or front. It could be what happened to me was i was low on diff lube and it shuddered when i got on it a bit or normal driving at times.
__________________
1996 Mustang GT, 17x9 front and 17x10.5 cobra r replica rims, 255/40/17 front 285/40/17 rear at the moment,
o/r x-pipe flow master 40 series dump downs, cai/ram intake, 75mm c&l throttle body and plenum, pi heads and intake swap, msd wires, stock gears, untuned at the moment, no dyno numbers for now.
1996mustang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2012, 11:53 PM   #4
Registered Member
Regular
 
02utahgt's Avatar
 
Join Date: Feb 2012
Region: Utah
Posts: 72
Mine did the same thing. After changing everything it ended being the trans mount . It would vibrate even sitting still.
02utahgt is offline   Reply With Quote
Old 11-11-2012, 09:09 AM   #5
Registered User
Newbie
 
Rockpanama's Avatar
 
Join Date: Oct 2012
Region: Indiana
Posts: 5
I thought it was the clutch so I changed it. Fortunately the clutch was worn out but that didn't fix the prob. It happens in 2nd thru 5th if rpms are low and under load. It feels like it is coming from the back but I can't be sure.
Rockpanama is offline   Reply With Quote
Old 11-11-2012, 11:25 AM   #6
Registered Member
Regular
 
1996mustang's Avatar
 
Join Date: Jun 2012
Location: Miami
Region: Florida
Posts: 1,013
I would check ur differential fluid ur probably low on it. Mine did it and i refilled it
__________________
1996 Mustang GT, 17x9 front and 17x10.5 cobra r replica rims, 255/40/17 front 285/40/17 rear at the moment,
o/r x-pipe flow master 40 series dump downs, cai/ram intake, 75mm c&l throttle body and plenum, pi heads and intake swap, msd wires, stock gears, untuned at the moment, no dyno numbers for now.
1996mustang is offline   Reply With Quote
Old 11-11-2012, 01:42 PM   #7
Registered User
Newbie
 
Rockpanama's Avatar
 
Join Date: Oct 2012
Region: Indiana
Posts: 5
Thanks for all the advice. I will check it and let you guys know what I find out.
Rockpanama is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:22 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.