Please help this n00b, should be easy... - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-18-2012, 09:59 PM   #1
Registered Member
Regular
 
Join Date: Oct 2012
Region: Florida
Posts: 60
Please help this n00b, should be easy...

Okay... check it.

Got a 96 GT cheap from a dealer (t-boned) but it drove straight as an arrow, and smooth, got it fixed and brought it home.

bought a DOHC off e-bay

swapped it out, and replaced fuel pump, upgraded, etc.

I am trying to fix problems first, before getting it to spec.

I am having a problem with my idle, and driving...

I've narrowed the problems down to being either my fuel pump (has a check valve issue and have to prime everytime I start.) and I have a 24lb MAF with pink tops @ 39 psi vacuum on.

1.) Which would you suspect first?

2.) Has anyone ever ran a car with mis-matched injectors and maf like that ^? If so what does it sound like (It makes it leaner right? but how would it idle if I set my tuner to stock and idle at 510rpm in gear... it seems to me like a weak pump or mis match... if you only had enough money for one thing for a while, which would you start with.

replaced tps, iac, 2 front O2's, egr eliminated (in tune too), 2 new pcv's, good battery, new alternator, ect, replaced with same 24lb maf (free), no vacuum leaks AT ALL. (except where the h-pipe extension meets muffler)

all those parts were working fine on the donor engine. still runing on stock ecu.

I have no idea what happened to my stock maf sensor :}

It idles like its about to die, i lowered the rpm to better hear whats going on, and under heavy load it cuts out, like the engine is off, it goes almost totally silent, very if almost, no popping.. or mis firing
Smokum281 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-19-2012, 10:46 PM   #2
Registered Member
Regular
 
Join Date: Oct 2012
Region: Florida
Posts: 60
BUMP

The car at idle sounds like its running out of gas...

under heavy throttle it goes quiet, very little pop as if it were lean...

---------- Post added at 11:46 PM ---------- Previous post was at 11:45 PM ----------

F*** it, in a week I'll have a 340lph fuel pump...

Its no big deal to have a return system still right?
Smokum281 is offline   Reply With Quote
Old 12-19-2012, 11:09 PM   #3
Registered Member
Regular
 
Coreyw428's Avatar
 
Join Date: Dec 2011
Region: Arkansas
Posts: 430
Which ecu are you running? And do you have a tune? What did the engine come out of?
Coreyw428 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2013, 09:04 PM   #4
Registered Member
Regular
 
Join Date: Oct 2012
Region: Florida
Posts: 60
Ddx3 ... 96 cobra... Sct canned tune for now... My gt harness doesnt supoort the knock sensors on the cobra

---------- Post added at 09:53 PM ---------- Previous post was at 09:52 PM ----------

My regulator was leaking inside.. Engine runs a little better, but still not like the gt... Imrcs are removed but slide is still there

---------- Post added at 09:56 PM ---------- Previous post was at 09:53 PM ----------

Sct canned tuned allows me to reprogram the injects and maf housing size.. Joping its calibrated... Seven tho i set my fuel psi to 51 9r so for now to get flow rate of 24 and cut back the inj slope for my hot cams

---------- Post added at 09:58 PM ---------- Previous post was at 09:56 PM ----------

Alternator regulator replaced .. Same problems

---------- Post added at 09:59 PM ---------- Previous post was at 09:58 PM ----------

When i reset the kan it fired evenly in all inj for a while... Back to a crappy idle... Drone inside makes it sound worse

---------- Post added at 10:01 PM ---------- Previous post was at 09:59 PM ----------

Found trans leak on bottom of radiator, shifts firmer... With stock gap it stumbles every cylinded... Lowered gap to 32 and it doesnt unload as bad.

---------- Post added at 10:01 PM ---------- Previous post was at 10:01 PM ----------

Msd coil packs 8mm wires motorcraft 42c plugs

---------- Post added at 10:02 PM ---------- Previous post was at 10:01 PM ----------

Msd coil packs 8mm wires motorcraft 42c plugs... Cleaned grounds on coil capacitors... No oil in wells... Added a chassis ground.. Better, no cigar.

---------- Post added at 10:04 PM ---------- Previous post was at 10:02 PM ----------

At idle timing jumps from around 14 to around 40

---------- Post added at 10:04 PM ---------- Previous post was at 10:04 PM ----------

At idle timing jumps from around 14 to around 40
Smokum281 is offline   Reply With Quote
Old 02-21-2013, 09:14 PM   #5
Registered Member
Regular
 
Join Date: Oct 2012
Region: Florida
Posts: 60
Learning to datalog... Intake temp for coolant and air intake temps spike momentarily here and there .saw the inlet spike in a straight line to like 200 degreez... A misfiring logged on all cylinders... In the thousands over 360 seconds... Each bank. 2 on each bank really bad... 1 medium on each bank and 1 not so much on each bank.... Everything i logged is all over the place sensor wise... I have good grnd and ohm reading at the ecu in kick panel

---------- Post added at 10:14 PM ---------- Previous post was at 10:10 PM ----------

What unterests me is a saw a needke like spike down to freezing temps then up to 290 degreez or so on my air inlet temp... But the sensor seems okay........... Hmm. Oh and the oscliscope for it on the datalog would be squared to pyrimid like and back and fourth randomly... Dunno if thats signs of a failure...
Smokum281 is offline   Reply With Quote
Old 02-21-2013, 09:24 PM   #6
Registered Member
Regular
 
Join Date: Oct 2012
Region: Florida
Posts: 60
Ill check back after replacenent...got to do brake pads and and fix a suspension issue first.... Drifted late kne night and iver steered over the median... But let the tires roll over after locking them up... That saved. My. ***.

---------- Post added at 10:24 PM ---------- Previous post was at 10:24 PM ----------

Ill check back after replacenent...got to do brake pads and and fix a suspension issue first.... Drifted late kne night and iver steered over the median... But let the tires roll over after locking them up... That saved. My. ***.... Still cant explain the timing issue
Smokum281 is offline   Reply With Quote
Old 02-22-2013, 05:19 AM   #7
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
It's running smoothly now? Consider taking it to a specialized Mustang dyno shop for second diagnosis?
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Old 02-24-2013, 01:19 PM   #8
Registered Member
Regular
 
Join Date: Oct 2012
Region: Florida
Posts: 60
No, not running smoothly.. I kind of feel a signwave like o2s or something wile driving.... Swapped an ecu and harbess from obd1 to obd 2 in a 93 camaro and a same profile cam and the thing purred, just needed to change the fuel air ratio n add timing etc... Im going to try to post freeze frames of my data logs
Smokum281 is offline   Reply With Quote
Old 02-24-2013, 03:23 PM   #9
Registered Member
Regular
 
Slow4V's Avatar
 
Join Date: Feb 2013
Location: Sa
Region: Alabama
Posts: 2,208
Need 24lb injectors also
Slow4V is offline   Reply With Quote
Old 02-24-2013, 03:29 PM   #10
Registered Member
Regular
 
Slow4V's Avatar
 
Join Date: Feb 2013
Location: Sa
Region: Alabama
Posts: 2,208
Need 24lb injectors also
Slow4V is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:37 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.