Just a question? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-28-2013, 09:36 PM   #1
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
Just a question?

My PVC valve has some oil coming from it so I think it may be time to change it but the one on American muscle says 80-01V8? I have an 03 GT so I was wondering would it fit? That's the only one they sell maybe it's universal? Haha idk but here it is

Click image for larger version

Name:	image-2165467369.jpg
Views:	205
Size:	236.2 KB
ID:	88101
Sonicblue11 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-29-2013, 12:27 AM   #2
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
No they changed it to this one.

http://www.latemodelrestoration.com/...raft-Pcv-Valve
jjsg09 is offline   Reply With Quote
Old 01-29-2013, 02:44 PM   #3
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
I have an 03 gt as well and the guy at the parts store have me the wrong PCV valve as well. Mine looks like the link above
BigB227 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-29-2013, 03:29 PM   #4
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
Quote:
Originally Posted by BigB227 View Post
I have an 03 gt as well and the guy at the parts store have me the wrong PCV valve as well. Mine looks like the link above
So is that the wrong one?
Sonicblue11 is offline   Reply With Quote
Old 01-29-2013, 04:35 PM   #5
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
Quote:
Originally Posted by Sonicblue11 View Post

So is that the wrong one?
No the link above is what I needed to buy
BigB227 is offline   Reply With Quote
Old 01-29-2013, 05:34 PM   #6
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
Quote:
Originally Posted by BigB227 View Post

No the link above is what I needed to buy
Okay good I have to get one
Sonicblue11 is offline   Reply With Quote
Old 02-04-2013, 06:19 PM   #7
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
This is on both valve covers right? The left side and right side? My driver side is the one leaking
Sonicblue11 is offline   Reply With Quote
Old 02-04-2013, 07:37 PM   #8
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by Sonicblue11 View Post
This is on both valve covers right? The left side and right side? My driver side is the one leaking
No theres only one and it's on the passenger side under your air intake.
jjsg09 is offline   Reply With Quote
Old 02-04-2013, 07:52 PM   #9
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
Quote:
Originally Posted by jjsg09 View Post

No theres only one and it's on the passenger side under your air intake.
Damn what's the one on the drive side?
Sonicblue11 is offline   Reply With Quote
Old 02-04-2013, 07:57 PM   #10
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Quote:
Originally Posted by Sonicblue11 View Post

Damn what's the one on the drive side?
It's just a hose that goes to your air intake to recirculate air. Pop it off and check the seal on top of the valve cover.
jjsg09 is offline   Reply With Quote
Old 02-04-2013, 08:02 PM   #11
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
Quote:
Originally Posted by jjsg09 View Post

It's just a hose that goes to your air intake to recirculate air. Pop it off and check the seal on top of the valve cover.
Okay thanks! Here is a picture of it anyways
Attached Thumbnails
Click image for larger version

Name:	image-3534485332.jpg
Views:	70
Size:	398.5 KB
ID:	89229  
Sonicblue11 is offline   Reply With Quote
Old 02-04-2013, 08:11 PM   #12
Registered Member
Regular
 
jjsg09's Avatar
 
Join Date: Feb 2011
Region: Indiana
Posts: 1,224
Yea try disconnecting that and from the intake and make sure it's not clogged up.
jjsg09 is offline   Reply With Quote
Old 02-04-2013, 08:13 PM   #13
Registered Member
Regular
 
Sonicblue11's Avatar
 
Join Date: Oct 2011
Location: Williamstown
Region: New Jersey
Posts: 542
Quote:
Originally Posted by jjsg09 View Post
Yea try disconnecting that and from the intake and make sure it's not clogged up.
I will do tmmrw morning!
Sonicblue11 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:52 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.