Need help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-08-2013, 03:23 PM   #1
Registered Member
Regular
 
The grim reaper's Avatar
 
Join Date: Jan 2013
Location: Columbus
Region: Ohio
Posts: 64
Need help

Ok boys this is what's happening I'm getting squeaking like the Alt is going bad so I had some one in the car rev it no squel but when the car is first turned off it sounds like somthing is still spinning for a few seconds it's coming from alternator water pump area and now my cars going stupid it's reving up so hard it's like trying to brake torque its self it's not throwing any codes checked the alternator and battery with a tester it says alt is putting out low volts but it's still charging fine because it has no trouble starting any body got ideals
The grim reaper is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-08-2013, 03:50 PM   #2
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
Try changing the water pump i had a weird noise coming from what seemed to be the alt and turned out to be the water pump. Mine wasn't revving it self just a noise , goodluck
Rich04 is offline   Reply With Quote
Old 02-08-2013, 03:51 PM   #3
Registered Member
Regular
 
The grim reaper's Avatar
 
Join Date: Jan 2013
Location: Columbus
Region: Ohio
Posts: 64
Thanks man how hard is the water pump to do
The grim reaper is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-08-2013, 04:06 PM   #4
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
I did mine in like half or little less. It was annoying getting off i had to beat it with a screw driver and hammer. Buy some antifreeze to top of after.

Oh yeah. I also didn't remove alt before doing it and hada rough time trying to get around it just take it off before hand a lot easier
Rich04 is offline   Reply With Quote
Old 02-08-2013, 04:08 PM   #5
Registered Member
Regular
 
tonyd01gt's Avatar
 
Join Date: Feb 2013
Location: ayden
Region: North Carolina
Posts: 1,065
Hi, water pump is not the hard of a job. 1 hour or there about . Also check your battery, and ICS.
tonyd01gt is offline   Reply With Quote
Old 02-08-2013, 06:53 PM   #6
Registered Member
Regular
 
1996mustang's Avatar
 
Join Date: Jun 2012
Location: Miami
Region: Florida
Posts: 1,013
My opinion change the idler pulley.....common thing that goes bad first
__________________
1996 Mustang GT, 17x9 front and 17x10.5 cobra r replica rims, 255/40/17 front 285/40/17 rear at the moment,
o/r x-pipe flow master 40 series dump downs, cai/ram intake, 75mm c&l throttle body and plenum, pi heads and intake swap, msd wires, stock gears, untuned at the moment, no dyno numbers for now.
1996mustang is offline   Reply With Quote
Old 02-08-2013, 07:04 PM   #7
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
Quote:
Originally Posted by 1996mustang View Post
My opinion change the idler pulley.....common thing that goes bad first
Thats was i did and was still there. Then changed out alt and still there then i listened to it good and decided water pump and there was my problem
Rich04 is offline   Reply With Quote
Old 02-08-2013, 09:24 PM   #8
Registered Member
Regular
 
1996mustang's Avatar
 
Join Date: Jun 2012
Location: Miami
Region: Florida
Posts: 1,013
Quote:
Originally Posted by Rich04 View Post

Thats was i did and was still there. Then changed out alt and still there then i listened to it good and decided water pump and there was my problem
True you have done it and found the problem on yours however op is looking for his so that's y i suggested this first cause everyones problems are diff as well as solutions
__________________
1996 Mustang GT, 17x9 front and 17x10.5 cobra r replica rims, 255/40/17 front 285/40/17 rear at the moment,
o/r x-pipe flow master 40 series dump downs, cai/ram intake, 75mm c&l throttle body and plenum, pi heads and intake swap, msd wires, stock gears, untuned at the moment, no dyno numbers for now.
1996mustang is offline   Reply With Quote
Old 02-08-2013, 09:37 PM   #9
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
Quote:
Originally Posted by 1996mustang View Post

True you have done it and found the problem on yours however op is looking for his so that's y i suggested this first cause everyones problems are diff as well as solutions
Oh no. I wasnt don't try it i was just explaining what I went threw i have a clip of the sound but i have to upload to youtube first right?
Rich04 is offline   Reply With Quote
Old 02-09-2013, 08:48 AM   #10
Registered Member
Regular
 
1996mustang's Avatar
 
Join Date: Jun 2012
Location: Miami
Region: Florida
Posts: 1,013
Quote:
Originally Posted by Rich04 View Post

Oh no. I wasnt don't try it i was just explaining what I went threw i have a clip of the sound but i have to upload to youtube first right?
No u can upload it by forum as well. Or photobucket and share link
__________________
1996 Mustang GT, 17x9 front and 17x10.5 cobra r replica rims, 255/40/17 front 285/40/17 rear at the moment,
o/r x-pipe flow master 40 series dump downs, cai/ram intake, 75mm c&l throttle body and plenum, pi heads and intake swap, msd wires, stock gears, untuned at the moment, no dyno numbers for now.
1996mustang is offline   Reply With Quote
Old 02-09-2013, 11:26 AM   #11
Registered Member
Regular
 
Rich04's Avatar
 
Join Date: Dec 2012
Location: Queens
Region: New York
Posts: 470
http://youtu.be/l7xXOsKQ-TE
Rich04 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:48 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.