Squeaking noise coming from belts - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-25-2013, 12:51 PM   #1
Registered Member
Regular
 
sLbxO143's Avatar
 
Join Date: Oct 2012
Location: Whitman, MA
Region: Massachusetts
Posts: 410
Squeaking noise coming from belts

When I start my car up, I hear squeaking/squealing coming from under my hood, when I popped it today I think it's coming from the belts on the transmission. Would this have anything to do with my battery light coming on randomly and sometimes flashing. I am having an ongoing problem with figuring out the battery light. Never stays on for more than 10 minutes at a time and I got the battery terminal fixed but light still randomly comes on for a minute or two once every 2/3 weeks. And the auto shop that fixed the corroded terminal said it wasn't the transmission. Please help need a sticker this month
sLbxO143 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-25-2013, 12:55 PM   #2
Registered Member
Regular
 
Mfore33's Avatar
 
Join Date: Feb 2012
Location: Murfreesboro
Region: Tennessee
Posts: 540
Most likely the tensioner pulley is weak replace it
Mfore33 is offline   Reply With Quote
Old 02-25-2013, 01:20 PM   #3
Registered Member
Regular
 
Slow4V's Avatar
 
Join Date: Feb 2013
Location: Sa
Region: Alabama
Posts: 2,208
Quote:
Originally Posted by sLbxO143 View Post
When I start my car up, I hear squeaking/squealing coming from under my hood, when I popped it today I think it's coming from the belts on the transmission. Would this have anything to do with my battery light coming on randomly and sometimes flashing. I am having an ongoing problem with figuring out the battery light. Never stays on for more than 10 minutes at a time and I got the battery terminal fixed but light still randomly comes on for a minute or two once every 2/3 weeks. And the auto shop that fixed the corroded terminal said it wasn't the transmission. Please help need a sticker this month
Need a new belt
Slow4V is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-25-2013, 01:21 PM   #4
Registered Member
Regular
 
sLbxO143's Avatar
 
Join Date: Oct 2012
Location: Whitman, MA
Region: Massachusetts
Posts: 410
I'm sorry I'm not unaware of what that is. How much would it be to replace it?
sLbxO143 is offline   Reply With Quote
Old 02-25-2013, 01:36 PM   #5
Registered Member
Regular
 
Mfore33's Avatar
 
Join Date: Feb 2012
Location: Murfreesboro
Region: Tennessee
Posts: 540
I think mine was 25 or so easy to replace. Won't hurt to get a new belt also
Mfore33 is offline   Reply With Quote
Old 02-25-2013, 01:54 PM   #6
Registered Member
Regular
 
sLbxO143's Avatar
 
Join Date: Oct 2012
Location: Whitman, MA
Region: Massachusetts
Posts: 410
Quote:
Originally Posted by Mfore33 View Post
I think mine was 25 or so easy to replace. Won't hurt to get a new belt also
What belt would I need? These may be really stupid questions and I'm sorry in advanced lol

---------- Post added at 02:54 PM ---------- Previous post was at 02:53 PM ----------

And the noise doesn't happen when I'm driving just on start-up. And would this be related to my battery light sometimes coming on?
sLbxO143 is offline   Reply With Quote
Old 02-25-2013, 01:55 PM   #7
Registered Member
Regular
 
tonyd01gt's Avatar
 
Join Date: Feb 2013
Location: ayden
Region: North Carolina
Posts: 1,065
Squeaking noise coming from belts

Quote:
Originally Posted by sLbxO143 View Post
I'm sorry I'm not unaware of what that is. How much would it be to replace it?
Hi, i agree most likely your tensioner is getting weak. When you change it you also need to change your serpentine belt. Do you have a Ford service manual or Chilton ? It will show you where the tensioner is. And also how to change it along with the belt. Not a hard job.
tonyd01gt is offline   Reply With Quote
Old 02-25-2013, 01:56 PM   #8
Registered Member
Regular
 
Mfore33's Avatar
 
Join Date: Feb 2012
Location: Murfreesboro
Region: Tennessee
Posts: 540
There is no stupid question. No problem. If there is a autozone advanced auto or oriley's near you just go to one of those places and tell them you need a belt for you year and model mustang and they will look it up for you.
Mfore33 is offline   Reply With Quote
Old 02-25-2013, 02:26 PM   #9
Registered Member
Regular
 
fomoco4life's Avatar
 
Join Date: Aug 2012
Location: Antioch
Region: California
Posts: 839
You can also just buy some belt dressing and squirt on the belt C ifit quiets down. Could be your idler pulley2 , mines squeekn right now only when car is cold
fomoco4life is offline   Reply With Quote
Old 02-25-2013, 03:00 PM   #10
Registered Member
Regular
 
sLbxO143's Avatar
 
Join Date: Oct 2012
Location: Whitman, MA
Region: Massachusetts
Posts: 410
Took it to my autobody shop they said the belt was all dry and cracked so they are going to replace that for me and also check the pulleys. They said that the belt could be causing the light to come on because when I take off from a red light the belt doesn't catch quick enough which will result in battery light to come on for some reason.
sLbxO143 is offline   Reply With Quote
Old 02-25-2013, 03:07 PM   #11
Registered Member
Regular
 
Slow4V's Avatar
 
Join Date: Feb 2013
Location: Sa
Region: Alabama
Posts: 2,208
Quote:
Originally Posted by sLbxO143 View Post
Took it to my autobody shop they said the belt was all dry and cracked so they are going to replace that for me and also check the pulleys. They said that the belt could be causing the light to come on because when I take off from a red light the belt doesn't catch quick enough which will result in battery light to come on for some reason.
Yup
Slow4V is offline   Reply With Quote
Old 02-25-2013, 03:08 PM   #12
Registered Member
Regular
 
sLbxO143's Avatar
 
Join Date: Oct 2012
Location: Whitman, MA
Region: Massachusetts
Posts: 410
Quote:
Originally Posted by Slow4V View Post

Yup
So I'm hoping this will fix the problem finally, this battery light has been haunting me lol. Thank you for all you guys help I always appreciate the support on ME
sLbxO143 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:32 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.