Fuel issue - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-03-2013, 02:45 PM   #1
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Fuel issue

Okay just got my car and got a issue at high Rpms I'm losing power I'm thinkin its a loss of gas
336badboy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-04-2013, 09:45 AM   #2
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Well today it shut off n not cranking I think imma take off filter n see if line clogged
336badboy is offline   Reply With Quote
Old 03-05-2013, 12:41 PM   #3
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Fuel pump shot but suppose to be a new one
336badboy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-06-2013, 05:34 PM   #4
Registered Member
Regular
 
Cornkush's Avatar
 
Join Date: Mar 2013
Location: Indianapolis
Region: Indiana
Posts: 171
with the car sitting ther push the fuel pressure release valve ( small valve stem similar to a tire) on the fuel rail and see if it has fuel pressure keep a rag around for obvious reasons. if it has pressure sitting off then try it with the key in th run/start postion the pump should be pressurized. still has pressure then pump is functioning.

---------- Post added at 06:34 PM ---------- Previous post was at 06:31 PM ----------

ah just saw last post sorry
Cornkush is offline   Reply With Quote
Old 03-06-2013, 08:38 PM   #5
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Quote:
Originally Posted by Cornkush View Post
with the car sitting ther push the fuel pressure release valve ( small valve stem similar to a tire) on the fuel rail and see if it has fuel pressure keep a rag around for obvious reasons. if it has pressure sitting off then try it with the key in th run/start postion the pump should be pressurized. still has pressure then pump is functioning.

---------- Post added at 06:34 PM ---------- Previous post was at 06:31 PM ----------

ah just saw last post sorry
Thanks I'm still gonna checc cause I'm working solo
336badboy is offline   Reply With Quote
Old 03-07-2013, 01:30 AM   #6
Registered Member
Regular
 
Cornkush's Avatar
 
Join Date: Mar 2013
Location: Indianapolis
Region: Indiana
Posts: 171
Same thing I'm currently dealing with fuel pump
Cornkush is offline   Reply With Quote
Old 03-07-2013, 09:01 AM   #7
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Quote:
Originally Posted by Cornkush View Post
Same thing I'm currently dealing with fuel pump
So yours is shot as well
336badboy is offline   Reply With Quote
Old 03-07-2013, 09:19 AM   #8
Registered Member
Regular
 
Cornkush's Avatar
 
Join Date: Mar 2013
Location: Indianapolis
Region: Indiana
Posts: 171
Yes and it's had a rod bearing that is knocking as well
Cornkush is offline   Reply With Quote
Old 03-07-2013, 10:52 AM   #9
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
was gonna say check the fuel pump voltage and see if it is bad at higher rpms
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Old 03-07-2013, 11:07 AM   #10
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Quote:
Originally Posted by SpectorV View Post
was gonna say check the fuel pump voltage and see if it is bad at higher rpms
That's how it was but now I'm getting no gas to engine whatsoever

---------- Post added at 12:07 PM ---------- Previous post was at 12:05 PM ----------

Quote:
Originally Posted by Cornkush View Post
Yes and it's had a rod bearing that is knocking as well
Damn I'm checcin on another engine now the one I got is fine but I want another ready for boost but then again I'm taking it from auto to manual
336badboy is offline   Reply With Quote
Old 03-08-2013, 10:26 AM   #11
Registered Member
Regular
 
Cornkush's Avatar
 
Join Date: Mar 2013
Location: Indianapolis
Region: Indiana
Posts: 171
Ever get the pump?
Cornkush is offline   Reply With Quote
Old 03-08-2013, 10:33 AM   #12
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Quote:
Originally Posted by Cornkush View Post
Ever get the pump?
Getting today checcing around or prices
336badboy is offline   Reply With Quote
Old 03-08-2013, 11:03 AM   #13
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
On top of that I just locced keys in the car wtf
336badboy is offline   Reply With Quote
Old 03-08-2013, 11:03 AM   #14
Registered Member
Regular
 
Cornkush's Avatar
 
Join Date: Mar 2013
Location: Indianapolis
Region: Indiana
Posts: 171
Coat hanger
Cornkush is offline   Reply With Quote
Old 03-08-2013, 11:17 AM   #15
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Quote:
Originally Posted by Cornkush View Post
Coat hanger
Sadly battery dead smh
336badboy is offline   Reply With Quote
Old 03-08-2013, 11:24 AM   #16
Registered Member
Regular
 
Cornkush's Avatar
 
Join Date: Mar 2013
Location: Indianapolis
Region: Indiana
Posts: 171
Ah sorry to hear that lol I have billet door locks so i can always grab em with a hanger if I have too lol
Cornkush is offline   Reply With Quote
Old 03-08-2013, 11:24 AM   #17
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Smh my bro got in convertibles might not be the way to go
336badboy is offline   Reply With Quote
Old 03-08-2013, 12:27 PM   #18
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Just got it $109.99
336badboy is offline   Reply With Quote
Old 03-09-2013, 01:25 AM   #19
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Fixed it but now new issue tires dry rott and gastank has a major leak
336badboy is offline   Reply With Quote
Old 03-09-2013, 10:33 AM   #20
Registered Member
Regular
 
Cornkush's Avatar
 
Join Date: Mar 2013
Location: Indianapolis
Region: Indiana
Posts: 171
Where did you get one for 109? But sorry to hear that
Cornkush is offline   Reply With Quote
Old 03-09-2013, 04:01 PM   #21
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Yea got new tires the gas tank leaks on side where top and bottom connect, and I got it from auto zone orileys was the same price just not in stocc
336badboy is offline   Reply With Quote
Old 03-09-2013, 04:13 PM   #22
Registered Member
Regular
 
ksrumbel's Avatar
 
Join Date: Feb 2011
Location: Hamburg
Region: Pennsylvania
Posts: 483
I just tried to start mine today after having it garaged since November... No fuel pressure also. Looks like I will be dropping the tank tomorrow to change the pump.
ksrumbel is offline   Reply With Quote
Old 03-09-2013, 06:32 PM   #23
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Quote:
Originally Posted by ksrumbel View Post
I just tried to start mine today after having it garaged since November... No fuel pressure also. Looks like I will be dropping the tank tomorrow to change the pump.
First make sure ya switch is pushed down n didn't reset
336badboy is offline   Reply With Quote
Old 03-09-2013, 07:08 PM   #24
Registered Member
Regular
 
ksrumbel's Avatar
 
Join Date: Feb 2011
Location: Hamburg
Region: Pennsylvania
Posts: 483
Quote:
Originally Posted by 336badboy View Post

First make sure ya switch is pushed down n didn't reset
I'm not really sure what you mean by that.
ksrumbel is offline   Reply With Quote
Old 03-09-2013, 07:23 PM   #25
Registered Member
Regular
 
ksrumbel's Avatar
 
Join Date: Feb 2011
Location: Hamburg
Region: Pennsylvania
Posts: 483
Quote:
Originally Posted by 336badboy View Post

First make sure ya switch is pushed down n didn't reset
I just read up on what you were referring to. The inertia switch. What would cause that to trip? I've read usually accidents.
ksrumbel is offline   Reply With Quote
Old 03-09-2013, 07:34 PM   #26
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Quote:
Originally Posted by ksrumbel View Post

I just read up on what you were referring to. The inertia switch. What would cause that to trip? I've read usually accidents.
I have had systems flip mine n hard spots in the road,
336badboy is offline   Reply With Quote
Old 03-10-2013, 08:51 AM   #27
Registered Member
Regular
 
ksrumbel's Avatar
 
Join Date: Feb 2011
Location: Hamburg
Region: Pennsylvania
Posts: 483
Quote:
Originally Posted by 336badboy View Post

I have had systems flip mine n hard spots in the road,
I'm going to have to check that out today. I don't know why it would have flipped. The car ran when I parked it for the winter and now it doesn't want to start.
ksrumbel is offline   Reply With Quote
Old 03-10-2013, 10:23 AM   #28
Registered Member
Regular
 
02 360R's Avatar
 
Join Date: Jul 2012
Region: Mississippi
Posts: 306
Quote:
Originally Posted by ksrumbel View Post

I'm going to have to check that out today. I don't know why it would have flipped. The car ran when I parked it for the winter and now it doesn't want to start.
I knew a lady that parked her focus in a driveway that was steep for about an hour and when she tried to leave, the car won't start. The switched flipped. What's strange is she parks there all the time. Just this time, the switch flipped. Thanks to roadside, otherwise, she was getting it towed back to the Ford dealership.
02 360R is offline   Reply With Quote
Old 03-10-2013, 10:38 AM   #29
Registered Member
Regular
 
ksrumbel's Avatar
 
Join Date: Feb 2011
Location: Hamburg
Region: Pennsylvania
Posts: 483
Quote:
Originally Posted by 02 360R View Post

I knew a lady that parked her focus in a driveway that was steep for about an hour and when she tried to leave, the car won't start. The switched flipped. What's strange is she parks there all the time. Just this time, the switch flipped. Thanks to roadside, otherwise, she was getting it towed back to the Ford dealership.
I check the switch. It seemed to be pushed down all the way. So I am left scratching my head. The car ran fine before I parked it for the winter. I don't know why the pump would just go bad from sitting.
ksrumbel is offline   Reply With Quote
Old 03-10-2013, 11:50 AM   #30
Registered Member
Regular
 
336badboy's Avatar
 
Join Date: Feb 2013
Location: Burlington
Region: North Carolina
Posts: 37
Quote:
Originally Posted by ksrumbel View Post

I check the switch. It seemed to be pushed down all the way. So I am left scratching my head. The car ran fine before I parked it for the winter. I don't know why the pump would just go bad from sitting.
Maybe its the relay I'm not sure mine was covered with trash and now its acting up again and I just put the new one in two days ago I think its more than just some trash in the tank
336badboy is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:04 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.