Low coolant light staying on - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-09-2013, 08:48 PM   #1
Registered Member
Regular
 
35th GT's Avatar
 
Join Date: Feb 2013
Location: Campti
Region: Louisiana
Posts: 57
Low coolant light staying on

It's full of coolant, not running hot or doing anything abnormal. The light is just kind of annoying. Anyway of clearing this myself? The only weird thing is after I take a long trip say if the car has been driven for a hour straight when I get out I can hear the cap sizzling. But nothing is leaking and the coolant is staying full. This is a 99 GT
35th GT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-09-2013, 08:59 PM   #2
Moderator Emeritus
Regular
 
deadsp0t's Avatar
 
Join Date: Aug 2011
Location: MidWorld
Region: Other
Posts: 4,786
Mine only comes on when the reservoir tank is low, the tank will be low and the radiator will be full on mine and the light will come on. I fill the tank above the cold line and the light goes off.. I don't know any other way to 'clear' the light.
__________________
That's unimpressive
deadsp0t is offline   Reply With Quote
Old 03-09-2013, 09:03 PM   #3
Registered Member
Regular
 
SilverPonyGT's Avatar
 
Join Date: Jan 2013
Location: St. Louis
Region: Missouri
Posts: 105
Mine does the same thing it comes on then goes away and after the car sits it turns off but coolant is always full
SilverPonyGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-09-2013, 09:05 PM   #4
Registered Member
Regular
 
35th GT's Avatar
 
Join Date: Feb 2013
Location: Campti
Region: Louisiana
Posts: 57
Quote:
Originally Posted by SilverPonyGT View Post
Mine does the same thing it comes on then goes away and after the car sits it turns off but coolant is always full
Mine never goes off its constantly on though, it's annoying
35th GT is offline   Reply With Quote
Old 03-09-2013, 09:45 PM   #5
Registered Member
Regular
 
tonyd01gt's Avatar
 
Join Date: Feb 2013
Location: ayden
Region: North Carolina
Posts: 1,065
Low coolant light stay on

Quote:
Originally Posted by 35th GT View Post
Mine never goes off its constantly on though, it's annoying
The coolant sensor is bad in your reservoir.
tonyd01gt is offline   Reply With Quote
Old 03-09-2013, 10:07 PM   #6
Registered Member
Regular
 
35th GT's Avatar
 
Join Date: Feb 2013
Location: Campti
Region: Louisiana
Posts: 57
Quote:
Originally Posted by tonyd01gt View Post
The coolant sensor is bad in your reservoir.
I'll get it checked out thanks man
35th GT is offline   Reply With Quote
Old 03-09-2013, 10:13 PM   #7
Registered Member
Regular
 
tonyd01gt's Avatar
 
Join Date: Feb 2013
Location: ayden
Region: North Carolina
Posts: 1,065
Look inside of the reservoir. You should be able to see the sensor. It probably is covered in some type of slim/rust. Causing your coolant light to stay on. Try clean it out. Maybe able to get enough out to get it working right. If not you will need another reservoir.
tonyd01gt is offline   Reply With Quote
Old 03-09-2013, 10:32 PM   #8
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
Wired because when my intake manifold had a leak it would lea all my coolant and I never had a light come on
BigB227 is offline   Reply With Quote
Old 03-10-2013, 01:29 AM   #9
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
I have the same problem it's on and it's annoying
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 03-10-2013, 03:07 AM   #10
Registered Member
Regular
 
bobsurvives's Avatar
 
Join Date: Apr 2011
Region: California
Posts: 216
lol mine has been stuck on forever too, too broke and lazy to buy another reservoir
bobsurvives is offline   Reply With Quote
Old 03-10-2013, 08:36 AM   #11
Registered Member
Regular
 
onesickstang01's Avatar
 
Join Date: May 2011
Posts: 441
Usually the float gets gunked up and doesnt float anymore. Clean the reservoir up and actuate the float up and down with a screw driver. Its a two wire connector so you can jump the two wires to turn the light off
onesickstang01 is offline   Reply With Quote
Old 03-10-2013, 10:49 AM   #12
Registered Member
Regular
 
35th GT's Avatar
 
Join Date: Feb 2013
Location: Campti
Region: Louisiana
Posts: 57
Quote:
Originally Posted by onesickstang01 View Post
Usually the float gets gunked up and doesnt float anymore. Clean the reservoir up and actuate the float up and down with a screw driver. Its a two wire connector so you can jump the two wires to turn the light off
That was the problem I drained the tank and moved the float around with a screw driver and the light is now off.. Thank all of y'all for the help hopefully I won't run into anymore problems for a while
35th GT is offline   Reply With Quote
Old 03-10-2013, 03:09 PM   #13
Registered Member
Regular
 
35th GT's Avatar
 
Join Date: Feb 2013
Location: Campti
Region: Louisiana
Posts: 57
The light came back on lol I guess the float is broke.. Looks like ill be buying a new over flow tank
35th GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:14 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.