Weird Idle - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-19-2013, 11:54 AM   #1
Registered Member
Regular
 
MineralGrayGT's Avatar
 
Join Date: Aug 2012
Region: Wyoming
Posts: 133
Weird Idle

So my car drives fine just every once in a while while im driving if i put my clutch in or am just sitting at a light my rpms will either jump up a bit or stay at like 1100 or 1200 rpm and has an odd noise while doing it and i cant really explain the noise. Any ideas on what it could be?
MineralGrayGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-19-2013, 12:29 PM   #2
Registered Member
Regular
 
Mustang936's Avatar
 
Join Date: Mar 2012
Region: Texas
Posts: 406
Check you idle air control valve, that has a lot to do with rpms at idle, there's a nice tutorial on YouTube on how to clean it.
Mustang936 is offline   Reply With Quote
Old 03-19-2013, 02:15 PM   #3
Registered Member
Regular
 
Mfore33's Avatar
 
Join Date: Feb 2012
Location: Murfreesboro
Region: Tennessee
Posts: 540
I second that +100
Mfore33 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-19-2013, 03:33 PM   #4
Registered Member
Regular
 
v8pony's Avatar
 
Join Date: Aug 2012
Location: Monmouth County, New Jersey
Region: New Jersey
Posts: 2,201
Had the same problem, I cleaned my MAF sensor, cleaned my TB, cleaned my iac, and seafoamed the engine, idle is smooth as smooth can be, and has stayed like that for 6+ months now
__________________
2002 5spd GT
Feb 2013 Mustang of the Month
v8pony is offline   Reply With Quote
Old 03-19-2013, 03:41 PM   #5
Registered Member
Regular
 
MineralGrayGT's Avatar
 
Join Date: Aug 2012
Region: Wyoming
Posts: 133
Awesome. Thanks guys ill will check all those possibilities!
MineralGrayGT is offline   Reply With Quote
Old 03-19-2013, 04:06 PM   #6
Registered Member
Regular
 
CAMARO_KILLA's Avatar
 
Join Date: Sep 2012
Region: North Carolina
Posts: 56
Quote:
Originally Posted by MineralGrayGT View Post
So my car drives fine just every once in a while while im driving if i put my clutch in or am just sitting at a light my rpms will either jump up a bit or stay at like 1100 or 1200 rpm and has an odd noise while doing it and i cant really explain the noise. Any ideas on what it could be?
if its not any of those i had the same problem and it just ended up being a leak in my PCV valve. got a new one and it was
fine
CAMARO_KILLA is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:00 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.