Need some help!! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-01-2013, 04:22 PM   #1
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
Question Need some help!!

I have a constant code P0174 that keeps popping up and refuses to go away. I experience no driveability problems and nothing other then the annoying check engine light. The code reads "System too lean Bank 2" I have cleaned my mass airflow sensor due to the oil from the air filter oil. light is still there. i replaced both upstream O2 sensors and the light came back. As far as i can tell or hear i do not think that i have a vaccuum leak anywhere. I have replaced the fuel filter and fuel pump(which needed replacing due to failing on me) and still this code appears. I am completely lost at what else there is i can do. Im also tired of throwing money and "hoping" that it fixes it. Does anyone here have any advice or experience into something that is causing it?
BigB227 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-01-2013, 04:27 PM   #2
Registered Member
Regular
 
Join Date: Sep 2012
Region: Louisiana
Posts: 64
Had this same problem on my 08. Look at your camshaft position sensors. They are known to go bad on pre 05 mustangs. Also check your oil level. My oil was running low and threw that same code until I corrected my oil level.
jazzystang is offline   Reply With Quote
Old 04-01-2013, 04:29 PM   #3
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
hmmmm i hadnt thought about that, Thank you very much! i will check both and post an update later if these are fixes to the problem
BigB227 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-01-2013, 04:37 PM   #4
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
Might be a dumb question but is there only one camshaft position sensor or two??
BigB227 is offline   Reply With Quote
Old 04-01-2013, 05:01 PM   #5
Registered Member
Regular
 
Join Date: Sep 2012
Region: Louisiana
Posts: 64
It should be two. And they are fairly cheap at parts stores. Usually about $20 each.
jazzystang is offline   Reply With Quote
Old 04-01-2013, 08:51 PM   #6
Registered Member
Regular
 
BigB227's Avatar
 
Join Date: Aug 2011
Location: West Palm Beach
Region: Florida
Posts: 1,120
Quote:
Originally Posted by jazzystang View Post
It should be two. And they are fairly cheap at parts stores. Usually about $20 each.
Alright thank you )
BigB227 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:04 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.