I have a problem - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-02-2013, 02:49 PM   #1
Registered Member
Regular
 
Krisis187's Avatar
 
Join Date: Jan 2013
Location: Las Vegas
Region: Nevada
Posts: 92
I have a problem

2001 mustang gt


It has a service engine light on abs light and fuel cap.

And it's saying......


1.bank one running too rich

2.bank 2 running too rich

3.and I smell gas

4.cuts off a lot especially when I get new gas

Any thing I can do my self I'm broke??
Krisis187 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-02-2013, 05:56 PM   #2
Registered Member
Regular
 
Jord05's Avatar
 
Join Date: Feb 2012
Region: Canada
Posts: 185
Check your fuses under your dash I had one blown causing the same problem don't remember which one tho
Jord05 is offline   Reply With Quote
Old 05-02-2013, 09:51 PM   #3
Registered Member
Regular
 
Krisis187's Avatar
 
Join Date: Jan 2013
Location: Las Vegas
Region: Nevada
Posts: 92
Ima check that
Krisis187 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1996-2004 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



03:28 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.